aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:05:43 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:05:43 +0000
commit2ebcebda66d2e0659a8c2b167542e1e5fa6038aa (patch)
tree0f0e15abe0edfe1467a873290f8c280409ebd4b3
parent384d8cf12dd07f4dd698b40fa21702542dfeeb63 (diff)
downloadports-2ebcebda66d2e0659a8c2b167542e1e5fa6038aa.tar.gz
ports-2ebcebda66d2e0659a8c2b167542e1e5fa6038aa.zip
net/py-softlayer: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
-rw-r--r--net/py-softlayer/Makefile5
-rw-r--r--net/py-softlayer/files/patch-setup.py9
2 files changed, 13 insertions, 1 deletions
diff --git a/net/py-softlayer/Makefile b/net/py-softlayer/Makefile
index f2d28683cc1f..0884b54fadb4 100644
--- a/net/py-softlayer/Makefile
+++ b/net/py-softlayer/Makefile
@@ -1,5 +1,6 @@
PORTNAME= softlayer
PORTVERSION= 6.1.11
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,6 +13,8 @@ WWW= https://github.com/softlayer/softlayer-python
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>=8.0.4:devel/py-click@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}prettytable>=2.5.0:devel/py-prettytable@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}prompt-toolkit>=2:devel/py-prompt-toolkit@${PY_FLAVOR} \
@@ -21,7 +24,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>=8.0.4:devel/py-click@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}urllib3>=1.24,1:net/py-urllib3@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
diff --git a/net/py-softlayer/files/patch-setup.py b/net/py-softlayer/files/patch-setup.py
index dc754ab85104..41247f1c2033 100644
--- a/net/py-softlayer/files/patch-setup.py
+++ b/net/py-softlayer/files/patch-setup.py
@@ -1,5 +1,14 @@
--- setup.py.orig 2023-12-20 21:04:33 UTC
+++ setup.py
+@@ -14,7 +14,7 @@ setup(
+ LONG_DESCRIPTION = DESCRIPTION
+
+ setup(
+- name='SoftLayer',
++ name='softlayer',
+ version='v6.1.11',
+ description=DESCRIPTION,
+ long_description=LONG_DESCRIPTION,
@@ -39,7 +39,7 @@ setup(
'prompt_toolkit >= 2',
'pygments >= 2.0.0',