aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2015-12-01 19:43:02 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2015-12-01 19:43:02 +0000
commit2ed3b91c0ee70eadc0bec8aa2bef39aba44409df (patch)
treef95f48c930f4ff876e48b0e321b60da6c2bb37c2
parent126034be610d4fcfddc5d27a92654b49fc5c7cc0 (diff)
downloadports-2ed3b91c0ee70eadc0bec8aa2bef39aba44409df.tar.gz
ports-2ed3b91c0ee70eadc0bec8aa2bef39aba44409df.zip
Phototonic is a fast and functional image viewer and organizer, inspired
by the traditional image viewer design (i.e. thumbnails and viewer layouts). WWW: http://oferkv.github.io/phototonic/
Notes
Notes: svn path=/head/; revision=402780
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/phototonic/Makefile26
-rw-r--r--graphics/phototonic/distinfo2
-rw-r--r--graphics/phototonic/files/patch-phototonic.pro27
-rw-r--r--graphics/phototonic/pkg-descr5
-rw-r--r--graphics/phototonic/pkg-plist5
6 files changed, 66 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 3fc98bd98a3f..522ed21522f1 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -756,6 +756,7 @@
SUBDIR += pgplot
SUBDIR += pho
SUBDIR += photopc
+ SUBDIR += phototonic
SUBDIR += php-facedetect
SUBDIR += php-gdal
SUBDIR += php-libpuzzle
diff --git a/graphics/phototonic/Makefile b/graphics/phototonic/Makefile
new file mode 100644
index 000000000000..ca0680bfecb0
--- /dev/null
+++ b/graphics/phototonic/Makefile
@@ -0,0 +1,26 @@
+# Created by: Olivier Duchateau
+# $FreeBSD$
+
+PORTNAME= phototonic
+PORTVERSION= 1.7
+DISTVERSIONPREFIX= v
+CATEGORIES= graphics
+
+MAINTAINER= olivierd@FreeBSD.org
+COMMENT= Image viewer and organizer
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libexiv2.so:${PORTSDIR}/graphics/exiv2
+
+USE_GITHUB= yes
+GH_ACCOUNT= oferkv
+
+USES= desktop-file-utils gettext qmake
+USE_QT5= buildtools_build imageformats svg widgets
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ ${WRKSRC}/phototonic.pro
+
+.include <bsd.port.mk>
diff --git a/graphics/phototonic/distinfo b/graphics/phototonic/distinfo
new file mode 100644
index 000000000000..c6cf4d46de21
--- /dev/null
+++ b/graphics/phototonic/distinfo
@@ -0,0 +1,2 @@
+SHA256 (oferkv-phototonic-v1.7_GH0.tar.gz) = ef194d41e71b4d50e347f56da27a2e5d00a86f4ba4ff6580f86852df475f39df
+SIZE (oferkv-phototonic-v1.7_GH0.tar.gz) = 284334
diff --git a/graphics/phototonic/files/patch-phototonic.pro b/graphics/phototonic/files/patch-phototonic.pro
new file mode 100644
index 000000000000..cab972558eb4
--- /dev/null
+++ b/graphics/phototonic/files/patch-phototonic.pro
@@ -0,0 +1,27 @@
+--- phototonic.pro.orig 2015-11-08 18:03:52 UTC
++++ phototonic.pro
+@@ -17,19 +17,19 @@ SOURCES += dialogs.cpp main.cpp mainwind
+ mdcache.cpp
+ RESOURCES += phototonic.qrc
+
+-target.path = /usr/bin/
++target.path = %%PREFIX%%/bin/
+
+ icon.files = images/phototonic.png
+-icon.path = /usr/share/icons/hicolor/48x48/apps
++icon.path = %%PREFIX%%/share/icons/hicolor/48x48/apps
+
+ icon16.files = images/icon16/phototonic.png
+-icon16.path = /usr/share/icons/hicolor/16x16/apps
++icon16.path = %%PREFIX%%/share/icons/hicolor/16x16/apps
+
+ iconPixmaps.files = images/icon16/phototonic.png
+-iconPixmaps.path = /usr/share/pixmaps
++iconPixmaps.path = %%PREFIX%%/share/pixmaps
+
+ desktop.files = phototonic.desktop
+-desktop.path = /usr/share/applications
++desktop.path = %%PREFIX%%/share/applications
+
+ INSTALLS += target icon icon16 iconPixmaps desktop
+
diff --git a/graphics/phototonic/pkg-descr b/graphics/phototonic/pkg-descr
new file mode 100644
index 000000000000..709551002d24
--- /dev/null
+++ b/graphics/phototonic/pkg-descr
@@ -0,0 +1,5 @@
+Phototonic is a fast and functional image viewer and organizer, inspired
+by the traditional image viewer design (i.e. thumbnails and viewer
+layouts).
+
+WWW: http://oferkv.github.io/phototonic/
diff --git a/graphics/phototonic/pkg-plist b/graphics/phototonic/pkg-plist
new file mode 100644
index 000000000000..644036f1d8e3
--- /dev/null
+++ b/graphics/phototonic/pkg-plist
@@ -0,0 +1,5 @@
+bin/phototonic
+share/applications/phototonic.desktop
+share/icons/hicolor/16x16/apps/phototonic.png
+share/icons/hicolor/48x48/apps/phototonic.png
+share/pixmaps/phototonic.png