aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-11-29 13:25:39 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-11-29 13:30:55 +0000
commit2f100b71cdbc2484401088f5e4325fe5d95a394e (patch)
tree72e79eef81f3c9436a6a23609beb5f896464d9da
parent08d02b28042725a9355067a50d1fd6ce0e07b26d (diff)
downloadports-2f100b71cdbc2484401088f5e4325fe5d95a394e.tar.gz
ports-2f100b71cdbc2484401088f5e4325fe5d95a394e.zip
www/typo3-10: Cleanup
- Requires php74 which was EOL on 2022-11-28 Sponsored by: Bounce Experts
-rw-r--r--MOVED1
-rw-r--r--www/Makefile1
-rw-r--r--www/typo3-10/Makefile100
-rw-r--r--www/typo3-10/distinfo3
-rw-r--r--www/typo3-10/files/pkg-message.in24
-rw-r--r--www/typo3-10/pkg-descr19
6 files changed, 1 insertions, 147 deletions
diff --git a/MOVED b/MOVED
index 0e0b26eb7262..f388aeac4c2e 100644
--- a/MOVED
+++ b/MOVED
@@ -17617,3 +17617,4 @@ net/libutp|net-p2p/libutp|2022-11-20|Moved to a more adequated category
x11-wm/sway-devel|x11-wm/sway|2022-11-26|Out of date: use x11-wm/sway for now
math/suitesparse-slip_lu|math/suitesparse-spex|2022-11-26|Renamed by upstream
graphics/giblib||2022-11-27|Has expired: Last release in 2004, abandoned upstream, not used, website disappeared
+www/typo3-10||2022-11-29|Requires php74 which was EOL on 2022-11-28
diff --git a/www/Makefile b/www/Makefile
index 4350f0cb660e..a38edd68cb65 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -2307,7 +2307,6 @@
SUBDIR += twiki-TwistyPlugin
SUBDIR += twiki-WysiwygPlugin
SUBDIR += twms
- SUBDIR += typo3-10
SUBDIR += typo3-11
SUBDIR += uchiwa
SUBDIR += ufdbguard
diff --git a/www/typo3-10/Makefile b/www/typo3-10/Makefile
deleted file mode 100644
index ff4503171ea7..000000000000
--- a/www/typo3-10/Makefile
+++ /dev/null
@@ -1,100 +0,0 @@
-PORTNAME= typo3
-PORTVERSION= ${PORT_V_MAJOR}.${PORT_V_MINOR}.${PORT_V_PATCH}
-CATEGORIES= www
-MASTER_SITES= https://typo3.azureedge.net/typo3/${PORTVERSION}/
-PKGNAMESUFFIX= -${PORT_V_MAJOR}${PHP_PKGNAMESUFFIX}
-DISTNAME= ${TYPO3SRC}
-
-MAINTAINER= freebsd-ports@charlieroot.de
-COMMENT= Typo3 content management system
-WWW= https://typo3.org/
-
-LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-
-DEPRECATED= Requires php 7.4 which is set to expire on 2022-11-29
-EXPIRATION_DATE=2022-11-28
-
-IGNORE_WITH_PHP= 80 81 82
-IGNORE_WITH_MYSQL= 101m
-
-USES= cpe php:web,flavors shebangfix
-USE_PHP= ctype dom fileinfo filter hash intl json openssl pcre session simplexml \
- spl tokenizer xml zip
-
-WRKSRC= ${WRKDIR}/${TYPO3SRC}
-NO_BUILD= yes
-NO_ARCH= yes
-SHEBANG_GLOB= *.sh *.php
-PORTSCOUT= limit:^${PORT_V_MAJOR}\.${PORT_V_MINOR}\.
-
-PORT_V_MAJOR= 10
-PORT_V_MINOR= 4
-PORT_V_PATCH= 32
-
-TYPO3WWW= www
-TYPO3SRC= ${PORTNAME}_src-${PORTVERSION}
-TYPO3DIR= ${PORTNAME}-${PORT_V_MAJOR}
-
-USERS= ${WWWOWN}
-GROUPS= ${WWWGRP}
-
-SUB_FILES= pkg-message
-SUB_LIST+= PREFIX=${PREFIX} \
- TYPO3WWW=${TYPO3WWW} \
- TYPO3DIR=${TYPO3DIR}
-
-OPTIONS_DEFINE= CURL GD GMP IMAGICK MBSTRING MYSQL POSTGRES SQLSRV SQLITE ZLIB
-OPTIONS_DEFAULT=MYSQL
-GD_DESC= GDlib/freetype support
-IMAGICK_DESC= ${IMAGEMAGICK_DESC}
-MBSTRING_DESC= ${MULTIBYTE_DESC}
-MYSQL_DESC= Use MySQL as DBMS
-POSTGRES_DESC= Use PostgreSQL as DBMS
-SQLITE_DESC= Use SQLite as DBMS
-SQLSRV_DESC= Use MSSQL as DBMS
-
-CURL_USE= PHP=curl
-GD_USE= PHP=gd
-GMP_USE= PHP=gmp
-MBSTRING_USE= PHP=mbstring
-MYSQL_USE= PHP=mysqli
-POSTGRES_USE= PHP=postgresql
-SQLSRV_USE= PHP=sqlsrv
-SQLITE_USE= PHP=sqlite3
-ZLIB_USE= PHP=zlib
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MIMAGICK}
-.if ${PORT_OPTIONS:MX11}
-USES+= magick:6,run
-.else
-USES+= magick:6,run,nox11
-.endif
-.endif
-
-do-install:
- # workaround fix for:
- # "Checking for items in STAGEDIR missing from pkg-plist"
- # "Error: Orphaned: @dir %%WWWDIR%%_src-10.4.16/vendor/symfony/string/Resources/bin"
- ${RMDIR} ${WRKSRC}/vendor/symfony/string/Resources/bin
- # remove source empty directory
- ${MKDIR} ${STAGEDIR}${PREFIX}/${TYPO3WWW}/${TYPO3DIR}
- ${CP} -R ${WRKDIR}/${TYPO3SRC} ${STAGEDIR}${PREFIX}/${TYPO3WWW}/
- ${LN} -fs ../${TYPO3SRC} ${STAGEDIR}${PREFIX}/${TYPO3WWW}/${TYPO3DIR}/typo3_src
- ${LN} -fs typo3_src/index.php ${STAGEDIR}${PREFIX}/${TYPO3WWW}/${TYPO3DIR}/index.php
- ${LN} -fs typo3_src/typo3 ${STAGEDIR}${PREFIX}/${TYPO3WWW}/${TYPO3DIR}/typo3
-
-post-install:
- @cd ${STAGEDIR}${PREFIX}; \
- ${FIND} * \( -type f -or -type l \) -path "${TYPO3WWW}/${TYPO3DIR}/*" | \
- ${SORT} >> ${TMPPLIST}; \
- ${ECHO} "@owner ${WWWOWN}" >> ${TMPPLIST}; \
- ${ECHO} "@dir ${TYPO3WWW}/${TYPO3DIR}" >> ${TMPPLIST}
- @cd ${STAGEDIR}${PREFIX}; \
- ${ECHO} "@owner" >> ${TMPPLIST}; \
- ${FIND} * \( -type f -or -type l \) -path "${TYPO3WWW}/${TYPO3SRC}/*" | \
- ${SORT} >> ${TMPPLIST}
-
-.include <bsd.port.mk>
diff --git a/www/typo3-10/distinfo b/www/typo3-10/distinfo
deleted file mode 100644
index c504aef721bb..000000000000
--- a/www/typo3-10/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1664114076
-SHA256 (typo3_src-10.4.32.tar.gz) = abfdeaa8119746a84898a3d4d7e368a6277b5a916c0a2e5dc7bd053282c0573b
-SIZE (typo3_src-10.4.32.tar.gz) = 29573147
diff --git a/www/typo3-10/files/pkg-message.in b/www/typo3-10/files/pkg-message.in
deleted file mode 100644
index 0e4c51232440..000000000000
--- a/www/typo3-10/files/pkg-message.in
+++ /dev/null
@@ -1,24 +0,0 @@
-[
-{ type: install
- message: <<EOM
-1) Add the following to your Apache configuration file
- httpd.conf and restart the web server:
-
- Alias /typo3 %%PREFIX%%/%%TYPO3WWW%%/%%TYPO3DIR%%/
- AcceptPathInfo On
- <Directory %%PREFIX%%/%%TYPO3WWW%%/%%TYPO3DIR%%/>
- Options Indexes FollowSymLinks
- AllowOverride None
- Require all granted
- </Directory>
-
-2) Visit your TYPO3 site with a browser (i.e.
- http://your.server.com/typo3/) to continue the
- installation / upgrade process.
-
-For more information, see the INSTALL DOCUMENTATION:
-
- https://docs.typo3.org/typo3cms/GettingStartedTutorial/latest/Installation/Index.html
-EOM
-}
-]
diff --git a/www/typo3-10/pkg-descr b/www/typo3-10/pkg-descr
deleted file mode 100644
index 42474d742d3c..000000000000
--- a/www/typo3-10/pkg-descr
+++ /dev/null
@@ -1,19 +0,0 @@
-TYPO3 is a free Open Source content management system for enterprise purposes
-on the web and in intranets. It offers full flexibility and extendability while
-featuring an accomplished set of ready-made interfaces, functions and modules.
-
-The old version with Long Term Support (LTS). It will receive security bugfixes
-until April 2023.
-
-* Dashboard for editors
-* Additional security features for editors and website users
-* Improved Site setup and URL handling
-
-System requirements
-* PHP 7.2 or later
-* MySQL 5.5+ / MariaDB / Postgres / SQLite support
-* Modern Browsers
-
-Supported Until
-Free: 2023-04-30
-ELTS: 2026-04-30