aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-21 16:34:07 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-21 16:36:33 +0000
commit2f1c26cbf8be4cf4276e84ddb9bd8c85d26122a2 (patch)
tree3a2295176a5861e3ac6cb611860b878c2279fe83
parent7d38e9a93ed023c309cff3eeeb83730898f421fe (diff)
downloadports-2f1c26cbf8be4cf4276e84ddb9bd8c85d26122a2.tar.gz
ports-2f1c26cbf8be4cf4276e84ddb9bd8c85d26122a2.zip
security/py-josepy: Convert to USE_PYTHON=pytest
-rw-r--r--security/py-josepy/Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/security/py-josepy/Makefile b/security/py-josepy/Makefile
index 72b57c213e19..3e521cff4b6b 100644
--- a/security/py-josepy/Makefile
+++ b/security/py-josepy/Makefile
@@ -16,17 +16,13 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=1.5:security/py-cryptography@$
${PYTHON_PKGNAMEPREFIX}openssl>=0.13:security/py-openssl@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}coverage>=4.0:devel/py-coverage@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}flake8>=0:devel/py-flake8@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest>=2.8.0,1:devel/py-pytest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-cache>=1.0:devel/py-pytest-cache@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-flake8>=0.5:devel/py-pytest-flake8@${PY_FLAVOR}
USES= python:3.6+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent distutils pytest
NO_ARCH= yes
-do-test:
- @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
-
.include <bsd.port.mk>