aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-26 16:35:41 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-26 16:36:08 +0000
commit2f35623c2e6c0f0306335b651ac704f913766b34 (patch)
tree87c82e9a1ebad97ede35f826771e473848ed0af2
parentc7f9e5d8849e445c9012e1f6ed84eba6c89cbba5 (diff)
downloadports-2f35623c2e6c0f0306335b651ac704f913766b34.tar.gz
ports-2f35623c2e6c0f0306335b651ac704f913766b34.zip
graphics/py-imageio: Add FITS, PYAV and TIFFFILE options
-rw-r--r--graphics/py-imageio/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/py-imageio/Makefile b/graphics/py-imageio/Makefile
index 94c3a5b8e13d..8d06d668fcbe 100644
--- a/graphics/py-imageio/Makefile
+++ b/graphics/py-imageio/Makefile
@@ -19,11 +19,17 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
-OPTIONS_DEFINE= FFMPEG
+OPTIONS_DEFINE= FFMPEG FITS PYAV TIFFFILE
OPTIONS_DEFAULT=FFMPEG
FFMPEG_DESC= Read/Write video using FFmpeg
+FITS_DESC= Read FITS files
+PYAV_DESC= Read/Write Videos (and images)
+TIFFFILE_DESC= Read/Write TIFF files
FFMPEG_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}imageio-ffmpeg>=0:graphics/py-imageio-ffmpeg@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}psutil>=0:sysutils/py-psutil@${PY_FLAVOR}
+FITS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}astropy>=0,2:astro/py-astropy@${PY_FLAVOR}
+PYAV_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}av>=0:multimedia/py-av@${PY_FLAVOR}
+TIFFFILE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tifffile>=0:graphics/py-tifffile@${PY_FLAVOR}
.include <bsd.port.mk>