aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg A. Mamontov <oleg@mamontov.net>2023-11-24 09:45:46 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2024-02-22 12:31:52 +0000
commit2f3bdc0e7ae3912b61ec9517633b15a6caec0bf5 (patch)
tree8475dc7e227044b89f9cf9ff637de9a7ea62c1d1
parentd12ba3f1c7a370617d6b2a579301915490e8e964 (diff)
downloadports-2f3bdc0e7ae3912b61ec9517633b15a6caec0bf5.tar.gz
ports-2f3bdc0e7ae3912b61ec9517633b15a6caec0bf5.zip
www/angie-module-testcookie: New angie module
Module is a simple robot mitigation module using cookie based challenge/response technique. Challenge cookies can be set using different methods and can be encrypted and then decrypted at client side with JavaScript. PR: 275299
-rw-r--r--www/Makefile1
-rw-r--r--www/angie-module-testcookie/Makefile25
-rw-r--r--www/angie-module-testcookie/files/pkg-message.in15
-rw-r--r--www/angie-module-testcookie/pkg-descr3
-rw-r--r--www/angie-module-testcookie/pkg-plist4
-rw-r--r--www/angie/distinfo4
6 files changed, 51 insertions, 1 deletions
diff --git a/www/Makefile b/www/Makefile
index 4dd154716d0b..43d00e7ecd8b 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -49,6 +49,7 @@
SUBDIR += angie-module-rtmp
SUBDIR += angie-module-set-misc
SUBDIR += angie-module-subs
+ SUBDIR += angie-module-testcookie
SUBDIR += angie-module-upload
SUBDIR += angie-module-vod
SUBDIR += angie-module-xslt
diff --git a/www/angie-module-testcookie/Makefile b/www/angie-module-testcookie/Makefile
new file mode 100644
index 000000000000..f4026c99bd06
--- /dev/null
+++ b/www/angie-module-testcookie/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= angie-module-testcookie
+GH_TUPLE= kyprizel:testcookie-nginx-module:64137c2f7e66e8866f56fdecaaf09ac10a034da9:module
+
+COMMENT= Angie testcookie dynamic module
+
+LICENSE_FILE= ${WRKSRC_module}/README.markdown
+
+MASTERDIR= ${.CURDIR}/../../www/angie
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${MODDIR}
+
+ ${INSTALL_LIB} ${WRKSRC}/objs/ngx_http_testcookie_access_module.so \
+ ${STAGEDIR}${MODDIR}
+
+ ${INSTALL_MAN} ${WRKSRC_module}/Changelog ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC_module}/README.markdown ${STAGEDIR}${DOCSDIR}
+
+do-install-DEBUG-on:
+ ${INSTALL} ${COPY} -m ${_SHAREMODE} \
+ ${WRKSRC_DEBUG}/objs/ngx_http_testcookie_access_module.so \
+ ${STAGEDIR}${MODDIR}/ngx_http_testcookie_access_module-debug.so
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/angie-module-testcookie/files/pkg-message.in b/www/angie-module-testcookie/files/pkg-message.in
new file mode 100644
index 000000000000..e98a0d08a5a8
--- /dev/null
+++ b/www/angie-module-testcookie/files/pkg-message.in
@@ -0,0 +1,15 @@
+[
+{ type: install
+ message: <<EOM
+
+The testcookie dynamic module for Angie has been installed.
+To enable this module, add the following to %%PREFIX%%/etc/angie/angie.conf
+and reload angie:
+
+ load_module modules/ngx_http_testcookie_access_module.so;
+
+Please refer to the module documentation for further details:
+https://github.com/kyprizel/testcookie-nginx-module
+EOM
+}
+]
diff --git a/www/angie-module-testcookie/pkg-descr b/www/angie-module-testcookie/pkg-descr
new file mode 100644
index 000000000000..65fdc9c4c38f
--- /dev/null
+++ b/www/angie-module-testcookie/pkg-descr
@@ -0,0 +1,3 @@
+Module is a simple robot mitigation module using cookie based
+challenge/response technique. Challenge cookies can be set using different
+methods and can be encrypted and then decrypted at client side with JavaScript.
diff --git a/www/angie-module-testcookie/pkg-plist b/www/angie-module-testcookie/pkg-plist
new file mode 100644
index 000000000000..ba3dfb4fb7b5
--- /dev/null
+++ b/www/angie-module-testcookie/pkg-plist
@@ -0,0 +1,4 @@
+%%DOCSDIR%%/Changelog
+%%DOCSDIR%%/README.markdown
+%%MODDIR%%/ngx_http_testcookie_access_module.so
+%%DEBUG%%%%MODDIR%%/ngx_http_testcookie_access_module-debug.so
diff --git a/www/angie/distinfo b/www/angie/distinfo
index 17b9800c9b0a..6fe046284bb4 100644
--- a/www/angie/distinfo
+++ b/www/angie/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1700818842
+TIMESTAMP = 1700819056
SHA256 (angie-1.3.2.tar.gz) = 636056d60788f8012738eed856733f7515b9cb2de0b002186c5edc820ffafb27
SIZE (angie-1.3.2.tar.gz) = 1483526
SHA256 (kjdev-nginx-auth-jwt-2a2bd643295610606734298e5afc1875203664e1_GH0.tar.gz) = fd540226223625c34d988f7bdc0a485b1e7bf76dec0e61ff8e6d9a4e585b8282
@@ -43,6 +43,8 @@ SHA256 (openresty-set-misc-nginx-module-v0.33_GH0.tar.gz) = cd5e2cc834bcfa30149e
SIZE (openresty-set-misc-nginx-module-v0.33_GH0.tar.gz) = 30084
SHA256 (yaoweibin-ngx_http_substitutions_filter_module-e12e965ac1837ca709709f9a26f572a54d83430e_GH0.tar.gz) = da2a26aa75884e1216941c7291b6e8b7fc4dd7163700a04191b92060b61fabb3
SIZE (yaoweibin-ngx_http_substitutions_filter_module-e12e965ac1837ca709709f9a26f572a54d83430e_GH0.tar.gz) = 94121
+SHA256 (kyprizel-testcookie-nginx-module-64137c2f7e66e8866f56fdecaaf09ac10a034da9_GH0.tar.gz) = 2946fd88157be64f69e29409160cf48a594fd6272c3f4c6b7f170bfa13074ee0
+SIZE (kyprizel-testcookie-nginx-module-64137c2f7e66e8866f56fdecaaf09ac10a034da9_GH0.tar.gz) = 20732
SHA256 (fdintino-nginx-upload-module-2.3.0_GH0.tar.gz) = c86e318addb9c88d70fdbd58ff1f6ef6f404a93070f6db8017a1f880c97946c4
SIZE (fdintino-nginx-upload-module-2.3.0_GH0.tar.gz) = 40139
SHA256 (kaltura-nginx-vod-module-1.32_GH0.tar.gz) = 958bbe7084704f9df49f8b71e8b90700591cd3edca7409f74bf0d8721621402f