aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2024-01-24 21:37:01 +0000
committerDan Langille <dvl@FreeBSD.org>2024-01-24 21:37:01 +0000
commit2f448a87ed311d7e3bc506c6a42e23da6ad8bfee (patch)
tree4c87d86a6bfc5c1097b96346a19c782ca2bb4ffa
parent3fa33433c1b9aa0a09e7224e78a4f32a2adaa10a (diff)
downloadports-2f448a87ed311d7e3bc506c6a42e23da6ad8bfee.tar.gz
ports-2f448a87ed311d7e3bc506c6a42e23da6ad8bfee.zip
security/sudo: re-add sssd-devel option
sudo already allows for the use of security/sssd (SSSD) This patch allows for selecting security/sssd-devel (SSSD_DEVEL) instead. Also updates security/sssd-devel, elminating a circular dependency. PR: 276598 272571
-rw-r--r--security/sssd-devel/Makefile3
-rw-r--r--security/sudo/Makefile11
2 files changed, 9 insertions, 5 deletions
diff --git a/security/sssd-devel/Makefile b/security/sssd-devel/Makefile
index ab8c12d7dbc1..cda27caa71d9 100644
--- a/security/sssd-devel/Makefile
+++ b/security/sssd-devel/Makefile
@@ -1,5 +1,6 @@
PORTNAME= sssd
PORTVERSION= 2.9.2
+PORTREVISION= 1
CATEGORIES= security
PKGNAMESUFFIX= -devel
@@ -100,8 +101,6 @@ CONFIGURE_ARGS= --disable-dependency-tracking \
--with-gpo-cache-path=/var/db/sss/gpo_cache \
--without-semanage \
--with-app-libs=${LOCALBASE}/lib/sssd/modules \
- --with-sudo \
- --with-sudo-lib-path=${LOCALBASE}/lib \
--without-autofs \
--with-files-provider \
--with-passkey \
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index e4bc49005f18..b955a563575b 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -1,6 +1,6 @@
PORTNAME= sudo
PORTVERSION= 1.9.15p5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= SUDO
@@ -32,10 +32,11 @@ LDFLAGS+= -lgcc
PORTSCOUT= ignore:1
OPTIONS_DEFINE= AUDIT DISABLE_AUTH DISABLE_ROOT_SUDO DOCS EXAMPLES \
- INSULTS LDAP NLS NOARGS_SHELL OPIE PAM PYTHON SSL SSSD
+ INSULTS LDAP NLS NOARGS_SHELL OPIE PAM PYTHON SSL
OPTIONS_DEFAULT= AUDIT PAM SSL
-OPTIONS_RADIO= KERBEROS
+OPTIONS_RADIO= KERBEROS SSSD
OPTIONS_RADIO_KERBEROS= GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT
+OPTIONS_RADIO_SSSD= SSSD SSSD_DEVEL
OPTIONS_SUB= yes
AUDIT_DESC= Enable BSM audit support
@@ -48,6 +49,7 @@ OPIE_DESC= Enable one-time passwords (no PAM support)
PYTHON_DESC= Enable python plugin support
SSL_DESC= Use OpenSSL TLS and SHA2 functions
SSSD_DESC= Enable SSSD backend support
+SSSD_DEVEL_DESC= Enable SSSD-devel backend support
AUDIT_CONFIGURE_WITH= bsm-audit
@@ -91,6 +93,9 @@ SSSD_PREVENTS_MSG= sssd requires MIT kerberos and it conflicts with heimdal
SSSD_RUN_DEPENDS= sssd:security/sssd
SSSD_CONFIGURE_ON= --with-sssd
+SSSD_DEVEL_RUN_DEPENDS= sssd:security/sssd-devel
+SSSD_DEVEL_CONFIGURE_ON= --with-sssd
+
LOGFAC?= authpriv
SUDO_LDAP_CONF?= ldap.conf