aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2023-08-20 20:15:18 +0000
committerJason E. Hale <jhale@FreeBSD.org>2023-08-20 20:19:13 +0000
commit2fb7dbce41974d1f7910c145408f5169c3702231 (patch)
treea97b8618e61dc71f99721d3698ba40097b123117
parentfae9b9e3f20a6d32436c07a6dd8c0d9122c29a0d (diff)
downloadports-2fb7dbce41974d1f7910c145408f5169c3702231.tar.gz
ports-2fb7dbce41974d1f7910c145408f5169c3702231.zip
audio/picard: Update to 2.9.1
Switch to PEP-517 Enable regression tests https://github.com/metabrainz/picard/releases/tag/release-2.9.1
-rw-r--r--audio/picard/Makefile8
-rw-r--r--audio/picard/distinfo6
-rw-r--r--audio/picard/files/patch-picard_ui_options_general.py13
3 files changed, 20 insertions, 7 deletions
diff --git a/audio/picard/Makefile b/audio/picard/Makefile
index bb7415ea6b27..8f308712f4b1 100644
--- a/audio/picard/Makefile
+++ b/audio/picard/Makefile
@@ -1,5 +1,5 @@
PORTNAME= picard
-PORTVERSION= 2.9
+PORTVERSION= 2.9.1
CATEGORIES= audio python
MASTER_SITES= http://ftp.musicbrainz.org/pub/musicbrainz/picard/ \
ftp://ftp.musicbrainz.org/pub/musicbrainz/picard/ \
@@ -12,6 +12,8 @@ WWW= https://picard.musicbrainz.org/
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING.txt
+BUILD_DEPENDS= ${PY_SETUPTOOLS} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}discid>=1.0:audio/py-discid@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mutagen>=1.37:audio/py-mutagen@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dateutil>=2.7:devel/py-dateutil@${PY_FLAVOR} \
@@ -23,12 +25,10 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}discid>=1.0:audio/py-discid@${PY_FLAVOR} \
USES= gettext pyqt:5 python desktop-file-utils
USE_LOCALE= en_US.UTF-8
USE_PYQT= pyqt5:run sip
-USE_PYTHON= autoplist distutils noflavors
+USE_PYTHON= autoplist noflavors pep517 unittest
CONFLICTS_INSTALL= picard-tools py*-python-picard # bin/picard
-WRKSRC= ${WRKDIR}/${PORTNAME}-release-${DISTVERSION}
-
OPTIONS_DEFINE= ACOUSTID PLUGINS
OPTIONS_DEFAULT= PLUGINS
diff --git a/audio/picard/distinfo b/audio/picard/distinfo
index ff77d674591a..a706b71be2d7 100644
--- a/audio/picard/distinfo
+++ b/audio/picard/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1690500422
-SHA256 (picard-2.9.tar.gz) = 89eb2d299f40eac9de7166593733c57942583dd1118f5c7a0b58278255fcd129
-SIZE (picard-2.9.tar.gz) = 6360770
+TIMESTAMP = 1692553916
+SHA256 (picard-2.9.1.tar.gz) = 7ae365a6c96e9411833b2c09b7a26cedd3984c874819c4515592a4da477136b8
+SIZE (picard-2.9.1.tar.gz) = 5270234
diff --git a/audio/picard/files/patch-picard_ui_options_general.py b/audio/picard/files/patch-picard_ui_options_general.py
new file mode 100644
index 000000000000..be04187a9c5b
--- /dev/null
+++ b/audio/picard/files/patch-picard_ui_options_general.py
@@ -0,0 +1,13 @@
+Disable checking for updates by default.
+
+--- picard/ui/options/general.py.orig 2023-08-16 07:38:39 UTC
++++ picard/ui/options/general.py
+@@ -71,7 +71,7 @@ class GeneralOptionsPage(OptionsPage):
+ TextOption("persist", "oauth_access_token", ""),
+ IntOption("persist", "oauth_access_token_expires", 0),
+ TextOption("persist", "oauth_username", ""),
+- BoolOption("setting", "check_for_updates", True),
++ BoolOption("setting", "check_for_updates", False),
+ IntOption("setting", "update_check_days", 7),
+ IntOption("setting", "update_level", DEFAULT_PROGRAM_UPDATE_LEVEL),
+ IntOption("persist", "last_update_check", 0),