aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:02:17 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:02:17 +0000
commit2fc390ba404f039f630fac6685cd1b1f225fb82f (patch)
treeeaea940ac9156e61ff6a34b4a473d487868f88fa
parent5c0d5f9b13d5b32a855c08f80d9115c45ef3e040 (diff)
downloadports-2fc390ba404f039f630fac6685cd1b1f225fb82f.tar.gz
ports-2fc390ba404f039f630fac6685cd1b1f225fb82f.zip
math/py-bottleneck: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
-rw-r--r--math/py-bottleneck/Makefile8
-rw-r--r--math/py-bottleneck/files/patch-pyproject.toml9
-rw-r--r--math/py-bottleneck/files/patch-setup.py11
3 files changed, 26 insertions, 2 deletions
diff --git a/math/py-bottleneck/Makefile b/math/py-bottleneck/Makefile
index 221458b8adb6..759a0368dc93 100644
--- a/math/py-bottleneck/Makefile
+++ b/math/py-bottleneck/Makefile
@@ -1,5 +1,6 @@
PORTNAME= bottleneck
PORTVERSION= 1.3.8
+PORTREVISION= 1
CATEGORIES= math python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,11 +13,14 @@ WWW= https://github.com/kwgoodman/bottleneck
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}versioneer>=0:devel/py-versioneer@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent cython distutils
+USE_PYTHON= autoplist concurrent cython pep517
DOCS= README.rst RELEASE.rst \
doc/source/conf.py doc/source/index.rst doc/source/intro.rst doc/source/reference.rst
diff --git a/math/py-bottleneck/files/patch-pyproject.toml b/math/py-bottleneck/files/patch-pyproject.toml
new file mode 100644
index 000000000000..0f93828ea05a
--- /dev/null
+++ b/math/py-bottleneck/files/patch-pyproject.toml
@@ -0,0 +1,9 @@
+--- pyproject.toml.orig 2024-02-25 00:30:13 UTC
++++ pyproject.toml
+@@ -3,5 +3,5 @@ requires = [
+ "setuptools",
+ "versioneer",
+ "wheel",
+- "oldest-supported-numpy"
++ "numpy"
+ ]
diff --git a/math/py-bottleneck/files/patch-setup.py b/math/py-bottleneck/files/patch-setup.py
new file mode 100644
index 000000000000..ba1ff4e2ea5a
--- /dev/null
+++ b/math/py-bottleneck/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2024-02-25 00:30:13 UTC
++++ setup.py
+@@ -175,7 +175,7 @@ metadata = dict(
+
+
+ metadata = dict(
+- name="Bottleneck",
++ name="bottleneck",
+ maintainer="Christopher Whelan",
+ maintainer_email="bottle-neck@googlegroups.com",
+ description="Fast NumPy array functions written in C",