aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-02-02 10:00:31 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-02-03 09:08:09 +0000
commit2fc8b719ca85b61981f9c0ebd8139220bd5a1ed6 (patch)
tree1a0b66049b9bbc4857fb1d2960471cd8ffeb448f
parent93b316f21cb78ed4c3c44169d7c628b7e2cfc4a7 (diff)
downloadports-2fc8b719ca85b61981f9c0ebd8139220bd5a1ed6.tar.gz
ports-2fc8b719ca85b61981f9c0ebd8139220bd5a1ed6.zip
x11-wm/hyprland: unbreak build with GCC after 33b9f9f8c931
FAILED: src/Hyprland /usr/local/bin/ld: src/Hyprland.p/managers_ThreadManager.cpp.o: in function `std::__1::basic_filebuf<char, std::__1::char_traits<char> >::overflow(int)': ThreadManager.cpp:(.text._ZNSt3__113basic_filebufIcNS_11char_traitsIcEEE8overflowEi[_ZNSt3__113basic_filebufIcNS_11char_traitsIcEEE8overflowEi]+0x2e4): undefined reference to `std::bad_cast::bad_cast()' /usr/local/bin/ld: src/Hyprland.p/managers_ThreadManager.cpp.o: in function `std::__1::basic_filebuf<char, std::__1::char_traits<char> >::sync()': ThreadManager.cpp:(.text._ZNSt3__113basic_filebufIcNS_11char_traitsIcEEE4syncEv[_ZNSt3__113basic_filebufIcNS_11char_traitsIcEEE4syncEv]+0x306): undefined reference to `std::bad_cast::bad_cast()' /usr/local/bin/ld: src/Hyprland.p/managers_ThreadManager.cpp.o: in function `std::__1::basic_filebuf<char, std::__1::char_traits<char> >::seekoff(long long, std::__1::ios_base::seekdir, unsigned int)': ThreadManager.cpp:(.text._ZNSt3__113basic_filebufIcNS_11char_traitsIcEEE7seekoffExNS_8ios_base7seekdirEj[_ZNSt3__113basic_filebufIcNS_11char_traitsIcEEE7seekoffExNS_8ios_base7seekdirEj]+0x166): undefined reference to `std::bad_cast::bad_cast()' [...]
-rw-r--r--x11-wm/hyprland/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/x11-wm/hyprland/Makefile b/x11-wm/hyprland/Makefile
index dbdda4dfebad..e6e2aa6cb40f 100644
--- a/x11-wm/hyprland/Makefile
+++ b/x11-wm/hyprland/Makefile
@@ -58,6 +58,7 @@ post-install:
.endif
# XXX Drop after FreeBSD 13.2 EOL around 2024-05-01 (don't forget distinfo)
+.if ${CXX} == c++ && exists(/usr/lib/libc++.so)
.if !exists(/usr/include/c++/v1/__ranges/as_rvalue_view.h) || make(makesum) || make(fetch)
. if exists(/usr/include/c++/v1/__algorithm/ranges_all_of.h) && !make(makesum) && !make(fetch)
CXXFLAGS+= -fexperimental-library # std::ranges::all_of
@@ -86,5 +87,6 @@ bundled-libcxx:
@${DO_MAKE_BUILD:NDESTDIR*} install -C ${WRKDIR}/libcxx_build
. endif
.endif
+.endif # exists(/usr/lib/libc++.so)
.include <bsd.port.mk>