aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-05-31 07:50:03 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-05-31 09:01:22 +0000
commit2fe85bfe92a9754967115cb0b987c34c702967d7 (patch)
tree6f958fa8d390695db6b97d325411af0e882f8740
parent4de211bca609d458f9a5f70ba900bc7f3958f408 (diff)
downloadports-2fe85bfe92a9754967115cb0b987c34c702967d7.tar.gz
ports-2fe85bfe92a9754967115cb0b987c34c702967d7.zip
math/octomap: Update 1.9.7 -> 1.9.8
-rw-r--r--math/octomap/Makefile10
-rw-r--r--math/octomap/distinfo6
-rw-r--r--math/octomap/files/patch-dynamicEDT3D_src_CMakeLists.txt6
-rw-r--r--math/octomap/files/patch-octomap_src_CMakeLists.txt4
-rw-r--r--math/octomap/files/patch-octomap_src_math_CMakeLists.txt8
-rw-r--r--math/octomap/files/patch-octovis_CMakeLists__src.txt24
-rw-r--r--math/octomap/pkg-plist8
7 files changed, 38 insertions, 28 deletions
diff --git a/math/octomap/Makefile b/math/octomap/Makefile
index dbec3e54ec0b..223a55bcf127 100644
--- a/math/octomap/Makefile
+++ b/math/octomap/Makefile
@@ -1,7 +1,6 @@
PORTNAME= octomap
DISTVERSIONPREFIX= v
-DISTVERSION= 1.9.7
-PORTREVISION= 1
+DISTVERSION= 1.9.8
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -14,13 +13,14 @@ LICENSE_FILE_GPLv2= ${WRKSRC}/octovis/LICENSE.txt
LIB_DEPENDS= libQGLViewer-qt5.so:graphics/libQGLViewer
-USES= cmake compiler:c++11-lang localbase:ldflags gl qt:5
-USE_GITHUB= yes
-GH_ACCOUNT= OctoMap
+USES= cmake:testing compiler:c++11-lang localbase:ldflags gl qt:5
USE_QT= core gui opengl xml widgets buildtools_build qmake_build
USE_GL= gl glu
USE_LDCONFIG= yes
+USE_GITHUB= yes
+GH_ACCOUNT= OctoMap
+
# Viewer is broken: https://github.com/OctoMap/octomap/issues/224, and libQGLViewer detection is broken: https://github.com/OctoMap/octomap/issues/225
#CMAKE_ON= OCTOVIS_QT5
CMAKE_ARGS= -DQGLVIEWER_BASE_DIR:PATH=${LOCALBASE}/include/QGLViewer #-DQGLViewer_LIBRARY_DIR_OTHER:PATH=${LOCALBASE}/lib
diff --git a/math/octomap/distinfo b/math/octomap/distinfo
index 20e1d0b22471..7def9824dee2 100644
--- a/math/octomap/distinfo
+++ b/math/octomap/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1620605016
-SHA256 (OctoMap-octomap-v1.9.7_GH0.tar.gz) = 3e9ac020686ceb4e17e161bffc5a0dafd9cccab33adeb9adee59a61c418ea1c1
-SIZE (OctoMap-octomap-v1.9.7_GH0.tar.gz) = 1684088
+TIMESTAMP = 1653983015
+SHA256 (OctoMap-octomap-v1.9.8_GH0.tar.gz) = 417af6da4e855e9a83b93458aa98b01a2c88f880088baad2b59d323ce162586e
+SIZE (OctoMap-octomap-v1.9.8_GH0.tar.gz) = 1693311
diff --git a/math/octomap/files/patch-dynamicEDT3D_src_CMakeLists.txt b/math/octomap/files/patch-dynamicEDT3D_src_CMakeLists.txt
index b1d079bf3ab1..000e1a04e2d1 100644
--- a/math/octomap/files/patch-dynamicEDT3D_src_CMakeLists.txt
+++ b/math/octomap/files/patch-dynamicEDT3D_src_CMakeLists.txt
@@ -1,6 +1,6 @@
---- dynamicEDT3D/src/CMakeLists.txt.orig 2018-11-20 06:37:53 UTC
+--- dynamicEDT3D/src/CMakeLists.txt.orig 2022-05-12 20:49:09 UTC
+++ dynamicEDT3D/src/CMakeLists.txt
-@@ -9,28 +9,28 @@ set_target_properties(dynamicedt3d PROPE
+@@ -9,28 +9,28 @@ set_target_properties(dynamicedt3d PROPERTIES
)
target_link_libraries(dynamicedt3d ${OCTOMAP_LIBRARIES})
@@ -33,5 +33,5 @@
-install(TARGETS dynamicedt3d dynamicedt3d-static
+install(TARGETS dynamicedt3d
EXPORT dynamicEDT3DTargets
- INCLUDES DESTINATION include
+ INCLUDES DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}"
${INSTALL_TARGETS_DEFAULT_ARGS}
diff --git a/math/octomap/files/patch-octomap_src_CMakeLists.txt b/math/octomap/files/patch-octomap_src_CMakeLists.txt
index 0dab6634c922..285dc6b7c31c 100644
--- a/math/octomap/files/patch-octomap_src_CMakeLists.txt
+++ b/math/octomap/files/patch-octomap_src_CMakeLists.txt
@@ -1,4 +1,4 @@
---- octomap/src/CMakeLists.txt.orig 2019-11-23 20:56:23 UTC
+--- octomap/src/CMakeLists.txt.orig 2022-05-12 20:49:09 UTC
+++ octomap/src/CMakeLists.txt
@@ -16,9 +16,9 @@ set_target_properties( octomap PROPERTIES
VERSION ${OCTOMAP_VERSION}
@@ -29,5 +29,5 @@
-install(TARGETS octomap octomap-static
+install(TARGETS octomap
EXPORT octomap-targets
- INCLUDES DESTINATION include
+ INCLUDES DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}"
${INSTALL_TARGETS_DEFAULT_ARGS}
diff --git a/math/octomap/files/patch-octomap_src_math_CMakeLists.txt b/math/octomap/files/patch-octomap_src_math_CMakeLists.txt
index ef05b4b2c385..4f3613a33ea6 100644
--- a/math/octomap/files/patch-octomap_src_math_CMakeLists.txt
+++ b/math/octomap/files/patch-octomap_src_math_CMakeLists.txt
@@ -1,8 +1,8 @@
---- octomap/src/math/CMakeLists.txt.orig 2018-11-20 06:36:08 UTC
+--- octomap/src/math/CMakeLists.txt.orig 2022-05-12 20:49:09 UTC
+++ octomap/src/math/CMakeLists.txt
-@@ -14,17 +14,17 @@ SET_TARGET_PROPERTIES( octomath PROPERTI
+@@ -12,17 +12,17 @@ SET_TARGET_PROPERTIES( octomath PROPERTIES
+ SOVERSION ${OCTOMAP_SOVERSION}
)
- # INSTALL_NAME_DIR seems to be necessary for MacOS X
-ADD_LIBRARY( octomath-static STATIC ${octomath_SRCS})
-SET_TARGET_PROPERTIES(octomath-static PROPERTIES OUTPUT_NAME "octomath")
@@ -20,5 +20,5 @@
-install(TARGETS octomath octomath-static
+install(TARGETS octomath
EXPORT octomap-targets
- INCLUDES DESTINATION include
+ INCLUDES DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}"
${INSTALL_TARGETS_DEFAULT_ARGS}
diff --git a/math/octomap/files/patch-octovis_CMakeLists__src.txt b/math/octomap/files/patch-octovis_CMakeLists__src.txt
index 2f45d787664f..f3014c571154 100644
--- a/math/octomap/files/patch-octovis_CMakeLists__src.txt
+++ b/math/octomap/files/patch-octovis_CMakeLists__src.txt
@@ -1,19 +1,29 @@
---- octovis/CMakeLists_src.txt.orig 2018-11-20 06:29:27 UTC
+--- octovis/CMakeLists_src.txt.orig 2022-05-12 20:49:09 UTC
+++ octovis/CMakeLists_src.txt
-@@ -99,9 +99,9 @@ include_directories(${CMAKE_CURRENT_BINA
+@@ -99,14 +99,14 @@ include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMAK
# Library target
-add_library(octovis-static STATIC ${viewerlib_SRCS})
--target_link_libraries(octovis-static)
+-target_link_libraries(octovis-static
+- ${OPENGL_gl_LIBRARY}
+- ${OPENGL_glu_LIBRARY}
+- ${OCTOMAP_LIBRARIES}
+- ${QGLViewer_LIBRARIES}
+-)
-set_target_properties(octovis-static PROPERTIES OUTPUT_NAME octovis)
+#add_library(octovis-static STATIC ${viewerlib_SRCS})
-+#target_link_libraries(octovis-static)
++#target_link_libraries(octovis-static
++# ${OPENGL_gl_LIBRARY}
++# ${OPENGL_glu_LIBRARY}
++# ${OCTOMAP_LIBRARIES}
++# ${QGLViewer_LIBRARIES}
++#)
+#set_target_properties(octovis-static PROPERTIES OUTPUT_NAME octovis)
add_library(octovis-shared SHARED ${viewerlib_SRCS})
target_link_libraries(octovis-shared
-@@ -119,7 +119,7 @@ set_target_properties(octovis-shared PRO
+@@ -124,7 +124,7 @@ set_target_properties(octovis-shared PROPERTIES
# directly depend on the octomap library target when building the
# complete distribution, so it is recompiled as needed
if (CMAKE_PROJECT_NAME STREQUAL "octomap-distribution")
@@ -22,7 +32,7 @@
ADD_DEPENDENCIES(octovis-shared octomap)
endif()
-@@ -146,10 +146,10 @@ if(NOT EXISTS "${CMAKE_LIBRARY_OUTPUT_DI
+@@ -151,10 +151,10 @@ if(NOT EXISTS "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/cmake
file(MAKE_DIRECTORY "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/cmake/octovis")
endif()
@@ -33,5 +43,5 @@
-install(TARGETS octovis octovis-static octovis-shared
+install(TARGETS octovis octovis-shared
EXPORT octovis-targets
- INCLUDES DESTINATION include
+ INCLUDES DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}"
${INSTALL_TARGETS_DEFAULT_ARGS}
diff --git a/math/octomap/pkg-plist b/math/octomap/pkg-plist
index 765af73a32ba..d505f617bf4c 100644
--- a/math/octomap/pkg-plist
+++ b/math/octomap/pkg-plist
@@ -54,16 +54,16 @@ include/octovis/SelectionBox.h
include/octovis/TrajectoryDrawer.h
lib/libdynamicedt3d.so
lib/libdynamicedt3d.so.1.9
-lib/libdynamicedt3d.so.1.9.7
+lib/libdynamicedt3d.so.1.9.8
lib/liboctomap.so
lib/liboctomap.so.1.9
-lib/liboctomap.so.1.9.7
+lib/liboctomap.so.1.9.8
lib/liboctomath.so
lib/liboctomath.so.1.9
-lib/liboctomath.so.1.9.7
+lib/liboctomath.so.1.9.8
lib/liboctovis.so
lib/liboctovis.so.1.9
-lib/liboctovis.so.1.9.7
+lib/liboctovis.so.1.9.8
libdata/pkgconfig/dynamicEDT3D.pc
libdata/pkgconfig/octomap.pc
share/ament_index/resource_index/packages/dynamicEDT3D