aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-02-23 16:23:12 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-02-23 20:45:51 +0000
commit30997c2f491f6faaf55583adc35a480225b85fa8 (patch)
tree1cf13b58b3e572cd4e3ba9138b8a4055d1d8403e
parentf39416df08c8c400f8f92a5d7f2f753662cdab20 (diff)
downloadports-30997c2f491f6faaf55583adc35a480225b85fa8.tar.gz
ports-30997c2f491f6faaf55583adc35a480225b85fa8.zip
cad/ghdl: Re-add port: GNU VHDL simulator
-rw-r--r--MOVED1
-rw-r--r--cad/Makefile1
-rw-r--r--cad/ghdl/Makefile63
-rw-r--r--cad/ghdl/distinfo3
-rw-r--r--cad/ghdl/files/patch-configure19
-rw-r--r--cad/ghdl/files/patch-scripts_windows_mcode_Makefile.in13
-rw-r--r--cad/ghdl/files/patch-src_grt_Makefile.inc13
-rw-r--r--cad/ghdl/files/patch-src_ortho_mcode_memsegs__c.c11
-rw-r--r--cad/ghdl/files/patch-testsuite_testsuite.sh13
-rw-r--r--cad/ghdl/pkg-descr9
-rw-r--r--cad/ghdl/pkg-plist202
11 files changed, 347 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index f271f2024125..45fdee339c63 100644
--- a/MOVED
+++ b/MOVED
@@ -16867,7 +16867,6 @@ net-mgmt/zabbix3-frontend||2022-02-28|Has expired: Upstream EOL reached on 2021-
net-mgmt/zabbix3-agent||2022-02-28|Has expired: Upstream EOL reached on 2021-02-28
net-mgmt/zabbix3-server||2022-02-28|Has expired: Upstream EOL reached on 2021-02-28
archivers/zip-ada||2022-02-28|Removed, depends on expired lang/gcc6-aux
-cad/ghdl||2022-02-28|Removed, depends on expired lang/gcc6-aux
databases/adabase||2022-02-28|Removed, depends on expired lang/gcc6-aux
databases/apq||2022-02-28|Removed, depends on expired lang/gcc6-aux
databases/apq-mysql||2022-02-28|Removed, depends on expired lang/gcc6-aux
diff --git a/cad/Makefile b/cad/Makefile
index e70db95d7378..65b27223a834 100644
--- a/cad/Makefile
+++ b/cad/Makefile
@@ -41,6 +41,7 @@
SUBDIR += gdt
SUBDIR += geda
SUBDIR += gerbv
+ SUBDIR += ghdl
SUBDIR += gmsh
SUBDIR += gnucap
SUBDIR += gplcver
diff --git a/cad/ghdl/Makefile b/cad/ghdl/Makefile
new file mode 100644
index 000000000000..6f69ede94736
--- /dev/null
+++ b/cad/ghdl/Makefile
@@ -0,0 +1,63 @@
+PORTNAME= ghdl
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.0.0.20230222
+CATEGORIES= cad
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= GNU VHDL simulator
+WWW= https://github.com/ghdl/ghdl
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING.md
+
+LIB_DEPENDS= libgmp.so:math/gmp \
+ libmpfr.so:math/mpfr \
+ libmpc.so:math/mpc
+TEST_DEPENDS= bash:shells/bash \
+ ${PYTHON_PKGNAMEPREFIX}pyTooling>=2.11.0:devel/py-pyTooling@${PY_FLAVOR}
+
+USES= ada:run gmake python:test shebangfix
+SHEBANG_FILES= testsuite/testsuite.sh
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_TAGNAME= 7670533
+
+GNU_CONFIGURE= yes
+
+LLVMVER= 15 # last supported version, see https://github.com/ghdl/ghdl/blob/master/configure#L317
+
+CONFIGURE_ARGS= --disable-libghdl
+
+OPTIONS_SINGLE= BACKEND
+OPTIONS_SINGLE_BACKEND= MCODE LLVM
+OPTIONS_DEFAULT= LLVM
+OPTIONS_SUB= yes
+
+MCODE_DESC= Use the MCODE backend
+# MCODE is enabled by default and doesn't require any configuration options
+
+LLVM_DESC= Code generator is LLVM
+LLVM_USES= libedit ncurses
+LLVM_CONFIGURE_ON= --with-llvm-config=${LOCALBASE}/bin/llvm-config${LLVMVER}
+LLVM_BUILD_DEPENDS= llvm-config${LLVMVER}:devel/llvm${LLVMVER}
+LLVM_RUN_DEPENDS= llc${LLVMVER}:devel/llvm${LLVMVER}
+
+post-install-MCODE-on:
+ @${STRIP_CMD} \
+ ${STAGEDIR}${PREFIX}/bin/ghdl \
+ ${STAGEDIR}${PREFIX}/lib/libghdlvpi.so
+
+post-install-LLVM-on:
+ @${STRIP_CMD} \
+ ${STAGEDIR}${PREFIX}/bin/ghdl \
+ ${STAGEDIR}${PREFIX}/bin/ghwdump \
+ ${STAGEDIR}${PREFIX}/bin/ghdl1-llvm \
+ ${STAGEDIR}${PREFIX}/lib/libghdlvpi.so \
+ ${STAGEDIR}${PREFIX}/lib/libghw.so
+
+do-test:
+ @cd ${WRKSRC}/testsuite && \
+ ${SETENV} ${MAKE_ENV} GHDL=${STAGEDIR}${PREFIX}/bin/ghdl ${SH} testsuite.sh
+
+.include <bsd.port.mk>
diff --git a/cad/ghdl/distinfo b/cad/ghdl/distinfo
new file mode 100644
index 000000000000..0b88111b1a15
--- /dev/null
+++ b/cad/ghdl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1677126772
+SHA256 (ghdl-ghdl-v2.0.0.20230222-7670533_GH0.tar.gz) = d0bd40ad1d5ffc51300e1fc8248f12621333376230defd79793b9454469b359d
+SIZE (ghdl-ghdl-v2.0.0.20230222-7670533_GH0.tar.gz) = 7196702
diff --git a/cad/ghdl/files/patch-configure b/cad/ghdl/files/patch-configure
new file mode 100644
index 000000000000..ab17ebeca497
--- /dev/null
+++ b/cad/ghdl/files/patch-configure
@@ -0,0 +1,19 @@
+--- configure.orig 2023-02-22 20:22:10 UTC
++++ configure
+@@ -136,8 +136,6 @@ for opt do
+ --enable-coverage) build_mode="coverage";;
+ -h|-help|--help) show_help=yes;;
+ *)
+- echo "$0: unknown option $opt; try $0 --help"
+- exit 1
+ ;;
+ esac
+ done
+@@ -429,6 +427,7 @@ if test $backend = mcode; then
+ *mingw32*) ortho_flags="Flags_Windows${mcode64}" ;;
+ *linux*) ortho_flags="Flags_Linux${mcode64}" ;;
+ *openbsd*) ortho_flags="Flags_Macosx${mcode64}" ;;
++ *freebsd*) ortho_flags="Flags_Linux${mcode64}" ;;
+ *) echo "Unsupported $build build for mcode"; exit 1;;
+ esac
+ echo "Generate ortho_code-x86-flags.ads"
diff --git a/cad/ghdl/files/patch-scripts_windows_mcode_Makefile.in b/cad/ghdl/files/patch-scripts_windows_mcode_Makefile.in
new file mode 100644
index 000000000000..87f8a3831b34
--- /dev/null
+++ b/cad/ghdl/files/patch-scripts_windows_mcode_Makefile.in
@@ -0,0 +1,13 @@
+- workaround for https://github.com/ghdl/ghdl/issues/2358
+
+--- scripts/windows/mcode/Makefile.in.orig 2023-02-23 18:09:00 UTC
++++ scripts/windows/mcode/Makefile.in
+@@ -14,7 +14,7 @@ GRTSRCDIR=grt
+ ####grt Makefile.inc
+
+ ghdl_mcode: default_paths.ads $(GRT_ADD_OBJS) mmap_binding.o force
+- gnatmake -aIghdldrv -aIghdl -aIortho -aIgrt $(GNATFLAGS) ghdl_mcode $(GNAT_BARGS) -largs mmap_binding.o $(GRT_ADD_OBJS) $(GRT_EXTRA_LIB) -Wl,--version-script=$(GRTSRCDIR)/grt.ver -Wl,--export-dynamic
++ gnatmake -aIghdldrv -aIghdl -aIortho -aIgrt $(GNATFLAGS) ghdl_mcode $(GNAT_BARGS) -largs mmap_binding.o $(GRT_ADD_OBJS) $(GRT_EXTRA_LIB) -Wl,--export-dynamic
+
+ mmap_binding.o: ortho/mmap_binding.c
+ $(CC) -c -g -o $@ $<
diff --git a/cad/ghdl/files/patch-src_grt_Makefile.inc b/cad/ghdl/files/patch-src_grt_Makefile.inc
new file mode 100644
index 000000000000..70ee28958186
--- /dev/null
+++ b/cad/ghdl/files/patch-src_grt_Makefile.inc
@@ -0,0 +1,13 @@
+- workaround for https://github.com/ghdl/ghdl/issues/2358
+
+--- src/grt/Makefile.inc.orig 2023-02-23 18:08:23 UTC
++++ src/grt/Makefile.inc
+@@ -43,7 +43,7 @@ else
+ endif
+
+ # Standard GRT_EXEC_OPTS value for ELF platforms.
+-GRT_ELF_EXEC_OPTS:=-Wl,--version-script=@/grt.ver -Wl,--export-dynamic
++GRT_ELF_EXEC_OPTS:=#-Wl,--version-script=@/grt.ver -Wl,--export-dynamic
+
+ # These conditions define these variables:
+ # GRT_TARGET_OBJS: platform specific files to be added in the grt library
diff --git a/cad/ghdl/files/patch-src_ortho_mcode_memsegs__c.c b/cad/ghdl/files/patch-src_ortho_mcode_memsegs__c.c
new file mode 100644
index 000000000000..b32ef2b82686
--- /dev/null
+++ b/cad/ghdl/files/patch-src_ortho_mcode_memsegs__c.c
@@ -0,0 +1,11 @@
+--- src/ortho/mcode/memsegs_c.c.orig 2022-02-28 18:46:53 UTC
++++ src/ortho/mcode/memsegs_c.c
+@@ -26,7 +26,7 @@
+ set rights.
+ */
+
+-#if defined(__APPLE__) || defined(__OpenBSD__)
++#if defined(__APPLE__) || defined(__OpenBSD__) || defined(__FreeBSD__)
+ #define MAP_ANONYMOUS MAP_ANON
+ #else
+ #define HAVE_MREMAP
diff --git a/cad/ghdl/files/patch-testsuite_testsuite.sh b/cad/ghdl/files/patch-testsuite_testsuite.sh
new file mode 100644
index 000000000000..7cc9ac1e91aa
--- /dev/null
+++ b/cad/ghdl/files/patch-testsuite_testsuite.sh
@@ -0,0 +1,13 @@
+- PyGHDL should be in a separate port
+
+--- testsuite/testsuite.sh.orig 2023-02-23 20:12:21 UTC
++++ testsuite/testsuite.sh
+@@ -110,7 +110,7 @@ for opt; do
+ esac
+ done
+
+-if [ "x$tests" = "x" ]; then tests="sanity pyunit gna vests synth vpi vhpi"; fi
++if [ "x$tests" = "x" ]; then tests="sanity gna vests synth vpi vhpi"; fi
+
+ echo "> tests: $tests"
+ echo "> args: $@"
diff --git a/cad/ghdl/pkg-descr b/cad/ghdl/pkg-descr
new file mode 100644
index 000000000000..82c883260cd5
--- /dev/null
+++ b/cad/ghdl/pkg-descr
@@ -0,0 +1,9 @@
+GHDL is the leading VHSIC Hardware Description Language (VHDL) simulator.
+
+Digital and mixed-signal systems such as field-programmable gate arrays
+and integrated circuits can be described by VHDL, and VHDL can also be
+used as a general purpose parallel programming language. GHDL compiles
+VHDL files and creates a binary which simulates the design.
+
+GHDL fully supports IEEE 1076-1987, IEEE 1-76-1993, IEEE 1076-2002
+versions of VHDL, and partially IEEE 1076-2008.
diff --git a/cad/ghdl/pkg-plist b/cad/ghdl/pkg-plist
new file mode 100644
index 000000000000..7907e23413a4
--- /dev/null
+++ b/cad/ghdl/pkg-plist
@@ -0,0 +1,202 @@
+bin/ghdl
+%%LLVM%%bin/ghdl1-llvm
+bin/ghwdump
+include/ghdl/libghw.h
+include/ghdl/vhpi_user.h
+include/ghdl/vpi_user.h
+lib/ghdl/ansi_color.sh
+%%LLVM%%lib/ghdl/grt-exec.lst
+%%LLVM%%lib/ghdl/grt-shared.lst
+%%LLVM%%lib/ghdl/grt.lst
+%%LLVM%%lib/ghdl/grt.ver
+%%LLVM%%lib/ghdl/ieee/v08/fixed_float_types.o
+%%LLVM%%lib/ghdl/ieee/v08/fixed_generic_pkg-body.o
+%%LLVM%%lib/ghdl/ieee/v08/fixed_generic_pkg.o
+%%LLVM%%lib/ghdl/ieee/v08/fixed_pkg.o
+%%LLVM%%lib/ghdl/ieee/v08/float_generic_pkg-body.o
+%%LLVM%%lib/ghdl/ieee/v08/float_generic_pkg.o
+%%LLVM%%lib/ghdl/ieee/v08/float_pkg.o
+lib/ghdl/ieee/v08/ieee-obj08.cf
+%%LLVM%%lib/ghdl/ieee/v08/ieee_bit_context.o
+%%LLVM%%lib/ghdl/ieee/v08/ieee_std_context.o
+%%LLVM%%lib/ghdl/ieee/v08/math_complex-body.o
+%%LLVM%%lib/ghdl/ieee/v08/math_complex.o
+%%LLVM%%lib/ghdl/ieee/v08/math_real-body.o
+%%LLVM%%lib/ghdl/ieee/v08/math_real.o
+%%LLVM%%lib/ghdl/ieee/v08/memory_b.o
+%%LLVM%%lib/ghdl/ieee/v08/memory_p.o
+%%LLVM%%lib/ghdl/ieee/v08/numeric_bit-body.o
+%%LLVM%%lib/ghdl/ieee/v08/numeric_bit.o
+%%LLVM%%lib/ghdl/ieee/v08/numeric_bit_unsigned-body.o
+%%LLVM%%lib/ghdl/ieee/v08/numeric_bit_unsigned.o
+%%LLVM%%lib/ghdl/ieee/v08/numeric_std-body.o
+%%LLVM%%lib/ghdl/ieee/v08/numeric_std.o
+%%LLVM%%lib/ghdl/ieee/v08/numeric_std_unsigned-body.o
+%%LLVM%%lib/ghdl/ieee/v08/numeric_std_unsigned.o
+%%LLVM%%lib/ghdl/ieee/v08/prmtvs_b.o
+%%LLVM%%lib/ghdl/ieee/v08/prmtvs_p.o
+%%LLVM%%lib/ghdl/ieee/v08/std_logic_1164-body.o
+%%LLVM%%lib/ghdl/ieee/v08/std_logic_1164.o
+%%LLVM%%lib/ghdl/ieee/v08/std_logic_arith.o
+%%LLVM%%lib/ghdl/ieee/v08/std_logic_misc-body.o
+%%LLVM%%lib/ghdl/ieee/v08/std_logic_misc.o
+%%LLVM%%lib/ghdl/ieee/v08/std_logic_signed.o
+%%LLVM%%lib/ghdl/ieee/v08/std_logic_textio.o
+%%LLVM%%lib/ghdl/ieee/v08/std_logic_unsigned.o
+%%LLVM%%lib/ghdl/ieee/v08/timing_b.o
+%%LLVM%%lib/ghdl/ieee/v08/timing_p.o
+%%LLVM%%lib/ghdl/ieee/v08/upf-body.o
+%%LLVM%%lib/ghdl/ieee/v08/upf.o
+lib/ghdl/ieee/v87/ieee-obj87.cf
+%%LLVM%%lib/ghdl/ieee/v87/numeric_bit-body.o
+%%LLVM%%lib/ghdl/ieee/v87/numeric_bit.o
+%%LLVM%%lib/ghdl/ieee/v87/numeric_std-body.o
+%%LLVM%%lib/ghdl/ieee/v87/numeric_std.o
+%%LLVM%%lib/ghdl/ieee/v87/std_logic_1164-body.o
+%%LLVM%%lib/ghdl/ieee/v87/std_logic_1164.o
+%%LLVM%%lib/ghdl/ieee/v87/std_logic_arith.o
+%%LLVM%%lib/ghdl/ieee/v87/std_logic_misc-body.o
+%%LLVM%%lib/ghdl/ieee/v87/std_logic_misc.o
+%%LLVM%%lib/ghdl/ieee/v87/std_logic_signed.o
+%%LLVM%%lib/ghdl/ieee/v87/std_logic_textio.o
+%%LLVM%%lib/ghdl/ieee/v87/std_logic_unsigned.o
+%%LLVM%%lib/ghdl/ieee/v87/upf-body.o
+%%LLVM%%lib/ghdl/ieee/v87/upf.o
+%%LLVM%%lib/ghdl/ieee/v87/vital_primitives-body.o
+%%LLVM%%lib/ghdl/ieee/v87/vital_primitives.o
+%%LLVM%%lib/ghdl/ieee/v87/vital_timing-body.o
+%%LLVM%%lib/ghdl/ieee/v87/vital_timing.o
+lib/ghdl/ieee/v93/ieee-obj93.cf
+%%LLVM%%lib/ghdl/ieee/v93/math_complex-body.o
+%%LLVM%%lib/ghdl/ieee/v93/math_complex.o
+%%LLVM%%lib/ghdl/ieee/v93/math_real-body.o
+%%LLVM%%lib/ghdl/ieee/v93/math_real.o
+%%LLVM%%lib/ghdl/ieee/v93/memory_b.o
+%%LLVM%%lib/ghdl/ieee/v93/memory_p.o
+%%LLVM%%lib/ghdl/ieee/v93/numeric_bit-body.o
+%%LLVM%%lib/ghdl/ieee/v93/numeric_bit.o
+%%LLVM%%lib/ghdl/ieee/v93/numeric_std-body.o
+%%LLVM%%lib/ghdl/ieee/v93/numeric_std.o
+%%LLVM%%lib/ghdl/ieee/v93/prmtvs_b.o
+%%LLVM%%lib/ghdl/ieee/v93/prmtvs_p.o
+%%LLVM%%lib/ghdl/ieee/v93/std_logic_1164-body.o
+%%LLVM%%lib/ghdl/ieee/v93/std_logic_1164.o
+%%LLVM%%lib/ghdl/ieee/v93/std_logic_arith.o
+%%LLVM%%lib/ghdl/ieee/v93/std_logic_misc-body.o
+%%LLVM%%lib/ghdl/ieee/v93/std_logic_misc.o
+%%LLVM%%lib/ghdl/ieee/v93/std_logic_signed.o
+%%LLVM%%lib/ghdl/ieee/v93/std_logic_textio.o
+%%LLVM%%lib/ghdl/ieee/v93/std_logic_unsigned.o
+%%LLVM%%lib/ghdl/ieee/v93/timing_b.o
+%%LLVM%%lib/ghdl/ieee/v93/timing_p.o
+%%LLVM%%lib/ghdl/ieee/v93/upf-body.o
+%%LLVM%%lib/ghdl/ieee/v93/upf.o
+%%LLVM%%lib/ghdl/libgrt.a
+lib/ghdl/src/ieee/math_complex-body.vhdl
+lib/ghdl/src/ieee/math_complex.vhdl
+lib/ghdl/src/ieee/math_real-body.vhdl
+lib/ghdl/src/ieee/math_real.vhdl
+lib/ghdl/src/ieee/v87/numeric_bit-body.vhdl
+lib/ghdl/src/ieee/v87/numeric_bit.vhdl
+lib/ghdl/src/ieee/v87/numeric_std-body.vhdl
+lib/ghdl/src/ieee/v87/numeric_std.vhdl
+lib/ghdl/src/ieee/v87/std_logic_1164-body.vhdl
+lib/ghdl/src/ieee/v87/std_logic_1164.vhdl
+lib/ghdl/src/ieee/v93/numeric_bit-body.vhdl
+lib/ghdl/src/ieee/v93/numeric_bit.vhdl
+lib/ghdl/src/ieee/v93/numeric_std-body.vhdl
+lib/ghdl/src/ieee/v93/numeric_std.vhdl
+lib/ghdl/src/ieee/v93/std_logic_1164-body.vhdl
+lib/ghdl/src/ieee/v93/std_logic_1164.vhdl
+lib/ghdl/src/ieee2008/LICENSE
+lib/ghdl/src/ieee2008/fixed_float_types.vhdl
+lib/ghdl/src/ieee2008/fixed_generic_pkg-body.vhdl
+lib/ghdl/src/ieee2008/fixed_generic_pkg.vhdl
+lib/ghdl/src/ieee2008/fixed_pkg.vhdl
+lib/ghdl/src/ieee2008/float_generic_pkg-body.vhdl
+lib/ghdl/src/ieee2008/float_generic_pkg.vhdl
+lib/ghdl/src/ieee2008/float_pkg.vhdl
+lib/ghdl/src/ieee2008/ieee_bit_context.vhdl
+lib/ghdl/src/ieee2008/ieee_std_context.vhdl
+lib/ghdl/src/ieee2008/math_complex-body.vhdl
+lib/ghdl/src/ieee2008/math_complex.vhdl
+lib/ghdl/src/ieee2008/math_real-body.vhdl
+lib/ghdl/src/ieee2008/math_real.vhdl
+lib/ghdl/src/ieee2008/numeric_bit-body.vhdl
+lib/ghdl/src/ieee2008/numeric_bit.vhdl
+lib/ghdl/src/ieee2008/numeric_bit_unsigned-body.vhdl
+lib/ghdl/src/ieee2008/numeric_bit_unsigned.vhdl
+lib/ghdl/src/ieee2008/numeric_std-body.vhdl
+lib/ghdl/src/ieee2008/numeric_std.vhdl
+lib/ghdl/src/ieee2008/numeric_std_unsigned-body.vhdl
+lib/ghdl/src/ieee2008/numeric_std_unsigned.vhdl
+lib/ghdl/src/ieee2008/std_logic_1164-body.vhdl
+lib/ghdl/src/ieee2008/std_logic_1164.vhdl
+lib/ghdl/src/ieee2008/std_logic_textio.vhdl
+lib/ghdl/src/std/env-body.vhdl
+lib/ghdl/src/std/env.vhdl
+lib/ghdl/src/std/v08/standard.vhdl
+lib/ghdl/src/std/v08/textio-body.vhdl
+lib/ghdl/src/std/v08/textio.vhdl
+lib/ghdl/src/std/v87/standard.vhdl
+lib/ghdl/src/std/v87/textio-body.vhdl
+lib/ghdl/src/std/v87/textio.vhdl
+lib/ghdl/src/std/v93/standard.vhdl
+lib/ghdl/src/std/v93/textio-body.vhdl
+lib/ghdl/src/std/v93/textio.vhdl
+lib/ghdl/src/synopsys/std_logic_arith.vhdl
+lib/ghdl/src/synopsys/std_logic_misc-body.vhdl
+lib/ghdl/src/synopsys/std_logic_misc.vhdl
+lib/ghdl/src/synopsys/std_logic_signed.vhdl
+lib/ghdl/src/synopsys/std_logic_textio.vhdl
+lib/ghdl/src/synopsys/std_logic_unsigned.vhdl
+lib/ghdl/src/synopsys/v08/std_logic_misc-body.vhdl
+lib/ghdl/src/synopsys/v08/std_logic_misc.vhdl
+lib/ghdl/src/upf/upf-body.vhdl
+lib/ghdl/src/upf/upf.vhdl
+lib/ghdl/src/vital2000/memory_b.vhdl
+lib/ghdl/src/vital2000/memory_p.vhdl
+lib/ghdl/src/vital2000/prmtvs_b.vhdl
+lib/ghdl/src/vital2000/prmtvs_p.vhdl
+lib/ghdl/src/vital2000/timing_b.vhdl
+lib/ghdl/src/vital2000/timing_p.vhdl
+lib/ghdl/src/vital95/vital_primitives-body.vhdl
+lib/ghdl/src/vital95/vital_primitives.vhdl
+lib/ghdl/src/vital95/vital_timing-body.vhdl
+lib/ghdl/src/vital95/vital_timing.vhdl
+%%LLVM%%lib/ghdl/std/v08/env-body.o
+%%LLVM%%lib/ghdl/std/v08/env.o
+lib/ghdl/std/v08/std-obj08.cf
+%%LLVM%%lib/ghdl/std/v08/std_standard.o
+%%LLVM%%lib/ghdl/std/v08/textio-body.o
+%%LLVM%%lib/ghdl/std/v08/textio.o
+lib/ghdl/std/v87/std-obj87.cf
+%%LLVM%%lib/ghdl/std/v87/std_standard.o
+%%LLVM%%lib/ghdl/std/v87/textio-body.o
+%%LLVM%%lib/ghdl/std/v87/textio.o
+lib/ghdl/std/v93/std-obj93.cf
+%%LLVM%%lib/ghdl/std/v93/std_standard.o
+%%LLVM%%lib/ghdl/std/v93/textio-body.o
+%%LLVM%%lib/ghdl/std/v93/textio.o
+lib/ghdl/vendors/README.md
+lib/ghdl/vendors/compile-altera.ps1
+lib/ghdl/vendors/compile-altera.sh
+lib/ghdl/vendors/compile-intel.ps1
+lib/ghdl/vendors/compile-intel.sh
+lib/ghdl/vendors/compile-lattice.ps1
+lib/ghdl/vendors/compile-lattice.sh
+lib/ghdl/vendors/compile-osvvm.ps1
+lib/ghdl/vendors/compile-osvvm.sh
+lib/ghdl/vendors/compile-uvvm.ps1
+lib/ghdl/vendors/compile-uvvm.sh
+lib/ghdl/vendors/compile-xilinx-ise.ps1
+lib/ghdl/vendors/compile-xilinx-ise.sh
+lib/ghdl/vendors/compile-xilinx-vivado.ps1
+lib/ghdl/vendors/compile-xilinx-vivado.sh
+lib/ghdl/vendors/config.psm1
+lib/ghdl/vendors/config.sh
+lib/ghdl/vendors/filter.analyze.sh
+lib/ghdl/vendors/shared.psm1
+lib/ghdl/vendors/shared.sh
+lib/libghdlvpi.so
+lib/libghw.so