aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-01-16 17:34:03 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-01-16 17:34:03 +0000
commit30fe0b26ba918dd05c785adc129de0ec061b0f0c (patch)
tree02428ab5015b51adc7135541ebb8ea61114e36bd
parent3c6c44b9f72c9fa443c6f4339117ae71422487c5 (diff)
downloadports-30fe0b26ba918dd05c785adc129de0ec061b0f0c.tar.gz
ports-30fe0b26ba918dd05c785adc129de0ec061b0f0c.zip
Stage support
Notes
Notes: svn path=/head/; revision=339943
-rw-r--r--audio/eawplus/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/audio/eawplus/Makefile b/audio/eawplus/Makefile
index 7dbd42076d58..934c19632346 100644
--- a/audio/eawplus/Makefile
+++ b/audio/eawplus/Makefile
@@ -16,14 +16,13 @@ RUN_DEPENDS= ${LOCALBASE}/share/eawpats/acbass.pat:${PORTSDIR}/audio/eawpats \
${LOCALBASE}/share/guspat/inst/GUS/acbass.pat:${PORTSDIR}/audio/guspat
NO_CDROM= Some of the patches are marked no-commercial-use
-NO_STAGE= yes
NO_WRKSUBDIR= yes
TIMIDITY_DATADIR= share/timidity
PLIST_SUB= TIMIDITY_DATADIR=${TIMIDITY_DATADIR}
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
post-extract:
@${RM} -f ${WRKSRC}/timidity/inst/GUS/power/h-hihatp.pat.orig
@@ -35,14 +34,12 @@ do-build:
${FILESDIR}/timidity.cfg > ${WRKDIR}/timidity.cfg
do-install:
- @${MKDIR} ${DATADIR}
- @${CP} -pr ${WRKSRC}/timidity/* ${DATADIR}
- @${MKDIR} ${PREFIX}/${TIMIDITY_DATADIR}
- @${INSTALL_DATA} ${WRKDIR}/timidity.cfg \
- ${PREFIX}/${TIMIDITY_DATADIR}/timidity.cfg-eawplus
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_MAN} ${WRKSRC}/doc/*/*.txt.gz ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${CP} -pr ${WRKSRC}/timidity/* ${STAGEDIR}${DATADIR}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${TIMIDITY_DATADIR}
+ ${INSTALL_DATA} ${WRKDIR}/timidity.cfg \
+ ${STAGEDIR}${PREFIX}/${TIMIDITY_DATADIR}/timidity.cfg-eawplus
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*/*.txt.gz ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>