aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2024-01-21 18:08:41 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2024-01-21 18:08:41 +0000
commit319b2de7f05f71a55f46631a8f01167cbc1ac803 (patch)
tree10e543f0f87bd7a440315d68480d32172733edb9
parent752d5c1dff15bafda4e6766e58b6ac236d0703cf (diff)
downloadports-319b2de7f05f71a55f46631a8f01167cbc1ac803.tar.gz
ports-319b2de7f05f71a55f46631a8f01167cbc1ac803.zip
*/*: Simply future removal of GNU_CONFIGURE_MANPREFIX
Simplify the future removal of GNU_CONFIGURE_MANPREFIX after the manprefix migration is complete. The current placement of GNU_CONFIGURE_MANPREFIX will not result in consecutive blank lines or comments when lines containing GNU_CONFIGURE_MANPREFIX are removed in batches. Notified by: mat
-rw-r--r--audio/gbsplay/Makefile4
-rw-r--r--audio/libadplug/Makefile4
-rw-r--r--audio/ocp/Makefile4
-rw-r--r--audio/shairport-sync/Makefile4
-rw-r--r--audio/xmp/Makefile4
-rw-r--r--ftp/weex/Makefile4
-rw-r--r--games/xcowsay/Makefile4
-rw-r--r--graphics/exrtools/Makefile2
-rw-r--r--graphics/iec16022/Makefile4
-rw-r--r--graphics/largetifftools/Makefile2
-rw-r--r--graphics/recoverjpeg/Makefile2
-rw-r--r--mail/isync/Makefile4
-rw-r--r--math/form/Makefile4
-rw-r--r--misc/talkfilters/Makefile4
-rw-r--r--net-mgmt/tcpreplay/Makefile4
-rw-r--r--net/tsocks/Makefile4
-rw-r--r--security/op/Makefile4
-rw-r--r--shells/bash/Makefile4
-rw-r--r--sysutils/dvdbackup/Makefile4
-rw-r--r--sysutils/magicrescue/Makefile4
-rw-r--r--x11-fm/xfe/Makefile4
-rw-r--r--x11/xterm/Makefile4
22 files changed, 19 insertions, 63 deletions
diff --git a/audio/gbsplay/Makefile b/audio/gbsplay/Makefile
index d95bd2faf2e3..17d7a3008fec 100644
--- a/audio/gbsplay/Makefile
+++ b/audio/gbsplay/Makefile
@@ -19,6 +19,7 @@ USE_GITHUB= yes
GH_ACCOUNT= mmitch
HAS_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS+= --mandir=${PREFIX}/share/man \
--prefix=${PREFIX} \
@@ -41,9 +42,6 @@ NLS_USES= gettext
NLS_CONFIGURE_OFF= --disable-i18n
NLS_LDFLAGS= -lintl
-# remove after manprefix migration
-GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
-
post-patch:
@${REINPLACE_CMD} -e "s|/etc/\(gbsplayrc\)|${PREFIX}/etc/\1|" \
${WRKSRC}/man/gbsplay.in.1 ${WRKSRC}/man/gbsplayrc.in.5
diff --git a/audio/libadplug/Makefile b/audio/libadplug/Makefile
index e44b451beb16..83af3dd7a41f 100644
--- a/audio/libadplug/Makefile
+++ b/audio/libadplug/Makefile
@@ -21,6 +21,7 @@ USE_GITHUB= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS+= --enable-maintainer-mode
INSTALL_TARGET= install-strip
@@ -28,7 +29,4 @@ INSTALL_TARGET= install-strip
INFO= libadplug
PLIST_SUB+= PORTVERSION=${PORTVERSION}
-# remove after manprefix migration
-GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
-
.include <bsd.port.mk>
diff --git a/audio/ocp/Makefile b/audio/ocp/Makefile
index d48ff259c4ba..094537b908f9 100644
--- a/audio/ocp/Makefile
+++ b/audio/ocp/Makefile
@@ -28,6 +28,7 @@ USES= compiler:c11 dos2unix gmake gnome iconv jpeg localbase:ldflags \
makeinfo ncurses pkgconfig shared-mime-info tar:xz
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS= --libdir=${PREFIX}/lib \
--with-dir-suffix="" \
--without-sdl \
@@ -99,9 +100,6 @@ TIMIDITY_CFG= ${LOCALBASE}/share/timidity/timidity.cfg
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
-# remove after manprefix migration
-GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
-
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/ocp
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/ocp/*.so
diff --git a/audio/shairport-sync/Makefile b/audio/shairport-sync/Makefile
index 75feedeb8a27..ff0310be718b 100644
--- a/audio/shairport-sync/Makefile
+++ b/audio/shairport-sync/Makefile
@@ -21,6 +21,7 @@ GH_ACCOUNT= mikebrady
USE_RC_SUBR= ${PORTNAME}
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS= --sysconfdir=${LOCALBASE}/etc \
--with-avahi \
--with-libdaemon \
@@ -67,9 +68,6 @@ PULSEAUDIO_CONFIGURE_ON= --with-pa
SNDIO_LIB_DEPENDS= libsndio.so:audio/sndio
SNDIO_CONFIGURE_ON= --with-sndio
-# remove after manprefix migration
-GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
-
post-patch:
@${REINPLACE_CMD} -e 's/-Wno-clobbered -Wno-psabi //' \
${WRKSRC}/Makefile.am
diff --git a/audio/xmp/Makefile b/audio/xmp/Makefile
index 2caaf87c0c17..455690ce82bb 100644
--- a/audio/xmp/Makefile
+++ b/audio/xmp/Makefile
@@ -15,6 +15,7 @@ LIB_DEPENDS= libxmp.so:audio/libxmp
USES= gmake localbase:ldflags pkgconfig
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc
@@ -34,9 +35,6 @@ PULSEAUDIO_CONFIGURE_ENABLE= pulseaudio
SNDIO_LIB_DEPENDS= libsndio.so:audio/sndio
-# remove after manprefix migration
-GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
-
post-patch:
@${REINPLACE_CMD} -e 's|\ install-conf||' ${WRKSRC}/Makefile.in
diff --git a/ftp/weex/Makefile b/ftp/weex/Makefile
index c4a28a381b99..6bba7da974de 100644
--- a/ftp/weex/Makefile
+++ b/ftp/weex/Makefile
@@ -15,6 +15,7 @@ LICENSE_FILE= ${WRKSRC}/doc/COPYING
USES= autoreconf cpe gettext-tools gmake ssl
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS= --with-cafile=${LOCALBASE}/share/certs/ca-root-nss.crt
CPPFLAGS+= -I${OPENSSLINC}
LIBS+= -L${OPENSSLLIB}
@@ -26,9 +27,6 @@ OPTIONS_SUB= yes
NLS_USES= gettext-runtime
NLS_CONFIGURE_ENABLE= nls
-# remove after manprefix migration
-GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
-
post-patch:
@${RM} -r ${WRKSRC}/intl
diff --git a/games/xcowsay/Makefile b/games/xcowsay/Makefile
index eacdf80bace5..dee3e30933cf 100644
--- a/games/xcowsay/Makefile
+++ b/games/xcowsay/Makefile
@@ -19,6 +19,7 @@ USES= gettext gmake gnome pkgconfig
USE_CSTD= c99
USE_GNOME= cairo gdkpixbuf2 gtk30
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
OPTIONS_DEFINE= DBUS
@@ -27,7 +28,4 @@ DBUS_LIB_DEPENDS= libdbus-1.so:devel/dbus \
DBUS_CONFIGURE_ENABLE= dbus
DBUS_CFLAGS= -DWITH_DBUS
-# remove after manprefix migration
-GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
-
.include <bsd.port.mk>
diff --git a/graphics/exrtools/Makefile b/graphics/exrtools/Makefile
index 94b0861bffea..3dbe824bb84f 100644
--- a/graphics/exrtools/Makefile
+++ b/graphics/exrtools/Makefile
@@ -18,8 +18,6 @@ LIB_DEPENDS= libImath.so:math/Imath \
USES= compiler:c++11-lang gmake jpeg localbase:ldflags pkgconfig
GNU_CONFIGURE= yes
-
-# remove after manprefix migration
GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
post-patch:
diff --git a/graphics/iec16022/Makefile b/graphics/iec16022/Makefile
index ca62fdad4591..8e85da518658 100644
--- a/graphics/iec16022/Makefile
+++ b/graphics/iec16022/Makefile
@@ -15,12 +15,10 @@ LIB_DEPENDS= libpopt.so:devel/popt
USES= gmake libtool pathfix pkgconfig tar:xz
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
INSTALL_TARGET= install-strip
CFLAGS+= -fPIC
-# remove after manprefix migration
-GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
-
.include <bsd.port.mk>
diff --git a/graphics/largetifftools/Makefile b/graphics/largetifftools/Makefile
index d4d4ccfed299..c76a22fa0121 100644
--- a/graphics/largetifftools/Makefile
+++ b/graphics/largetifftools/Makefile
@@ -17,8 +17,6 @@ LIB_DEPENDS= libpng.so:graphics/png \
USES= autoreconf jpeg localbase:ldconfig tar:bzip2
GNU_CONFIGURE= yes
-
-# remove after manprefix migration
GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
.include <bsd.port.mk>
diff --git a/graphics/recoverjpeg/Makefile b/graphics/recoverjpeg/Makefile
index fd4983ff3c69..7995718b127f 100644
--- a/graphics/recoverjpeg/Makefile
+++ b/graphics/recoverjpeg/Makefile
@@ -16,8 +16,6 @@ RUN_DEPENDS= exif:graphics/exif
USES= magick:6,run python shebangfix
SHEBANG_FILES= scripts/remove-duplicates
GNU_CONFIGURE= yes
-
-# remove after manprefix migration
GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
.include <bsd.port.mk>
diff --git a/mail/isync/Makefile b/mail/isync/Makefile
index 1f8d00f50b2d..102c4822f7d7 100644
--- a/mail/isync/Makefile
+++ b/mail/isync/Makefile
@@ -18,6 +18,7 @@ CPE_VENDOR= isync_project
USE_PERL5= build
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS= --with-sasl=${LOCALBASE} \
--with-ssl=${OPENSSLLIB:H}
@@ -27,9 +28,6 @@ MAKE_ARGS+= SSL_LIBS="-L${OPENSSLLIB} -lssl -lcrypto"
CPPFLAGS+= -I${BDB_INCLUDE_DIR}
LDFLAGS+= -L${BDB_LIB_DIR}
-# remove after manprefix migration
-GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
-
post-patch:
@${REINPLACE_CMD} -e 's|: install-docDATA|:|g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|\$$(docdir)/examples|\$$(sysconfdir)|g' \
diff --git a/math/form/Makefile b/math/form/Makefile
index 1aa427f334a1..dd38ff7c9421 100644
--- a/math/form/Makefile
+++ b/math/form/Makefile
@@ -18,6 +18,7 @@ USE_GITHUB= yes
GH_ACCOUNT= vermaseren
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS+= --disable-native \
--enable-largefile \
--enable-scalar \
@@ -36,9 +37,6 @@ OPENMPI_CONFIGURE_ENABLE= parform
OPENMPI_CONFIGURE_ENV+= MPICC="${MPICC}" \
MPICXX="${MPICXX}"
-# remove after manprefix migration
-GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
-
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && (${OSVERSION} >= 1400091 || (${OSVERSION} >= 1302507 && \
diff --git a/misc/talkfilters/Makefile b/misc/talkfilters/Makefile
index 0f3bb0da3b08..d3a6375016f5 100644
--- a/misc/talkfilters/Makefile
+++ b/misc/talkfilters/Makefile
@@ -14,15 +14,13 @@ LICENSE= GPLv2
USES= libtool pathfix
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFLICTS= chef filters
SUB_FILES= pkg-message
INFO= talkfilters
-# remove after manprefix migration
-GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
-
post-extract:
@${ECHO} ${DO_NADA} > ${WRKSRC}/install-sh
@${CHMOD} +x ${WRKSRC}/install-sh
diff --git a/net-mgmt/tcpreplay/Makefile b/net-mgmt/tcpreplay/Makefile
index 735575fe89dc..50296fb6d678 100644
--- a/net-mgmt/tcpreplay/Makefile
+++ b/net-mgmt/tcpreplay/Makefile
@@ -18,6 +18,7 @@ USES= cpe gmake libtool pkgconfig tar:xz
CPE_VENDOR= broadcom
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
# libopts options are required when using autogen
CONFIGURE_ARGS= --disable-libopts-install \
--disable-local-libopts \
@@ -40,7 +41,4 @@ LIBPCAP_BASE_CONFIGURE_ON= --with-libpcap=/usr/lib
# needs .so version (see: 262976)
LIBPCAP_PORTS_LIB_DEPENDS= libpcap.so.1:net/libpcap
-# remove after manprefix migration
-GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
-
.include <bsd.port.mk>
diff --git a/net/tsocks/Makefile b/net/tsocks/Makefile
index 8afff55a97b5..c326ed48ea4d 100644
--- a/net/tsocks/Makefile
+++ b/net/tsocks/Makefile
@@ -17,6 +17,7 @@ USES= gmake
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS= --libdir=${PREFIX}/lib \
--with-conf=${PREFIX}/etc/tsocks.conf
@@ -37,9 +38,6 @@ MUTE_CONFIGURE_ON= --disable-debug
OLDMETHOD_CONFIGURE_ON= --enable-oldmethod
SOCKSDNS_CONFIGURE_ON= --enable-socksdns
-# remove after manprefix migration
-GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
-
post-patch:
@${REINPLACE_CMD} -e 's|/usr|${PREFIX}|' ${WRKSRC}/tsocks
diff --git a/security/op/Makefile b/security/op/Makefile
index c9646061c554..e6e5c20d4316 100644
--- a/security/op/Makefile
+++ b/security/op/Makefile
@@ -14,10 +14,8 @@ USE_GITHUB= yes
GH_ACCOUNT= dagwieers
GNU_CONFIGURE= yes
-CONFLICTS_INSTALL= security/1password-client
-
-# remove after manprefix migration
GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
+CONFLICTS_INSTALL= security/1password-client
post-configure:
@${REINPLACE_CMD} -e 's|\(OPENLOG_VOID\) 0|\1 1|' ${WRKSRC}/config.h
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 1bccb38b44ee..cb8a69084362 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -23,6 +23,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USES= bison cpe iconv localbase pathfix
CPE_VENDOR= gnu
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS+= --without-bash-malloc \
--disable-rpath \
--enable-disabled-builtins \
@@ -77,9 +78,6 @@ STANDARD_PATH= /sbin:/bin:/usr/sbin:/usr/bin
CPPFLAGS+= -DDEFAULT_PATH_VALUE='\"${STANDARD_PATH}:${LOCALBASE}/sbin:${LOCALBASE}/bin\"' \
-DSTANDARD_UTILS_PATH='\"${STANDARD_PATH}\"'
-# remove after manprefix migration
-GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
-
post-patch:
# Ensure y.tab.c is regenerated
${TOUCH} ${WRKSRC}/parse.y
diff --git a/sysutils/dvdbackup/Makefile b/sysutils/dvdbackup/Makefile
index b36d7b499303..84556e86c781 100644
--- a/sysutils/dvdbackup/Makefile
+++ b/sysutils/dvdbackup/Makefile
@@ -14,6 +14,7 @@ LIB_DEPENDS= libdvdread.so:multimedia/libdvdread
USES= gmake
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -28,9 +29,6 @@ OPTIONS_SUB= yes
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
-# remove after manprefix migration
-GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
-
post-patch:
@${REINPLACE_CMD} "s|/dev/dvd|${DEFAULT_DVD_DEVICE}|g" \
${WRKSRC}/src/main.c ${WRKSRC}/po/*.po ${WRKSRC}/po/*.pot \
diff --git a/sysutils/magicrescue/Makefile b/sysutils/magicrescue/Makefile
index 0a7894afc1be..aa1d45f57b4f 100644
--- a/sysutils/magicrescue/Makefile
+++ b/sysutils/magicrescue/Makefile
@@ -19,13 +19,11 @@ USE_PERL5= run
SHEBANG_FILES= magicsort tools/*.pl tools/checkrecipe
HAS_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS= --prefix=${PREFIX}
MAKE_ENV+= STAGEDIR=${STAGEDIR}
-# remove after manprefix migration
-GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
-
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/magicrescue \
${STAGEDIR}${PREFIX}/bin/dupemap
diff --git a/x11-fm/xfe/Makefile b/x11-fm/xfe/Makefile
index 11568385727c..4627d7b51d78 100644
--- a/x11-fm/xfe/Makefile
+++ b/x11-fm/xfe/Makefile
@@ -23,6 +23,7 @@ USE_GNOME= intltool
USE_XORG= x11 xcb xft xrandr xrender
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
LDFLAGS+= -pthread
@@ -33,9 +34,6 @@ NLS_USES= gettext
NLS_USES_OFF= gettext-tools
NLS_CONFIGURE_ENABLE= nls
-# remove after manprefix migration
-GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
-
post-patch:
.for i in XFileExplorer.cpp help.h xfedefs.h
@${REINPLACE_CMD} -e \
diff --git a/x11/xterm/Makefile b/x11/xterm/Makefile
index 5689dfcf6ccc..3bd53e21077d 100644
--- a/x11/xterm/Makefile
+++ b/x11/xterm/Makefile
@@ -22,6 +22,7 @@ USES= cpe localbase ncurses tar:tgz xorg
CPE_VENDOR= invisible-island
USE_XORG= ice x11 xext xft xmu xpm xt
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS+= --enable-narrowproto \
--with-utempter
@@ -81,9 +82,6 @@ XINERAMA_CONFIGURE_OFF= --without-xinerama
ICONVERSION= 1
-# remove after manprefix migration
-GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
-
post-extract:
@${CP} ${WRKDIR}/bsd-xterm-icons-${ICONVERSION}/*.png \
${WRKDIR}/bsd-xterm-icons-${ICONVERSION}/*.xpm \