aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2006-11-05 03:59:12 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2006-11-05 03:59:12 +0000
commit31ad592f90e818f64b067aaa86f01c660a06153d (patch)
tree9164b8e7e41885f711dc43ca3bd1e112cbd34718
parentd1e1e59912e7541e154a7b1817a40d2b6effb0bd (diff)
downloadports-31ad592f90e818f64b067aaa86f01c660a06153d.tar.gz
ports-31ad592f90e818f64b067aaa86f01c660a06153d.zip
INSTALLS_SHLIB -> USE_LDCONFIG.
Found by: portlint (cports.sh)
Notes
Notes: svn path=/head/; revision=176403
-rw-r--r--textproc/enchant/Makefile2
-rw-r--r--textproc/libcroco/Makefile2
-rw-r--r--textproc/libxml/Makefile2
-rw-r--r--textproc/libxml2/Makefile2
-rw-r--r--textproc/libxslt/Makefile2
-rw-r--r--textproc/link-grammar/Makefile2
-rw-r--r--www/libghttp/Makefile2
7 files changed, 7 insertions, 7 deletions
diff --git a/textproc/enchant/Makefile b/textproc/enchant/Makefile
index e732622cf0d0..16d2a196af7e 100644
--- a/textproc/enchant/Makefile
+++ b/textproc/enchant/Makefile
@@ -17,7 +17,7 @@ COMMENT= Dictionary/spellchecking framework
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
USE_GNOME= gnomehack gnometarget glib20 ltverhack
CONFIGURE_ARGS= --disable-hspell \
--disable-uspell
diff --git a/textproc/libcroco/Makefile b/textproc/libcroco/Makefile
index ee53dafec50d..2cfff2295281 100644
--- a/textproc/libcroco/Makefile
+++ b/textproc/libcroco/Makefile
@@ -17,7 +17,7 @@ COMMENT= CSS2 parsing library
USE_BZIP2= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
USE_GNOME= gnomehack glib20 libxml2 ltverhack
PLIST_SUB= VERSION="0.6"
diff --git a/textproc/libxml/Makefile b/textproc/libxml/Makefile
index 831845e86187..8cbfae9487c4 100644
--- a/textproc/libxml/Makefile
+++ b/textproc/libxml/Makefile
@@ -18,7 +18,7 @@ COMMENT= XML parser library for GNOME
USE_GMAKE= yes
USE_GNOME= pkgconfig
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
pre-patch:
@${FIND} ${WRKSRC} -name "*.[ch]" | ${XARGS} ${REINPLACE_CMD} -e \
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 459c465dbb9f..22baf9722900 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -30,7 +30,7 @@ USE_GMAKE= yes
USE_ICONV= yes
GNU_CONFIGURE= yes
USE_GNOME?= gnomehack gnometarget pkgconfig
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ARGS?= --with-iconv=${LOCALBASE} \
--with-html-dir=${PREFIX}/share/doc \
--with-html-subdir=${PORTNAME} \
diff --git a/textproc/libxslt/Makefile b/textproc/libxslt/Makefile
index 047e8e061626..8ec304a27f8e 100644
--- a/textproc/libxslt/Makefile
+++ b/textproc/libxslt/Makefile
@@ -22,7 +22,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
USE_GNOME?= gnomehack gnometarget libxml2
CONFIGURE_ARGS?= --with-html-dir=${PREFIX}/share/doc \
--without-python
diff --git a/textproc/link-grammar/Makefile b/textproc/link-grammar/Makefile
index 21ff0f00ce2e..c8d7401b44ca 100644
--- a/textproc/link-grammar/Makefile
+++ b/textproc/link-grammar/Makefile
@@ -16,7 +16,7 @@ COMMENT= A grammar checking library
USE_GNOME= gnometarget ltverhack
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
DOCS= AUTHORS LICENSE MAINTAINERS README
diff --git a/www/libghttp/Makefile b/www/libghttp/Makefile
index 7fc920d9c077..fb2aead48be0 100644
--- a/www/libghttp/Makefile
+++ b/www/libghttp/Makefile
@@ -16,6 +16,6 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME http client library
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
.include <bsd.port.mk>