aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2021-12-14 16:46:17 +0000
committerDima Panov <fluffy@FreeBSD.org>2021-12-14 18:07:00 +0000
commit31b0a37de2f4de1b1b33a4a0856e538321954ede (patch)
tree36de66e978601deebd8177d4603a794fcfd34280
parent9d362e791d8a3e4485dfae1a4da0de7541b826b2 (diff)
downloadports-31b0a37de2f4de1b1b33a4a0856e538321954ede.tar.gz
ports-31b0a37de2f4de1b1b33a4a0856e538321954ede.zip
graphics/recastnavigation: add port (+)
Recastnavigation is an art navigation mesh construction toolset for games. Currntly recuired by upcoming games/openmw update
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/recastnavigation/Makefile19
-rw-r--r--graphics/recastnavigation/distinfo3
-rw-r--r--graphics/recastnavigation/pkg-descr7
-rw-r--r--graphics/recastnavigation/pkg-plist39
5 files changed, 69 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 9f3dd3febb50..8038dba8ac13 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -959,6 +959,7 @@
SUBDIR += reactphysics3d
SUBDIR += reallyslick
SUBDIR += realsr-ncnn-vulkan
+ SUBDIR += recastnavigation
SUBDIR += recoverjpeg
SUBDIR += renrot
SUBDIR += repng2jpeg
diff --git a/graphics/recastnavigation/Makefile b/graphics/recastnavigation/Makefile
new file mode 100644
index 000000000000..864363588bbd
--- /dev/null
+++ b/graphics/recastnavigation/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= recastnavigation
+PORTVERSION= 1.5.1
+CATEGORIES= graphics
+
+MAINTAINER= fluffy@FreeBSD.org
+COMMENT= Art navigation mesh construction toolset for games
+
+USES= cmake compiler:c++17-lang gl openal pkgconfig sdl xorg
+USE_GL= gl
+USE_SDL= sdl2
+USE_GITHUB= yes
+GH_TUPLE= recastnavigation:recastnavigation:e75adf86f91eb3082220085e42dda62679f9a3ea
+
+CMAKE_ARGS= -DBUILD_SHARED_LIBS=ON \
+ -DRECASTNAVIGATION_DEMO=OFF \
+ -DRECASTNAVIGATION_TESTS=OFF \
+ -DRECASTNAVIGATION_EXAMPLES=OFF
+
+.include <bsd.port.mk>
diff --git a/graphics/recastnavigation/distinfo b/graphics/recastnavigation/distinfo
new file mode 100644
index 000000000000..d98bfb285d06
--- /dev/null
+++ b/graphics/recastnavigation/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1639412872
+SHA256 (recastnavigation-recastnavigation-1.5.1-e75adf86f91eb3082220085e42dda62679f9a3ea_GH0.tar.gz) = c647e307d6cc62ba00bfd888e82da83844bf1e72f2c98bed2f1d95bac229b950
+SIZE (recastnavigation-recastnavigation-1.5.1-e75adf86f91eb3082220085e42dda62679f9a3ea_GH0.tar.gz) = 1542425
diff --git a/graphics/recastnavigation/pkg-descr b/graphics/recastnavigation/pkg-descr
new file mode 100644
index 000000000000..4bf5640f5483
--- /dev/null
+++ b/graphics/recastnavigation/pkg-descr
@@ -0,0 +1,7 @@
+Recast is state of the art navigation mesh construction toolset for games.
+
+It is automatic, which means that you can throw any level geometry at it and you will get robust mesh out
+It is fast which means swift turnaround times for level designers
+It is open source so it comes with full source and you can customize it to your heart's content.
+
+WWW: https://github.com/recastnavigation/recastnavigation/
diff --git a/graphics/recastnavigation/pkg-plist b/graphics/recastnavigation/pkg-plist
new file mode 100644
index 000000000000..73c999e2bedf
--- /dev/null
+++ b/graphics/recastnavigation/pkg-plist
@@ -0,0 +1,39 @@
+include/recastnavigation/DebugDraw.h
+include/recastnavigation/DetourAlloc.h
+include/recastnavigation/DetourAssert.h
+include/recastnavigation/DetourCommon.h
+include/recastnavigation/DetourCrowd.h
+include/recastnavigation/DetourDebugDraw.h
+include/recastnavigation/DetourLocalBoundary.h
+include/recastnavigation/DetourMath.h
+include/recastnavigation/DetourNavMesh.h
+include/recastnavigation/DetourNavMeshBuilder.h
+include/recastnavigation/DetourNavMeshQuery.h
+include/recastnavigation/DetourNode.h
+include/recastnavigation/DetourObstacleAvoidance.h
+include/recastnavigation/DetourPathCorridor.h
+include/recastnavigation/DetourPathQueue.h
+include/recastnavigation/DetourProximityGrid.h
+include/recastnavigation/DetourStatus.h
+include/recastnavigation/DetourTileCache.h
+include/recastnavigation/DetourTileCacheBuilder.h
+include/recastnavigation/Recast.h
+include/recastnavigation/RecastAlloc.h
+include/recastnavigation/RecastAssert.h
+include/recastnavigation/RecastDebugDraw.h
+include/recastnavigation/RecastDump.h
+lib/libDebugUtils.so
+lib/libDebugUtils.so.1
+lib/libDebugUtils.so.1.0.0
+lib/libDetour.so
+lib/libDetour.so.1
+lib/libDetour.so.1.0.0
+lib/libDetourCrowd.so
+lib/libDetourCrowd.so.1
+lib/libDetourCrowd.so.1.0.0
+lib/libDetourTileCache.so
+lib/libDetourTileCache.so.1
+lib/libDetourTileCache.so.1.0.0
+lib/libRecast.so
+lib/libRecast.so.1
+lib/libRecast.so.1.0.0