aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2022-02-23 10:05:29 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2022-03-09 10:07:53 +0000
commit31ced78684e69d7cde0974090e18240fbbf64f17 (patch)
tree5beaa923f158d3f8c77955da38500a0d1bcab591
parentc829c1f962eaa2a2c1eb2e2377f266b819d9df37 (diff)
downloadports-31ced78684e69d7cde0974090e18240fbbf64f17.tar.gz
ports-31ced78684e69d7cde0974090e18240fbbf64f17.zip
security/rubygem-ssh_data: new port 1.3.0
Required for gitlab-ce 14.8.
-rw-r--r--security/Makefile1
-rw-r--r--security/rubygem-ssh_data/Makefile19
-rw-r--r--security/rubygem-ssh_data/distinfo3
-rw-r--r--security/rubygem-ssh_data/pkg-descr12
4 files changed, 35 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 5a7a82855a5d..3c20119b266a 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1174,6 +1174,7 @@
SUBDIR += rubygem-securerandom
SUBDIR += rubygem-signet
SUBDIR += rubygem-six
+ SUBDIR += rubygem-ssh_data
SUBDIR += rubygem-sshkey
SUBDIR += rubygem-sshkit
SUBDIR += rubygem-sslshake
diff --git a/security/rubygem-ssh_data/Makefile b/security/rubygem-ssh_data/Makefile
new file mode 100644
index 000000000000..633c6983f8cf
--- /dev/null
+++ b/security/rubygem-ssh_data/Makefile
@@ -0,0 +1,19 @@
+# Created by: Matthias Fechner <mfechner@FreeBSD.org>
+
+PORTNAME= ssh_data
+PORTVERSION= 1.2.0
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+
+MAINTAINER= mfechner@FreeBSD.org
+COMMENT= Library for parsing SSH certificates
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-ssh_data/distinfo b/security/rubygem-ssh_data/distinfo
new file mode 100644
index 000000000000..66f06ce0a4a9
--- /dev/null
+++ b/security/rubygem-ssh_data/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1645607571
+SHA256 (rubygem/ssh_data-1.2.0.gem) = 7a99782b6bef6e21075fabaf4ff08fb2ffef5961d2838ce18597d6e504567b5c
+SIZE (rubygem/ssh_data-1.2.0.gem) = 16384
diff --git a/security/rubygem-ssh_data/pkg-descr b/security/rubygem-ssh_data/pkg-descr
new file mode 100644
index 000000000000..a5e75acd8b18
--- /dev/null
+++ b/security/rubygem-ssh_data/pkg-descr
@@ -0,0 +1,12 @@
+This is a Ruby library for processing SSH keys and certificates.
+
+The scope of this project is limited to processing and directly using keys and certificates.
+It can be used to generate SSH private keys, verify signatures using public keys, sign data
+using private keys, issue certificates using private keys, and parse certificates and public
+and private keys. This library supports RSA, DSA, ECDSA, and ED25519* keys. This library
+does not offer or intend to offer functionality for SSH connectivity, processing of SSH wire
+protocol data, or processing of other key formats or types.
+
+Project Status: Used by @github in production
+
+WWW: https://github.com/github/ssh_data