aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-26 11:51:42 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-26 12:16:01 +0000
commit31d521a0740f7680ef3b266adfa1ba943f92d322 (patch)
tree1306819a0f8f81350bfc9acc38a69131fd03ef26
parent09ce8deaafe01223e9e2cbb70ea062eafcb56f7a (diff)
downloadports-31d521a0740f7680ef3b266adfa1ba943f92d322.tar.gz
ports-31d521a0740f7680ef3b266adfa1ba943f92d322.zip
textproc/apertium: Fix build with llvm16
Sponsored by: The FreeBSD Foundation
-rw-r--r--textproc/apertium/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/textproc/apertium/Makefile b/textproc/apertium/Makefile
index 3e66788a38f9..0a7034a9fbae 100644
--- a/textproc/apertium/Makefile
+++ b/textproc/apertium/Makefile
@@ -44,4 +44,12 @@ INSTALL_TARGET= install-strip
CFLAGS+= -I${LOCALBASE}/include/utf8cpp
+.include <bsd.port.options.mk>
+
+post-patch:
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+ @${REINPLACE_CMD} -e 's|std::unary_function|std::__unary_function|' \
+ ${WRKSRC}/apertium/perceptron_spec.h
+.endif
+
.include <bsd.port.mk>