aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2019-12-24 08:03:19 +0000
committerBen Woods <woodsb02@FreeBSD.org>2019-12-24 08:03:19 +0000
commit321a6d5e7a2a2b4235406d7ea4caa43eacd8b36f (patch)
treee50203f921b4419a0b919ae5334bc183658eb2e4
parent94944299ece7b132b629a9a03c93c89ad05bf6ef (diff)
Add new port www/py-flask-mongoengine
Flask extension that provides integration with MongoEngine. It handles connection management for your app. You can also use WTForms as model forms for your models. WWW: https://github.com/mongoengine/flask-mongoengine PR: 242785 Submitted by: Goran Mekić <meka@tilda.center>
Notes
Notes: svn path=/head/; revision=520785
-rw-r--r--www/Makefile1
-rw-r--r--www/py-flask-mongoengine/Makefile36
-rw-r--r--www/py-flask-mongoengine/distinfo3
-rw-r--r--www/py-flask-mongoengine/files/patch-setup.py11
-rw-r--r--www/py-flask-mongoengine/pkg-descr5
5 files changed, 56 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 2cf8cea16f4a..e39a4399df25 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1636,6 +1636,7 @@
SUBDIR += py-flask-marshmallow
SUBDIR += py-flask-migrate
SUBDIR += py-flask-moment
+ SUBDIR += py-flask-mongoengine
SUBDIR += py-flask-oauthlib
SUBDIR += py-flask-peewee
SUBDIR += py-flask-principal
diff --git a/www/py-flask-mongoengine/Makefile b/www/py-flask-mongoengine/Makefile
new file mode 100644
index 000000000000..c43524494955
--- /dev/null
+++ b/www/py-flask-mongoengine/Makefile
@@ -0,0 +1,36 @@
+# $FreeBSD$
+
+PORTNAME= flask-mongoengine
+PORTVERSION= 0.9.5
+DISTVERSIONPREFIX= v
+CATEGORIES= www devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= meka@tilda.center
+COMMENT= Flask extension that provides integration with MongoEngine
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Flask>=0:www/py-flask@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Flask-WTF>=0:www/py-flask-wtf@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mongoengine>=0:databases/py-mongoengine@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}coverage>=0:devel/py-coverage@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}rednose>=0:devel/py-rednose@${PY_FLAVOR}
+
+USES= python:3.5+
+USE_GITHUB= yes # tests not packaged with PyPI sdist
+GH_ACCOUNT= MongoEngine
+USE_PYTHON= autoplist concurrent distutils
+
+TEST_ENV= PYTHONPATH=${WRKSRC}/src
+
+NO_ARCH= yes
+
+do-test:
+ cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} setup.py nosetests \
+ -e test_connection_default
+
+.include <bsd.port.mk>
diff --git a/www/py-flask-mongoengine/distinfo b/www/py-flask-mongoengine/distinfo
new file mode 100644
index 000000000000..5c696d6db70c
--- /dev/null
+++ b/www/py-flask-mongoengine/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1577167260
+SHA256 (MongoEngine-flask-mongoengine-v0.9.5_GH0.tar.gz) = af9122fbb1c516fe12e7afcae1f87d18ba0f3c846e927a2270b2e78d420d309d
+SIZE (MongoEngine-flask-mongoengine-v0.9.5_GH0.tar.gz) = 120281
diff --git a/www/py-flask-mongoengine/files/patch-setup.py b/www/py-flask-mongoengine/files/patch-setup.py
new file mode 100644
index 000000000000..186bfde1fcc5
--- /dev/null
+++ b/www/py-flask-mongoengine/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2019-12-24 07:50:35 UTC
++++ setup.py
+@@ -53,7 +53,7 @@ setup(
+ 'flask_mongoengine.wtf'],
+ include_package_data=True,
+ tests_require=test_requirements,
+- setup_requires=test_requirements, # Allow proper nose usage with setuptools and tox
++ # setup_requires=test_requirements, # Allow proper nose usage with setuptools and tox
+ description=description,
+ long_description=long_description,
+ classifiers=[
diff --git a/www/py-flask-mongoengine/pkg-descr b/www/py-flask-mongoengine/pkg-descr
new file mode 100644
index 000000000000..555c20105588
--- /dev/null
+++ b/www/py-flask-mongoengine/pkg-descr
@@ -0,0 +1,5 @@
+Flask extension that provides integration with MongoEngine. It handles
+connection management for your app. You can also use WTForms as model forms
+for your models.
+
+WWW: https://github.com/mongoengine/flask-mongoengine