aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2003-02-27 16:12:21 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2003-02-27 16:12:21 +0000
commit325e708294d95137045823163a60b10421e489ce (patch)
tree5a9d1a0e4d71c388d03911d94480c707eae2a79f
parent11e00240067cc93b9113e83bd27111aa7e20ff1d (diff)
downloadports-325e708294d95137045823163a60b10421e489ce.tar.gz
ports-325e708294d95137045823163a60b10421e489ce.zip
Add ruby-html-template, a Ruby library to use HTML as a template file
from CGI scripts.
Notes
Notes: svn path=/head/; revision=76576
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/ruby-html-template/Makefile40
-rw-r--r--textproc/ruby-html-template/distinfo1
-rw-r--r--textproc/ruby-html-template/pkg-descr5
-rw-r--r--textproc/ruby-html-template/pkg-plist18
5 files changed, 65 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 60b6d706b9b5..1baa683ea3e0 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -329,6 +329,7 @@
SUBDIR += ruby-gdome
SUBDIR += ruby-html-fillinform
SUBDIR += ruby-html-parser
+ SUBDIR += ruby-html-template
SUBDIR += ruby-htmlcompact
SUBDIR += ruby-htmlrepair
SUBDIR += ruby-htmlsplit
diff --git a/textproc/ruby-html-template/Makefile b/textproc/ruby-html-template/Makefile
new file mode 100644
index 000000000000..ad5efe05f3ff
--- /dev/null
+++ b/textproc/ruby-html-template/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: HTML/Template for Ruby
+# Date created: 28 February 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= html-template
+PORTVERSION= 0.16
+CATEGORIES= textproc www ruby
+MASTER_SITES= http://shebang.jp/src/ruby/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= A Ruby library to use HTML as a template file from CGI scripts
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+RUBY_SETUP= install.rb
+
+DOCS_EN= ChangeLog \
+ README \
+ html-template.rd
+DOCS_JA= html-template.ja.rd
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/example/ ${RUBY_MODEXAMPLESDIR}/
+ ${MKDIR} ${RUBY_MODDOCDIR}/ja
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ja/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/ruby-html-template/distinfo b/textproc/ruby-html-template/distinfo
new file mode 100644
index 000000000000..7d41a8d666dc
--- /dev/null
+++ b/textproc/ruby-html-template/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/html-template-0.16.tar.gz) = e5ebf5a2ce5e1fa5fa2b1617f4060455
diff --git a/textproc/ruby-html-template/pkg-descr b/textproc/ruby-html-template/pkg-descr
new file mode 100644
index 000000000000..b6535357dade
--- /dev/null
+++ b/textproc/ruby-html-template/pkg-descr
@@ -0,0 +1,5 @@
+HTML/Template is a Ruby library to use HTML as a template file from
+CGI scripts.
+
+Author: IKEBE Tomohiro <ikebe@shebang.jp>
+WWW: http://shebang.jp/src/ruby/
diff --git a/textproc/ruby-html-template/pkg-plist b/textproc/ruby-html-template/pkg-plist
new file mode 100644
index 000000000000..9315fe262b31
--- /dev/null
+++ b/textproc/ruby-html-template/pkg-plist
@@ -0,0 +1,18 @@
+%%RUBY_SITELIBDIR%%/html/template.rb
+@unexec rmdir %D/%%RUBY_SITELIBDIR%%/html 2>/dev/null || true
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/cond.html
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/cond.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/env.html
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/env.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/envlist.html
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/envlist.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/envlist2.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/nest.html
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/nest.rb
+%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ChangeLog
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/html-template.rd
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/html-template.ja.rd
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%/ja
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%