aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2021-08-24 01:49:06 +0000
committerHiroki Sato <hrs@FreeBSD.org>2021-08-24 01:50:44 +0000
commit3268f3350f3d7f2f3343c26eeede622f06863f9a (patch)
treed2194ed44e4a5e4f3f0fc0405daa88fa534586d1
parentca3f9a8e0cdec34ec9ec6e4f5106a5dc0adf2675 (diff)
downloadports-3268f3350f3d7f2f3343c26eeede622f06863f9a.tar.gz
ports-3268f3350f3d7f2f3343c26eeede622f06863f9a.zip
dns/dnsperf: resurrect dnsperf and update it to 2.7.0
PR: 247478
-rw-r--r--MOVED1
-rw-r--r--dns/Makefile1
-rw-r--r--dns/dnsperf/Makefile36
-rw-r--r--dns/dnsperf/distinfo3
-rw-r--r--dns/dnsperf/pkg-descr18
5 files changed, 58 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index a182a3fdc4a4..a0f3ddc66b8b 100644
--- a/MOVED
+++ b/MOVED
@@ -14474,7 +14474,6 @@ sysutils/DTraceToolkit|sysutils/dtrace-toolkit|2020-04-26|Renamed to match the p
devel/k8048|devel/pickle|2020-04-28|Project renamed
net-mgmt/bgpq|net-mgmt/bgpq3|2020-04-30|Has expired: Use net-mgmt/bgpq3 or net-mgmt/bgpq4
net/boringtun||2020-04-30|Has expired: Status of the project and motivation is unclear
-dns/dnsperf||2020-04-30|Removed, depends on expired dns/bind914, not compatible with dns/bind916
dns/bind914|dns/bind916|2020-04-30|Has expired: End of life, please migrate to a newer version of BIND9
net/py-pcap|net/py-pypcap|2020-05-01|Has expired: Broken with python3 please consider using net/py-pypcap
x11-drivers/xf86-video-tseng||2020-05-01|Has expired: broken
diff --git a/dns/Makefile b/dns/Makefile
index 3902cd11bec8..83a25830788b 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -47,6 +47,7 @@
SUBDIR += dnsmasq
SUBDIR += dnsmasq-devel
SUBDIR += dnsmax-perl
+ SUBDIR += dnsperf
SUBDIR += dnsproxy
SUBDIR += dnsrecon
SUBDIR += dnsreflector
diff --git a/dns/dnsperf/Makefile b/dns/dnsperf/Makefile
new file mode 100644
index 000000000000..d323deaf61e4
--- /dev/null
+++ b/dns/dnsperf/Makefile
@@ -0,0 +1,36 @@
+# Created by: Edwin Groothuis (edwin@mavetju.org)
+
+PORTNAME= dnsperf
+PORTVERSION= 2.7.0
+DISTVERSIONPREFIX=v
+CATEGORIES= dns benchmarks net
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Performance measurement of Domain Name System (DNS) servers
+
+LICENSE= APACHE20
+
+LIB_DEPENDS= libnghttp2.so:www/libnghttp2 \
+ libck.so:devel/concurrencykit \
+ libldns.so:dns/ldns
+
+USES= autoreconf compiler:c11 libtool ssl
+USE_GITHUB= yes
+GH_ACCOUNT= DNS-OARC
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= libssl_LIBS="-lssl -L${OPENSSLLIB}" \
+ libssl_CFLAGS="-I${OPENSSLINC}" \
+ libcrypto_LIBS="-lcrypto -L${OPENSSLLIB}" \
+ libcrypto_CFLAGS="-I${OPENSSLINC}"
+MAKE_ENV= INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
+ INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
+ INSTALL_DATA="${INSTALL_DATA}" \
+ INSTALL_MAN="${INSTALL_MAN}"
+PLIST_FILES= bin/dnsperf \
+ bin/resperf \
+ bin/resperf-report \
+ man/man1/dnsperf.1.gz \
+ man/man1/resperf.1.gz
+
+.include <bsd.port.mk>
diff --git a/dns/dnsperf/distinfo b/dns/dnsperf/distinfo
new file mode 100644
index 000000000000..f4039645a435
--- /dev/null
+++ b/dns/dnsperf/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1629768486
+SHA256 (DNS-OARC-dnsperf-v2.7.0_GH0.tar.gz) = 3344201d1e09d2547ccce8b1501400a732229d804ab51a83bd994ab5642ccd51
+SIZE (DNS-OARC-dnsperf-v2.7.0_GH0.tar.gz) = 106420
diff --git a/dns/dnsperf/pkg-descr b/dns/dnsperf/pkg-descr
new file mode 100644
index 000000000000..cdd0971f9cd2
--- /dev/null
+++ b/dns/dnsperf/pkg-descr
@@ -0,0 +1,18 @@
+DNSPerf and ResPerf are free tools developed by Nominum that make it
+simple to gather accurate latency and throughput metrics for Domain
+Name System (DNS) servers. The latest version of the DNSPerf and
+ResPerf can be used with test files that include IPv6 queries.
+
+DNSPerf "self-paces" the DNS query load to simulate network conditions.
+New features in DNSPerf improve the precision of latency measurements
+and allow for per packet per-query latency reporting is possible.
+DNSPerf is now multithreaded, multiple DNSPerf clients can be supported
+in multicore systems (each client requires two cores). The output of
+DNSPerf has also been improved so it is more concise and useful.
+Latency data can be used to make detailed graphs so it is simple for
+network operators to take advantage of the data.
+
+ResPerf systematically increases the query rate and monitors the
+response rate to simulate caching DNS services.
+
+WWW: https://www.dns-oarc.net/tools/dnsperf