aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2022-08-17 18:46:24 +0000
committerCy Schubert <cy@FreeBSD.org>2022-11-07 18:38:54 +0000
commit32d885a48f080621960de681637d312c324c6225 (patch)
treed4e7298b7e95941746aeed05f1d2d1f25a9c5c0b
parent2fcb1d1e64f5c7b0a29f4091afa2612c26d91cb8 (diff)
downloadports-32d885a48f080621960de681637d312c324c6225.tar.gz
ports-32d885a48f080621960de681637d312c324c6225.zip
devel/binutils: Update from 2.37 to 2.39
Update our binutils port from 2.37 to 2.39. While at it change the distfile from tar.xz to tar.lz, which is 4 MB smaller than the .xz version. Exp-run PR: 265917 Exp-run by: antoine
-rw-r--r--devel/binutils/Makefile8
-rw-r--r--devel/binutils/distinfo6
-rw-r--r--devel/binutils/files/patch-etc_texi2pod.pl11
-rw-r--r--devel/binutils/files/patch-gold_gc.h45
-rw-r--r--devel/binutils/pkg-plist1
-rw-r--r--devel/binutils/pkg-plist-amd6488
6 files changed, 9 insertions, 150 deletions
diff --git a/devel/binutils/Makefile b/devel/binutils/Makefile
index fc3cd70cd8d2..a7db40351340 100644
--- a/devel/binutils/Makefile
+++ b/devel/binutils/Makefile
@@ -1,6 +1,5 @@
PORTNAME= binutils
-PORTVERSION= 2.37
-PORTREVISION= 4
+PORTVERSION= 2.39
PORTEPOCH?= 1
CATEGORIES?= devel
MASTER_SITES= SOURCEWARE/binutils/releases
@@ -22,7 +21,7 @@ FLAVORS= native aarch64 aarch64_none_elf amd64 arm_gnueabi arm_none_eabi \
riscv64_none_elf s390x sparc64 riscv32_unknown_elf
FLAVOR?= native
-USES= bison:alias compiler:env cpe gmake libtool makeinfo perl5 tar:xz
+USES= bison:alias compiler:env cpe gmake libtool makeinfo perl5 tar:lz
USE_PERL5= build
CPE_VENDOR= gnu
GNU_CONFIGURE= yes
@@ -96,8 +95,11 @@ CONFIGURE_ARGS+= --with-system-zlib \
--with-mpfr=${LOCALBASE} \
--enable-targets=all \
--enable-threads=yes
+# XXX Needed to support gcc10 and earlier:
+CONFIGURE_ARGS+= --with-isa-spec=2.2
INFO= as \
binutils \
+ ctf-spec \
gprof \
bfd \
ld
diff --git a/devel/binutils/distinfo b/devel/binutils/distinfo
index 429395053a3a..29906643c282 100644
--- a/devel/binutils/distinfo
+++ b/devel/binutils/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1626719973
-SHA256 (binutils-2.37.tar.xz) = 820d9724f020a3e69cb337893a0b63c2db161dadcb0e06fc11dc29eb1e84a32c
-SIZE (binutils-2.37.tar.xz) = 22916924
+TIMESTAMP = 1660760045
+SHA256 (binutils-2.39.tar.lz) = 5ab51668874d8533201b8edd2edb5e5d81d588205c6da300c8919bd7cf8664e8
+SIZE (binutils-2.39.tar.lz) = 24759528
diff --git a/devel/binutils/files/patch-etc_texi2pod.pl b/devel/binutils/files/patch-etc_texi2pod.pl
deleted file mode 100644
index 456d44cfcdbd..000000000000
--- a/devel/binutils/files/patch-etc_texi2pod.pl
+++ /dev/null
@@ -1,11 +0,0 @@
---- etc/texi2pod.pl.orig 2021-08-30 17:17:09 UTC
-+++ etc/texi2pod.pl
-@@ -59,6 +59,8 @@ while ($_ = shift) {
- $flag = shift;
- }
- push (@ipath, $flag);
-+ } elsif (/^--no-split$/) {
-+ # ignore option for makeinfo compatibility
- } elsif (/^-/) {
- usage();
- } else {
diff --git a/devel/binutils/files/patch-gold_gc.h b/devel/binutils/files/patch-gold_gc.h
deleted file mode 100644
index 5430f1897ee5..000000000000
--- a/devel/binutils/files/patch-gold_gc.h
+++ /dev/null
@@ -1,45 +0,0 @@
-From 10b4dbbf281397e2827820c715c39559c7f7a29d Mon Sep 17 00:00:00 2001
-From: Alan Modra <amodra@gmail.com>
-Date: Tue, 20 Jul 2021 18:46:57 +0930
-Subject: [PATCH] PR28106, build of 2.37 fails on FreeBSD and Clang
-
-https://en.cppreference.com/w/cpp/types/NULL says NULL might be
-defined as nullptr.
-https://en.cppreference.com/w/cpp/language/reinterpret_cast says
-reinterpret_cast can't be used on nullptr.
-
- PR gold/28106
- PR gold/27815
- * gc.h (gc_process_relocs): Use static_cast in Section_id constructor.
-
-(cherry picked from commit b97bd976233ee4d43c2fe18f6356e62779cbe82d)
----
- gold/ChangeLog | 6 ++++++
- gold/gc.h | 4 ++--
- 2 files changed, 8 insertions(+), 2 deletions(-)
-
-diff --git gold/gc.h gold/gc.h
-index 6ebd81f3fd0..4a1368f5abe 100644
---- gold/gc.h
-+++ gold/gc.h
-@@ -247,7 +247,7 @@ gc_process_relocs(
- if (is_ordinary)
- (*secvec).push_back(Section_id(src_obj, dst_indx));
- else
-- (*secvec).push_back(Section_id(reinterpret_cast<Relobj*>(NULL), 0));
-+ (*secvec).push_back(Section_id(static_cast<Relobj*>(NULL), 0));
- // If the target of the relocation is an STT_SECTION symbol,
- // make a note of that by storing -1 in the symbol vector.
- if (lsym.get_st_type() == elfcpp::STT_SECTION)
-@@ -329,7 +329,7 @@ gc_process_relocs(
- if (is_ordinary && dst_obj != NULL)
- (*secvec).push_back(Section_id(dst_obj, dst_indx));
- else
-- (*secvec).push_back(Section_id(reinterpret_cast<Relobj*>(NULL), 0));
-+ (*secvec).push_back(Section_id(static_cast<Relobj*>(NULL), 0));
- (*symvec).push_back(gsym);
- (*addendvec).push_back(std::make_pair(
- static_cast<long long>(symvalue),
---
-2.32.0
-
diff --git a/devel/binutils/pkg-plist b/devel/binutils/pkg-plist
index 2c8766973a3e..71a7c06f83ac 100644
--- a/devel/binutils/pkg-plist
+++ b/devel/binutils/pkg-plist
@@ -100,6 +100,7 @@ man/man1/strip.1.gz
%%NLS%%share/locale/ja/LC_MESSAGES/gas.mo
%%NLS%%share/locale/ja/LC_MESSAGES/gprof.mo
%%NLS%%share/locale/ja/LC_MESSAGES/ld.mo
+%%NLS%%share/locale/ka/LC_MESSAGES/gprof.mo
%%NLS%%share/locale/ms/LC_MESSAGES/gprof.mo
%%NLS%%share/locale/nl/LC_MESSAGES/gprof.mo
%%NLS%%share/locale/nl/LC_MESSAGES/opcodes.mo
diff --git a/devel/binutils/pkg-plist-amd64 b/devel/binutils/pkg-plist-amd64
index 66958eb7482d..b6fc6b18834d 100644
--- a/devel/binutils/pkg-plist-amd64
+++ b/devel/binutils/pkg-plist-amd64
@@ -109,94 +109,6 @@ man/man1/%%BUTARGET%%-windres.1.gz
%%BUTARGET%%/lib/ldscripts/elf_iamcu.xu
%%BUTARGET%%/lib/ldscripts/elf_iamcu.xw
%%BUTARGET%%/lib/ldscripts/elf_iamcu.xwe
-%%BUTARGET%%/lib/ldscripts/elf_k1om.x
-%%BUTARGET%%/lib/ldscripts/elf_k1om.xbn
-%%BUTARGET%%/lib/ldscripts/elf_k1om.xc
-%%BUTARGET%%/lib/ldscripts/elf_k1om.xce
-%%BUTARGET%%/lib/ldscripts/elf_k1om.xd
-%%BUTARGET%%/lib/ldscripts/elf_k1om.xdc
-%%BUTARGET%%/lib/ldscripts/elf_k1om.xdce
-%%BUTARGET%%/lib/ldscripts/elf_k1om.xde
-%%BUTARGET%%/lib/ldscripts/elf_k1om.xdw
-%%BUTARGET%%/lib/ldscripts/elf_k1om.xdwe
-%%BUTARGET%%/lib/ldscripts/elf_k1om.xe
-%%BUTARGET%%/lib/ldscripts/elf_k1om.xn
-%%BUTARGET%%/lib/ldscripts/elf_k1om.xr
-%%BUTARGET%%/lib/ldscripts/elf_k1om.xs
-%%BUTARGET%%/lib/ldscripts/elf_k1om.xsc
-%%BUTARGET%%/lib/ldscripts/elf_k1om.xsce
-%%BUTARGET%%/lib/ldscripts/elf_k1om.xse
-%%BUTARGET%%/lib/ldscripts/elf_k1om.xsw
-%%BUTARGET%%/lib/ldscripts/elf_k1om.xswe
-%%BUTARGET%%/lib/ldscripts/elf_k1om.xu
-%%BUTARGET%%/lib/ldscripts/elf_k1om.xw
-%%BUTARGET%%/lib/ldscripts/elf_k1om.xwe
-%%BUTARGET%%/lib/ldscripts/elf_k1om_fbsd.x
-%%BUTARGET%%/lib/ldscripts/elf_k1om_fbsd.xbn
-%%BUTARGET%%/lib/ldscripts/elf_k1om_fbsd.xc
-%%BUTARGET%%/lib/ldscripts/elf_k1om_fbsd.xce
-%%BUTARGET%%/lib/ldscripts/elf_k1om_fbsd.xd
-%%BUTARGET%%/lib/ldscripts/elf_k1om_fbsd.xdc
-%%BUTARGET%%/lib/ldscripts/elf_k1om_fbsd.xdce
-%%BUTARGET%%/lib/ldscripts/elf_k1om_fbsd.xde
-%%BUTARGET%%/lib/ldscripts/elf_k1om_fbsd.xdw
-%%BUTARGET%%/lib/ldscripts/elf_k1om_fbsd.xdwe
-%%BUTARGET%%/lib/ldscripts/elf_k1om_fbsd.xe
-%%BUTARGET%%/lib/ldscripts/elf_k1om_fbsd.xn
-%%BUTARGET%%/lib/ldscripts/elf_k1om_fbsd.xr
-%%BUTARGET%%/lib/ldscripts/elf_k1om_fbsd.xs
-%%BUTARGET%%/lib/ldscripts/elf_k1om_fbsd.xsc
-%%BUTARGET%%/lib/ldscripts/elf_k1om_fbsd.xsce
-%%BUTARGET%%/lib/ldscripts/elf_k1om_fbsd.xse
-%%BUTARGET%%/lib/ldscripts/elf_k1om_fbsd.xsw
-%%BUTARGET%%/lib/ldscripts/elf_k1om_fbsd.xswe
-%%BUTARGET%%/lib/ldscripts/elf_k1om_fbsd.xu
-%%BUTARGET%%/lib/ldscripts/elf_k1om_fbsd.xw
-%%BUTARGET%%/lib/ldscripts/elf_k1om_fbsd.xwe
-%%BUTARGET%%/lib/ldscripts/elf_l1om.x
-%%BUTARGET%%/lib/ldscripts/elf_l1om.xbn
-%%BUTARGET%%/lib/ldscripts/elf_l1om.xc
-%%BUTARGET%%/lib/ldscripts/elf_l1om.xce
-%%BUTARGET%%/lib/ldscripts/elf_l1om.xd
-%%BUTARGET%%/lib/ldscripts/elf_l1om.xdc
-%%BUTARGET%%/lib/ldscripts/elf_l1om.xdce
-%%BUTARGET%%/lib/ldscripts/elf_l1om.xde
-%%BUTARGET%%/lib/ldscripts/elf_l1om.xdw
-%%BUTARGET%%/lib/ldscripts/elf_l1om.xdwe
-%%BUTARGET%%/lib/ldscripts/elf_l1om.xe
-%%BUTARGET%%/lib/ldscripts/elf_l1om.xn
-%%BUTARGET%%/lib/ldscripts/elf_l1om.xr
-%%BUTARGET%%/lib/ldscripts/elf_l1om.xs
-%%BUTARGET%%/lib/ldscripts/elf_l1om.xsc
-%%BUTARGET%%/lib/ldscripts/elf_l1om.xsce
-%%BUTARGET%%/lib/ldscripts/elf_l1om.xse
-%%BUTARGET%%/lib/ldscripts/elf_l1om.xsw
-%%BUTARGET%%/lib/ldscripts/elf_l1om.xswe
-%%BUTARGET%%/lib/ldscripts/elf_l1om.xu
-%%BUTARGET%%/lib/ldscripts/elf_l1om.xw
-%%BUTARGET%%/lib/ldscripts/elf_l1om.xwe
-%%BUTARGET%%/lib/ldscripts/elf_l1om_fbsd.x
-%%BUTARGET%%/lib/ldscripts/elf_l1om_fbsd.xbn
-%%BUTARGET%%/lib/ldscripts/elf_l1om_fbsd.xc
-%%BUTARGET%%/lib/ldscripts/elf_l1om_fbsd.xce
-%%BUTARGET%%/lib/ldscripts/elf_l1om_fbsd.xd
-%%BUTARGET%%/lib/ldscripts/elf_l1om_fbsd.xdc
-%%BUTARGET%%/lib/ldscripts/elf_l1om_fbsd.xdce
-%%BUTARGET%%/lib/ldscripts/elf_l1om_fbsd.xde
-%%BUTARGET%%/lib/ldscripts/elf_l1om_fbsd.xdw
-%%BUTARGET%%/lib/ldscripts/elf_l1om_fbsd.xdwe
-%%BUTARGET%%/lib/ldscripts/elf_l1om_fbsd.xe
-%%BUTARGET%%/lib/ldscripts/elf_l1om_fbsd.xn
-%%BUTARGET%%/lib/ldscripts/elf_l1om_fbsd.xr
-%%BUTARGET%%/lib/ldscripts/elf_l1om_fbsd.xs
-%%BUTARGET%%/lib/ldscripts/elf_l1om_fbsd.xsc
-%%BUTARGET%%/lib/ldscripts/elf_l1om_fbsd.xsce
-%%BUTARGET%%/lib/ldscripts/elf_l1om_fbsd.xse
-%%BUTARGET%%/lib/ldscripts/elf_l1om_fbsd.xsw
-%%BUTARGET%%/lib/ldscripts/elf_l1om_fbsd.xswe
-%%BUTARGET%%/lib/ldscripts/elf_l1om_fbsd.xu
-%%BUTARGET%%/lib/ldscripts/elf_l1om_fbsd.xw
-%%BUTARGET%%/lib/ldscripts/elf_l1om_fbsd.xwe
%%BUTARGET%%/lib/ldscripts/elf_x86_64.x
%%BUTARGET%%/lib/ldscripts/elf_x86_64.xbn
%%BUTARGET%%/lib/ldscripts/elf_x86_64.xc