aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-16 22:29:41 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-16 22:29:41 +0000
commit331ac64f1b3ad22f6f2346657c56820728ee87db (patch)
tree98dd57b1f83e8421411ea0a1cf348ece2ba02dd5
parent4bd231072e99617bf9c848d83ff035e3684166b4 (diff)
downloadports-331ac64f1b3ad22f6f2346657c56820728ee87db.tar.gz
ports-331ac64f1b3ad22f6f2346657c56820728ee87db.zip
lang/php74: fix build on riscv64
Same fix as for php80.
-rw-r--r--lang/php74/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/lang/php74/Makefile b/lang/php74/Makefile
index 73dceab16cd6..027ef5276504 100644
--- a/lang/php74/Makefile
+++ b/lang/php74/Makefile
@@ -46,6 +46,7 @@ OPTIONS_EXCLUDE_mips64= DTRACE FPM
OPTIONS_EXCLUDE_powerpc64= ${OPTIONS_EXCLUDE_${ARCH}_${OSREL:R}}
OPTIONS_EXCLUDE_powerpc64_11= DTRACE
OPTIONS_EXCLUDE_powerpc64_12= DTRACE
+OPTIONS_EXCLUDE_riscv64= DTRACE
OPTIONS_EXCLUDE_sparc64= DTRACE
OPTIONS_SUB= yes
@@ -64,6 +65,10 @@ DESTDIRNAME= INSTALL_ROOT
.include <bsd.port.pre.mk>
+.if ${ARCH} == riscv64
+CONFIGURE_ARGS+=--without-pcre-jit
+.endif
+
.if ${PORT_OPTIONS:MMYSQLND}
CONFIGURE_ARGS+=--enable-mysqlnd
.endif