aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2006-07-14 11:13:58 +0000
committerPeter Pentchev <roam@FreeBSD.org>2006-07-14 11:13:58 +0000
commit332f6bac11259bb491259b231e43593e0649fc18 (patch)
tree8b2292a824988da1ed7e22a4059603d41d67a80e
parent0c855f3a694640cb0ee2d0e5d8f0342beb1d037e (diff)
downloadports-332f6bac11259bb491259b231e43593e0649fc18.tar.gz
ports-332f6bac11259bb491259b231e43593e0649fc18.zip
Update to Net-Akismet 0.02, which basically incorporates our port patches
and also fixes a couple of minor build issues.
Notes
Notes: svn path=/head/; revision=167781
-rw-r--r--www/p5-Net-Akismet/Makefile7
-rw-r--r--www/p5-Net-Akismet/distinfo6
-rw-r--r--www/p5-Net-Akismet/files/Net-Akismet-coverage.t15
-rw-r--r--www/p5-Net-Akismet/files/Net-Akismet-podcheck.t27
-rw-r--r--www/p5-Net-Akismet/files/patch-README9
-rw-r--r--www/p5-Net-Akismet/files/patch-lib-Net-Akismet.pm38
6 files changed, 14 insertions, 88 deletions
diff --git a/www/p5-Net-Akismet/Makefile b/www/p5-Net-Akismet/Makefile
index 48402fe8b552..eacaac89481e 100644
--- a/www/p5-Net-Akismet/Makefile
+++ b/www/p5-Net-Akismet/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Net-Akismet
-PORTVERSION= 0.01
+PORTVERSION= 0.02
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Net
@@ -27,11 +27,8 @@ PERL_CONFIGURE= yes
MAN3= Net::Akismet.3
post-patch:
- ${CP} ${FILESDIR}/Net-Akismet-podcheck.t \
- ${FILESDIR}/Net-Akismet-coverage.t \
- ${WRKSRC}/t/
# Grrrr, this really shouldn't be needed!
- ${RM} ${WRKSRC}/lib/Net/Akismet.pm.orig
+ ${FIND} ${WRKSRC} -type f -name \*.orig -delete
test: build
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test
diff --git a/www/p5-Net-Akismet/distinfo b/www/p5-Net-Akismet/distinfo
index 77d31dfd591e..f14f7f525066 100644
--- a/www/p5-Net-Akismet/distinfo
+++ b/www/p5-Net-Akismet/distinfo
@@ -1,3 +1,3 @@
-MD5 (Net-Akismet-0.01.tar.gz) = ea0510f5f5fccf913d862ec28c92fe1f
-SHA256 (Net-Akismet-0.01.tar.gz) = 76863a80913865750c2804791fbb90f25fcf79f8f6d1d7dd7e60143bab1ca5b0
-SIZE (Net-Akismet-0.01.tar.gz) = 3774
+MD5 (Net-Akismet-0.02.tar.gz) = 117bb28a008b28247a3554c32df1e74c
+SHA256 (Net-Akismet-0.02.tar.gz) = f1df682e8f5671b27769cb403098b035c3caef8c368a3b4e61d44f0a6904f982
+SIZE (Net-Akismet-0.02.tar.gz) = 4144
diff --git a/www/p5-Net-Akismet/files/Net-Akismet-coverage.t b/www/p5-Net-Akismet/files/Net-Akismet-coverage.t
deleted file mode 100644
index cfd9d2e16236..000000000000
--- a/www/p5-Net-Akismet/files/Net-Akismet-coverage.t
+++ /dev/null
@@ -1,15 +0,0 @@
-# Before `make install' is performed this script should be runnable with
-# `make test'. After `make install' it should work as `perl Net-Akismet-coverage.t'
-
-BEGIN {
- eval 'use Test::Pod::Coverage tests => 1';
- if ($@) {
- use Test;
- plan tests => 1;
- skip('Test::Pod::Coverage not found');
- exit(0);
- }
-}
-
-
-pod_coverage_ok('Net::Akismet');
diff --git a/www/p5-Net-Akismet/files/Net-Akismet-podcheck.t b/www/p5-Net-Akismet/files/Net-Akismet-podcheck.t
deleted file mode 100644
index f49e99c16b3a..000000000000
--- a/www/p5-Net-Akismet/files/Net-Akismet-podcheck.t
+++ /dev/null
@@ -1,27 +0,0 @@
-# $Id: Net-Akismet-podcheck.t 135 2006-01-27 17:54:46Z roam $
-# Before `make install' is performed this script should be runnable with
-# `make test'. After `make install' it should work as `perl Net-Akismet-coverage.t'
-
-use Pod::Checker;
-use Test;
-plan tests => 6;
-
-my ($c, $res);
-
-$c = new Pod::Checker '-warnings' => 1;
-ok($c);
-$res = $c->parse_from_file('lib/Net/Akismet.pm', \*STDERR);
-if ($res == -1) {
- warn "No POD data found in Net::Akismet\n";
-}
-ok(!$res);
-ok($c->num_errors() == 0 && $c->num_warnings() == 0);
-
-$c = new Pod::Checker '-warnings' => 5;
-ok($c);
-$res = $c->parse_from_file('lib/Net/Akismet.pm', \*STDERR);
-if ($res == -1) {
- warn "No POD data found in Net::Akismet\n";
-}
-ok(!$res);
-ok($c->num_errors() == 0 && $c->num_warnings() == 0);
diff --git a/www/p5-Net-Akismet/files/patch-README b/www/p5-Net-Akismet/files/patch-README
new file mode 100644
index 000000000000..9627c113c93b
--- /dev/null
+++ b/www/p5-Net-Akismet/files/patch-README
@@ -0,0 +1,9 @@
+diff -urN -x .svn ../Net-Akismet-0.02/README ./README
+--- README.orig Fri Jul 14 13:44:12 2006
++++ README Fri Jul 14 13:46:57 2006
+@@ -1,4 +1,4 @@
+-Net-Akismet version 0.01
++Net-Akismet version 0.02
+ ========================
+
+ Net::Akismet is meant to provide perl interface to the Akismet web service.
diff --git a/www/p5-Net-Akismet/files/patch-lib-Net-Akismet.pm b/www/p5-Net-Akismet/files/patch-lib-Net-Akismet.pm
deleted file mode 100644
index 6553b3977992..000000000000
--- a/www/p5-Net-Akismet/files/patch-lib-Net-Akismet.pm
+++ /dev/null
@@ -1,38 +0,0 @@
---- lib/Net/Akismet.pm.old Thu Apr 20 15:50:08 2006
-+++ lib/Net/Akismet.pm Thu Apr 20 15:50:49 2006
-@@ -24,7 +24,7 @@
- KEY => 'secret-baba-API-key',
- URL => 'http://example.blog.net/',
- ) or die('Key verification failure!');
--
-+
- my $verdict = $akismet->check(
- USER_IP => '10.10.10.11',
- COMMENT_CONTENT => 'Run, Lola, Run, the spam will catch you!',
-@@ -37,7 +37,7 @@
-
- print "I found spam. I am a spam-founder!\n";
- }
--
-+
- =head1 METHODS
-
- =over 8
-@@ -47,7 +47,7 @@
- Net::Akismet->new(PARAM => ...);
-
- Acceptable parameters:
--
-+
- =over 4
-
- =item KEY
-@@ -61,7 +61,7 @@
- =item USER_AGENT
-
- If supplied the value is prepended to this module's identification string to become something like:
--
-+
- yourkillerapp/0.042 | Akismet Perl/0.01
-
- Otherwise just Akismet Perl's user agent string will be sent.