aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-08-06 19:07:50 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-08-06 19:12:13 +0000
commit33839ffd1d4fada3b7baaa7cd93c0e52eb9dd5cc (patch)
treeda2f2789f125debd3b1ef132f147887aa4ed4092
parent227fa40a1f9fd9c15f98b87bb14b38f39dc33567 (diff)
downloadports-33839ffd1d4fada3b7baaa7cd93c0e52eb9dd5cc.tar.gz
ports-33839ffd1d4fada3b7baaa7cd93c0e52eb9dd5cc.zip
lang/php80: Update version 8.0.20=>8.0.22
- STRIP Binaries [1] CLI: - Fixed potential overflow for the builtin server via the PHP_CLI_SERVER_WORKERS environment variable. Core: - Fixed bug GH-8923 (error_log on Windows can hold the file write lock). - Fixed bug GH-8995 (WeakMap object reference offset causing TypeError). Date: - Fixed bug #80047 (DatePeriod doesn't warn with custom DateTimeImmutable). DBA: - Fixed LMDB driver hanging when attempting to delete a non-existing key. FPM: - Fixed zlog message prepend, free on incorrect address. - Fixed possible double free on configuration loading failure. GD: - Fixed bug GH-8848 (imagecopyresized() error refers to the wrong argument). Intl: - Fixed build for ICU 69.x and onwards. OPcache: - Fixed bug GH-8847 (PHP hanging infinitly at 100% cpu when check php syntaxe of a valid file). Standard: - Fixed the crypt_sha256/512 api build with clang > 12. - Uses CCRandomGenerateBytes instead of arc4random_buf on macOs. Reported by: sunpoet [1] Approved by: tz (private email) Relnotes: https://www.php.net/ChangeLog-8.php#8.0.22 Sponsored by: Bounce Experts
-rw-r--r--archivers/php80-zip/Makefile1
-rw-r--r--lang/php80/Makefile18
-rw-r--r--lang/php80/distinfo6
-rw-r--r--www/mod_php80/Makefile1
4 files changed, 20 insertions, 6 deletions
diff --git a/archivers/php80-zip/Makefile b/archivers/php80-zip/Makefile
index be485abbd922..91acb043f381 100644
--- a/archivers/php80-zip/Makefile
+++ b/archivers/php80-zip/Makefile
@@ -1,4 +1,3 @@
-PORTREVISION= 1
CATEGORIES= archivers
MASTERDIR= ${.CURDIR}/../../lang/php80
diff --git a/lang/php80/Makefile b/lang/php80/Makefile
index c26c7a79b55d..2f614ce513d4 100644
--- a/lang/php80/Makefile
+++ b/lang/php80/Makefile
@@ -1,5 +1,5 @@
PORTNAME= php80
-DISTVERSION= 8.0.20
+DISTVERSION= 8.0.22
PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= PHP
@@ -150,6 +150,22 @@ test: build
post-install:
${INSTALL_DATA} ${WRKSRC}/php.ini-development ${WRKSRC}/php.ini-production \
${WRKDIR}/php.conf ${STAGEDIR}/${PREFIX}/etc
+
+post-install-CLI-on:
+ ${STRIP_CMD} ${STAGEDIR}/${PREFIX}/bin/php
+
+post-install-CGI-on:
+ ${STRIP_CMD} ${STAGEDIR}/${PREFIX}/bin/php-cgi
+
+post-install-EMBED-on:
+ ${STRIP_CMD} ${STAGEDIR}/${PREFIX}/lib/libphp.so
+
+post-install-FPM-on:
+ ${STRIP_CMD} ${STAGEDIR}/${PREFIX}/sbin/php-fpm
+
+post-install-PHPDBG-on:
+ ${STRIP_CMD} ${STAGEDIR}/${PREFIX}/bin/phpdbg
+
.else
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}
diff --git a/lang/php80/distinfo b/lang/php80/distinfo
index a56b11d3b93a..47533856cdd7 100644
--- a/lang/php80/distinfo
+++ b/lang/php80/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1654868216
-SHA256 (php/php-8.0.20.tar.xz) = 973fec765336ee01f47536a5db1c2eee98df9d34a41522b7b6c760159bf0a77b
-SIZE (php/php-8.0.20.tar.xz) = 10879064
+TIMESTAMP = 1659811643
+SHA256 (php/php-8.0.22.tar.xz) = 130937c0fa3050cd33d6c415402f6ccbf0682ae83eb8d39c91164224ddfe57f1
+SIZE (php/php-8.0.22.tar.xz) = 10785228
diff --git a/www/mod_php80/Makefile b/www/mod_php80/Makefile
index 775b9efc9b2a..8ca5af8db5f6 100644
--- a/www/mod_php80/Makefile
+++ b/www/mod_php80/Makefile
@@ -1,4 +1,3 @@
-PORTREVISION= 1
CATEGORIES= www devel
PKGNAMEPREFIX= mod_