aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-12-25 22:24:32 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-12-26 02:34:59 +0000
commit33e99ff51b84f596cf1b257f30737b923c44bb61 (patch)
tree1ce0c901ff286a8c758134965cc98968e1c14851
parentbb8b0fac8417439fefd31e67f88b3fde30746ff9 (diff)
downloadports-33e99ff51b84f596cf1b257f30737b923c44bb61.tar.gz
ports-33e99ff51b84f596cf1b257f30737b923c44bb61.zip
finance/py-exchange-calendars: New port: Calendars for securities exchanges
-rw-r--r--finance/Makefile1
-rw-r--r--finance/py-exchange-calendars/Makefile30
-rw-r--r--finance/py-exchange-calendars/distinfo3
-rw-r--r--finance/py-exchange-calendars/pkg-descr4
4 files changed, 38 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index 1bd0e52291c2..56b715c4819c 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -99,6 +99,7 @@
SUBDIR += py-backtrader
SUBDIR += py-bitcoin
SUBDIR += py-ebaysdk
+ SUBDIR += py-exchange-calendars
SUBDIR += py-financedatabase
SUBDIR += py-finnhub-python
SUBDIR += py-finviz
diff --git a/finance/py-exchange-calendars/Makefile b/finance/py-exchange-calendars/Makefile
new file mode 100644
index 000000000000..24be9ed8b2dc
--- /dev/null
+++ b/finance/py-exchange-calendars/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= exchange-calendars
+DISTVERSION= 4.2.4
+CATEGORIES= finance python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME:S/-/_/}-${PORTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Calendars for securities exchanges
+WWW= https://github.com/gerrymanoim/exchange_calendars
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+PY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}korean-lunar-calendar>0:korean/py-korean-lunar-calendar@${PY_FLAVOR} \
+ ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=1.1:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyluach>0:hebrew/py-pyluach@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytz>=0:devel/py-pytz@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}toolz>=0:devel/py-toolz@${PY_FLAVOR}
+BUILD_DEPENDS= ${PY_DEPENDS}
+RUN_DEPENDS= ${PY_DEPENDS}
+
+USES= python:3.8+
+USE_PYTHON= distutils autoplist pytest
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/finance/py-exchange-calendars/distinfo b/finance/py-exchange-calendars/distinfo
new file mode 100644
index 000000000000..590922d7e9e2
--- /dev/null
+++ b/finance/py-exchange-calendars/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1672004653
+SHA256 (exchange_calendars-4.2.4.tar.gz) = ca4daee5f0f620a7ec1355e5fa5a5cc12994f51677fbfaffe9ef5cc9139af727
+SIZE (exchange_calendars-4.2.4.tar.gz) = 3372127
diff --git a/finance/py-exchange-calendars/pkg-descr b/finance/py-exchange-calendars/pkg-descr
new file mode 100644
index 000000000000..2bfa2256a888
--- /dev/null
+++ b/finance/py-exchange-calendars/pkg-descr
@@ -0,0 +1,4 @@
+FinViz aims to make market information accessible and provides a lot of data in
+visual snapshots, allowing traders and investors to quickly find the stock,
+future or forex pair they are looking for. The site provides advanced screeners,
+market maps, analysis, comparative tools, and charts.