aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEinar Bjarni Halldórsson <einar@isnic.is>2024-04-05 11:04:18 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2024-04-06 14:42:36 +0000
commit340d72381df973bcf7c61486b4a5945f60e7433b (patch)
tree29c7f67b37539856559791f392a20fcf1568d0be
parent10abd882d5ad365b16dcda616c31d09d2fcd192e (diff)
downloadports-340d72381df973bcf7c61486b4a5945f60e7433b.tar.gz
ports-340d72381df973bcf7c61486b4a5945f60e7433b.zip
databases/R-cran-dtplyr: New port: Data Table Back-End for 'dplyr'
- Submitter becomes maintainer Provides a data.table backend for 'dplyr'. The goal of 'dtplyr' is to allow you to write 'dplyr' code that is automatically translated to the equivalent, but usually much faster, data.table code. WWW: https://dtplyr.tidyverse.org/ Differential Revision: https://reviews.freebsd.org/D43735
-rw-r--r--databases/Makefile1
-rw-r--r--databases/R-cran-dtplyr/Makefile28
-rw-r--r--databases/R-cran-dtplyr/distinfo3
-rw-r--r--databases/R-cran-dtplyr/pkg-descr3
4 files changed, 35 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index e92213a1efd7..268bc50a232a 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -6,6 +6,7 @@
SUBDIR += R-cran-RSQLite
SUBDIR += R-cran-cachem
SUBDIR += R-cran-dbplyr
+ SUBDIR += R-cran-dtplyr
SUBDIR += R-cran-fastmap
SUBDIR += R-cran-sqldf
SUBDIR += WWWdb
diff --git a/databases/R-cran-dtplyr/Makefile b/databases/R-cran-dtplyr/Makefile
new file mode 100644
index 000000000000..fff62a008ca9
--- /dev/null
+++ b/databases/R-cran-dtplyr/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= dtplyr
+DISTVERSION= 1.3.1
+CATEGORIES= databases
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= einar@isnic.is
+COMMENT= Data Table Back-End for 'dplyr'
+WWW= https://dtplyr.tidyverse.org/
+
+LICENSE= MIT
+
+CRAN_DEPENDS= R-cran-cli>=3.4.0:devel/R-cran-cli \
+ R-cran-data.table>=1.13.0:devel/R-cran-data.table \
+ R-cran-dplyr>=1.1.0:math/R-cran-dplyr \
+ R-cran-glue>0:devel/R-cran-glue \
+ R-cran-lifecycle>0:devel/R-cran-lifecycle \
+ R-cran-rlang>=1.0.4:devel/R-cran-rlang \
+ R-cran-tibble>0:devel/R-cran-tibble \
+ R-cran-tidyselect>=1.2.0:devel/R-cran-tidyselect \
+ R-cran-vctrs>=0.4.1:devel/R-cran-vctrs
+BUILD_DEPENDS= ${CRAN_DEPENDS}
+RUN_DEPENDS= ${CRAN_DEPENDS}
+TEST_DEPENDS= R-cran-testthat>0:devel/R-cran-testthat \
+ R-cran-tidyr>0:devel/R-cran-tidyr
+
+USES= cran:auto-plist
+
+.include <bsd.port.mk>
diff --git a/databases/R-cran-dtplyr/distinfo b/databases/R-cran-dtplyr/distinfo
new file mode 100644
index 000000000000..188c853cdc05
--- /dev/null
+++ b/databases/R-cran-dtplyr/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1706915299
+SHA256 (dtplyr_1.3.1.tar.gz) = a5a9689a640b8bd1274519af220c33deaa3919654acac4ebdff1ff365cc8d6e5
+SIZE (dtplyr_1.3.1.tar.gz) = 150971
diff --git a/databases/R-cran-dtplyr/pkg-descr b/databases/R-cran-dtplyr/pkg-descr
new file mode 100644
index 000000000000..1a2509c71627
--- /dev/null
+++ b/databases/R-cran-dtplyr/pkg-descr
@@ -0,0 +1,3 @@
+Provides a data.table backend for 'dplyr'. The goal of 'dtplyr' is to allow you
+to write 'dplyr' code that is automatically translated to the equivalent, but
+usually much faster, data.table code.