aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-06-23 20:39:23 +0000
committerPatrick Li <pat@FreeBSD.org>2002-06-23 20:39:23 +0000
commit3429beb3d69bf05cc09137cac5b420f8e26b86db (patch)
tree4affc92982e244cfbe7e05e3bdd22240b4c28520
parentec8028156e7ada0e0867358c46bf5af20c16fec3 (diff)
downloadports-3429beb3d69bf05cc09137cac5b420f8e26b86db.tar.gz
ports-3429beb3d69bf05cc09137cac5b420f8e26b86db.zip
PERL -> REINPLACE_CMD
PR: ports/39729, ports/39727, ports/39726, ports/39724 PR: ports/39722, ports/39721, ports/39720, ports/39719, ports/39718 Submitted by: Scott Flatman <sf@dsinw.com>
Notes
Notes: svn path=/head/; revision=61839
-rw-r--r--security/botan/Makefile3
-rw-r--r--security/ccrypt/Makefile3
-rw-r--r--security/cfv/Makefile3
-rw-r--r--security/fwlogwatch/Makefile5
-rw-r--r--security/hashish/Makefile5
-rw-r--r--security/logcheck/Makefile5
-rw-r--r--security/nofgpg/Makefile3
-rw-r--r--security/opencl/Makefile3
-rw-r--r--security/portsentry/Makefile3
-rw-r--r--security/rid/Makefile3
10 files changed, 23 insertions, 13 deletions
diff --git a/security/botan/Makefile b/security/botan/Makefile
index 891b39479c18..e36449be8ccb 100644
--- a/security/botan/Makefile
+++ b/security/botan/Makefile
@@ -16,6 +16,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
USE_NEWGCC= yes
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= configure.pl
@@ -27,7 +28,7 @@ INSTALLS_SHLIB= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
post-patch:
- @${PERL} -pi -e "s,%%PREFIX%%,${PREFIX},g ; \
+ @${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX},g ; \
s,%%CFLAGS%%,${CFLAGS},g" ${WRKSRC}/${CONFIGURE_SCRIPT}
@${RM} -f ${WRKSRC}/src/pipe_io.cpp.orig
diff --git a/security/ccrypt/Makefile b/security/ccrypt/Makefile
index c7eb499065bc..13f8ee21ed1a 100644
--- a/security/ccrypt/Makefile
+++ b/security/ccrypt/Makefile
@@ -17,6 +17,7 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
@@ -27,6 +28,6 @@ MLINKS= ccrypt.1 ccencrypt.1 \
ccrypt.1 ccat.1
post-patch:
- @${PERL} -pi -e "s,gtar,tar,g" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e "s,gtar,tar,g" ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/security/cfv/Makefile b/security/cfv/Makefile
index b66e198e3095..b54863c033f7 100644
--- a/security/cfv/Makefile
+++ b/security/cfv/Makefile
@@ -16,6 +16,7 @@ MAINTAINER= ports@FreeBSD.org
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/fchksum.so:${PORTSDIR}/security/py-fchksum
+USE_REINPLACE= yes
USE_PYTHON= yes
ALL_TARGET= cfv.wrapper
INSTALL_TARGET= install-wrapper
@@ -23,6 +24,6 @@ INSTALL_TARGET= install-wrapper
MAN1= cfv.1
post-patch:
- @${PERL} -pi -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/Makefile
.include <bsd.port.mk>
diff --git a/security/fwlogwatch/Makefile b/security/fwlogwatch/Makefile
index 024ccfe06100..9c61f8ff6793 100644
--- a/security/fwlogwatch/Makefile
+++ b/security/fwlogwatch/Makefile
@@ -16,18 +16,19 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= intl.2:${PORTSDIR}/devel/gettext
+USE_REINPLACE= yes
INSTALL_TARGET= install install-config install-i18n
MANCOMPRESSES= no
MAN8= fwlogwatch.8
MAKE_ENV= MKDIR="${MKDIR}"
post-patch:
- @${PERL} -pi -e 's,/etc,${PREFIX}/etc,g; \
+ @${REINPLACE_CMD} -e 's,/etc,${PREFIX}/etc,g; \
s,/usr/local,${PREFIX},g; \
s,/usr/share,${PREFIX}/share,g; \
s,%%LOCALBASE%%,${LOCALBASE},g' \
${WRKSRC}/Makefile ${WRKSRC}/main.h
- @${PERL} -pi -e "s,/etc,${PREFIX}/etc,g" ${WRKSRC}/${MAN8}
+ @${REINPLACE_CMD} -e "s,/etc,${PREFIX}/etc,g" ${WRKSRC}/${MAN8}
post-install:
@${INSTALL_SCRIPT} ${FILESDIR}/fwlogwatch.sh.sample ${PREFIX}/etc/rc.d
diff --git a/security/hashish/Makefile b/security/hashish/Makefile
index 5369a5792c3c..fc876299180d 100644
--- a/security/hashish/Makefile
+++ b/security/hashish/Makefile
@@ -19,14 +19,15 @@ MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/libcryptopp.a:${PORTSDIR}/security/cryptopp
LIB_DEPENDS= wx_gtk:${PORTSDIR}/x11-toolkits/wxgtk-devel
+USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/Hashish
CFLAGS+= -I${LOCALBASE}/include
USE_GMAKE= yes
post-patch:
- @${PERL} -pi -e "s,^CXXFLAGS =,CXXFLAGS+=,g ; \
+ @${REINPLACE_CMD} -e "s,^CXXFLAGS =,CXXFLAGS+=,g ; \
s,^LBLIBS =,LBLIBS = -L${LOCALBASE}/lib,g" ${WRKSRC}/Makefile
- @${PERL} -pi -e "s,crypto/,cryptopp/,g" ${WRKSRC}/src/main.cpp
+ @${REINPLACE_CMD} -e "s,crypto/,cryptopp/,g" ${WRKSRC}/src/main.cpp
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/hashish ${PREFIX}/bin
diff --git a/security/logcheck/Makefile b/security/logcheck/Makefile
index 2a6409b82c31..801935cc7479 100644
--- a/security/logcheck/Makefile
+++ b/security/logcheck/Makefile
@@ -13,14 +13,15 @@ DISTNAME= logsentry-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PKGMESSAGE= ${WRKDIR}/MESSAGE
pre-configure:
- ${PERL} -pi -e "s@/usr/local/etc/tmp@${PREFIX}/var/tmp@g; \
+ ${REINPLACE_CMD} -e "s@/usr/local/etc/tmp@${PREFIX}/var/tmp@g; \
s@/usr/local@${PREFIX}@" ${WRKSRC}/Makefile \
${WRKSRC}/systems/freebsd/logcheck.sh
- ${PERL} -pi -e "s@/bin/mkdir@${MKDIR}@g" ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e "s@/bin/mkdir@${MKDIR}@g" ${WRKSRC}/Makefile
post-build:
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${PKGDIR}/pkg-message > ${PKGMESSAGE}
diff --git a/security/nofgpg/Makefile b/security/nofgpg/Makefile
index f92304aecfb2..7f973e740a34 100644
--- a/security/nofgpg/Makefile
+++ b/security/nofgpg/Makefile
@@ -16,13 +16,14 @@ MAINTAINER= ports@FreeBSD.org
RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg \
${PYTHON_SITELIBDIR}/gnome/ui.py:${PORTSDIR}/x11-toolkits/py-gnome
+USE_REINPLACE= yes
USE_PYTHON= yes
NO_BUILD= yes
MAN1= nofgpg.1
post-patch:
- @${PERL} -pi -e "s,/usr/share,${X11BASE}/share/gnome,g" ${WRKSRC}/nofgpg
+ @${REINPLACE_CMD} -e "s,/usr/share,${X11BASE}/share/gnome,g" ${WRKSRC}/nofgpg
do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
diff --git a/security/opencl/Makefile b/security/opencl/Makefile
index 891b39479c18..e36449be8ccb 100644
--- a/security/opencl/Makefile
+++ b/security/opencl/Makefile
@@ -16,6 +16,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
USE_NEWGCC= yes
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= configure.pl
@@ -27,7 +28,7 @@ INSTALLS_SHLIB= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
post-patch:
- @${PERL} -pi -e "s,%%PREFIX%%,${PREFIX},g ; \
+ @${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX},g ; \
s,%%CFLAGS%%,${CFLAGS},g" ${WRKSRC}/${CONFIGURE_SCRIPT}
@${RM} -f ${WRKSRC}/src/pipe_io.cpp.orig
diff --git a/security/portsentry/Makefile b/security/portsentry/Makefile
index de001c36ee30..a7d3693412b6 100644
--- a/security/portsentry/Makefile
+++ b/security/portsentry/Makefile
@@ -13,9 +13,10 @@ MASTER_SITES= http://www.psionic.com/downloads/
MAINTAINER= ports@FreeBSD.org
ALL_TARGET= freebsd
+USE_REINPLACE= yes
post-patch:
- @${PERL} -pi -e 's,__PREFIX__,${PREFIX},g' \
+ @${REINPLACE_CMD} -e 's,__PREFIX__,${PREFIX},g' \
${WRKSRC}/portsentry.conf ${WRKSRC}/portsentry_config.h
do-install:
diff --git a/security/rid/Makefile b/security/rid/Makefile
index b468417acf09..60c324c6f859 100644
--- a/security/rid/Makefile
+++ b/security/rid/Makefile
@@ -16,9 +16,10 @@ DISTFILES= ${PORTNAME}-1_0.tgz
MAINTAINER= ports@FreeBSD.org
ALL_TARGET= rid
+USE_REINPLACE= yes
pre-configure:
- @${PERL} -pi -e 's:config.txt:${PREFIX}/etc/rid.conf:g' \
+ @${REINPLACE_CMD} -e 's:config.txt:${PREFIX}/etc/rid.conf:g' \
${WRKSRC}/config.h
do-install: