aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2024-01-22 12:09:10 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2024-01-22 12:09:10 +0000
commit345fc748de406d65743d58178ef3f989d6a73e35 (patch)
tree23a22bcdf06ca57c8d797a77aa2537758fce9de3
parentf01565af56adf30995366251deae0d442395826e (diff)
downloadports-345fc748de406d65743d58178ef3f989d6a73e35.tar.gz
ports-345fc748de406d65743d58178ef3f989d6a73e35.zip
Override GNU_CONFIGURE_MANPREFIX in my GNU autotools-based ports
This is a temporary measure to facilitate entering the new world order where manual pages are installed under ${PREFIX}/share/man.
-rw-r--r--archivers/lbzip2/Makefile7
-rw-r--r--audio/cdparanoia/Makefile3
-rw-r--r--audio/cdparanoia/pkg-plist2
-rw-r--r--devel/patch/Makefile3
-rw-r--r--editors/shed/Makefile3
-rw-r--r--misc/gwhich/Makefile3
-rw-r--r--net-p2p/btcheck/Makefile3
-rw-r--r--security/distcache/Makefile1
-rw-r--r--security/distcache/pkg-plist32
-rw-r--r--sysutils/parkverbot/Makefile3
-rw-r--r--www/thttpd/Makefile1
-rw-r--r--www/thttpd/pkg-plist12
12 files changed, 41 insertions, 32 deletions
diff --git a/archivers/lbzip2/Makefile b/archivers/lbzip2/Makefile
index 95113b8047a4..e45894c35cc2 100644
--- a/archivers/lbzip2/Makefile
+++ b/archivers/lbzip2/Makefile
@@ -11,11 +11,12 @@ WWW= https://lbzip2.org/
USES= tar:bzip2
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
PLIST_FILES= bin/lbunzip2 bin/lbzcat bin/lbzip2 \
- man/man1/lbunzip2.1.gz \
- man/man1/lbzcat.1.gz \
- man/man1/lbzip2.1.gz
+ share/man/man1/lbunzip2.1.gz \
+ share/man/man1/lbzcat.1.gz \
+ share/man/man1/lbzip2.1.gz
PORTDOCS= AUTHORS ChangeLog NEWS README THANKS
diff --git a/audio/cdparanoia/Makefile b/audio/cdparanoia/Makefile
index 3611f59c555b..a4ffafa2b436 100644
--- a/audio/cdparanoia/Makefile
+++ b/audio/cdparanoia/Makefile
@@ -13,8 +13,9 @@ WWW= https://www.xiph.org/paranoia/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/GPL
-GNU_CONFIGURE= yes
USES= gmake
+GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
USE_LDCONFIG= yes
post-patch:
diff --git a/audio/cdparanoia/pkg-plist b/audio/cdparanoia/pkg-plist
index ac1b107f6ed5..a6e8d4d57b67 100644
--- a/audio/cdparanoia/pkg-plist
+++ b/audio/cdparanoia/pkg-plist
@@ -9,4 +9,4 @@ lib/libcdda_paranoia.a
lib/libcdda_paranoia.so
lib/libcdda_paranoia.so.0
lib/libcdda_paranoia.so.0.9.8
-man/man1/cdparanoia.1.gz
+share/man/man1/cdparanoia.1.gz
diff --git a/devel/patch/Makefile b/devel/patch/Makefile
index a303446bec8a..306d44745c9c 100644
--- a/devel/patch/Makefile
+++ b/devel/patch/Makefile
@@ -20,12 +20,13 @@ TEST_DEPENDS= bash:shells/bash
USES= cpe charsetfix gmake tar:xz
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS= --program-prefix=g
CPE_VENDOR= gnu
TEST_TARGET= check
-PLIST_FILES= bin/gpatch man/man1/gpatch.1.gz
+PLIST_FILES= bin/gpatch share/man/man1/gpatch.1.gz
post-patch:
@${REINPLACE_CMD} -e '/^LOG_COMPILER =/,+1s|$$(SHELL)|bash|' \
diff --git a/editors/shed/Makefile b/editors/shed/Makefile
index eb72db446271..ef19c6aca1ba 100644
--- a/editors/shed/Makefile
+++ b/editors/shed/Makefile
@@ -11,8 +11,9 @@ LICENSE= GPLv2
USES= ncurses
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
-PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
+PLIST_FILES= bin/${PORTNAME} share/man/man1/${PORTNAME}.1.gz
PORTDOCS= AUTHORS BUGS ChangeLog README TODO
OPTIONS_DEFINE= DOCS
diff --git a/misc/gwhich/Makefile b/misc/gwhich/Makefile
index 8a97c4193652..658ea48c75a8 100644
--- a/misc/gwhich/Makefile
+++ b/misc/gwhich/Makefile
@@ -10,11 +10,12 @@ COMMENT= GNU Which - Everything you never wanted in a which
WWW= https://savannah.gnu.org/projects/which/
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS= --program-prefix=g
INFO= which
PORTEXAMPLES= EXAMPLES
-PLIST_FILES= bin/gwhich man/man1/gwhich.1.gz
+PLIST_FILES= bin/gwhich share/man/man1/gwhich.1.gz
OPTIONS_DEFINE= EXAMPLES
diff --git a/net-p2p/btcheck/Makefile b/net-p2p/btcheck/Makefile
index 3a379d41db52..3bdf9ca6a6b9 100644
--- a/net-p2p/btcheck/Makefile
+++ b/net-p2p/btcheck/Makefile
@@ -11,10 +11,11 @@ WWW= https://sourceforge.net/projects/btcheck/
LICENSE= GPLv3
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFLICTS_INSTALL= libbt # bin/btcheck
-PLIST_FILES= bin/btcheck man/man1/btcheck.1.gz
+PLIST_FILES= bin/btcheck share/man/man1/btcheck.1.gz
PORTDOCS= AUTHORS ChangeLog NEWS README
OPTIONS_DEFINE= DOCS
diff --git a/security/distcache/Makefile b/security/distcache/Makefile
index 368487aa995b..089c51d567dc 100644
--- a/security/distcache/Makefile
+++ b/security/distcache/Makefile
@@ -14,6 +14,7 @@ USES= libtool ssl tar:bzip2
USE_RC_SUBR= dc_server
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS= --enable-shared --with-ssl=${OPENSSLBASE}
INSTALL_TARGET= install-strip
diff --git a/security/distcache/pkg-plist b/security/distcache/pkg-plist
index b529b4cfd611..6a7b66f314ed 100644
--- a/security/distcache/pkg-plist
+++ b/security/distcache/pkg-plist
@@ -32,21 +32,21 @@ lib/libnalssl.a
lib/libnalssl.so
lib/libnalssl.so.1
lib/libnalssl.so.1.0.1
-man/man1/dc_client.1.gz
-man/man1/dc_server.1.gz
-man/man1/dc_snoop.1.gz
-man/man1/dc_test.1.gz
-man/man1/sslswamp.1.gz
-man/man2/DC_CTX_new.2.gz
-man/man2/DC_PLUG_new.2.gz
-man/man2/DC_PLUG_read.2.gz
-man/man2/DC_SERVER_new.2.gz
-man/man2/NAL_ADDRESS_new.2.gz
-man/man2/NAL_BUFFER_new.2.gz
-man/man2/NAL_CONNECTION_new.2.gz
-man/man2/NAL_LISTENER_new.2.gz
-man/man2/NAL_SELECTOR_new.2.gz
-man/man2/NAL_decode_uint32.2.gz
-man/man8/distcache.8.gz
+share/man/man1/dc_client.1.gz
+share/man/man1/dc_server.1.gz
+share/man/man1/dc_snoop.1.gz
+share/man/man1/dc_test.1.gz
+share/man/man1/sslswamp.1.gz
+share/man/man2/DC_CTX_new.2.gz
+share/man/man2/DC_PLUG_new.2.gz
+share/man/man2/DC_PLUG_read.2.gz
+share/man/man2/DC_SERVER_new.2.gz
+share/man/man2/NAL_ADDRESS_new.2.gz
+share/man/man2/NAL_BUFFER_new.2.gz
+share/man/man2/NAL_CONNECTION_new.2.gz
+share/man/man2/NAL_LISTENER_new.2.gz
+share/man/man2/NAL_SELECTOR_new.2.gz
+share/man/man2/NAL_decode_uint32.2.gz
+share/man/man8/distcache.8.gz
share/swamp/A-client.pem
share/swamp/CA.pem
diff --git a/sysutils/parkverbot/Makefile b/sysutils/parkverbot/Makefile
index 576667972caf..aca112eb7b5a 100644
--- a/sysutils/parkverbot/Makefile
+++ b/sysutils/parkverbot/Makefile
@@ -13,8 +13,9 @@ LIB_DEPENDS= libHX.so:lang/libhx
USES= pkgconfig tar:xz
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
-PLIST_FILES= man/man8/parkverbot.8.gz sbin/parkverbot
+PLIST_FILES= share/man/man8/parkverbot.8.gz sbin/parkverbot
post-install:
${RM} -r ${STAGEDIR}/lib/systemd
diff --git a/www/thttpd/Makefile b/www/thttpd/Makefile
index 8737fc803096..837dc98453d6 100644
--- a/www/thttpd/Makefile
+++ b/www/thttpd/Makefile
@@ -12,6 +12,7 @@ LICENSE= BSD2CLAUSE
USES= cpe
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
MAKE_ARGS= WEBDIR=${WWWDIR}
USE_RC_SUBR= ${PORTNAME}
SUB_FILES= pkg-message thttpd.conf.sample
diff --git a/www/thttpd/pkg-plist b/www/thttpd/pkg-plist
index e44ccd338c07..1cf4e374df3c 100644
--- a/www/thttpd/pkg-plist
+++ b/www/thttpd/pkg-plist
@@ -1,11 +1,11 @@
etc/newsyslog.conf.d/thttpd.conf
@sample etc/thttpd.conf.sample
-man/man1/makeweb.1.gz
-man/man1/thtpasswd.1.gz
-man/man8/redirect.8.gz
-man/man8/ssi.8.gz
-man/man8/syslogtocern.8.gz
-man/man8/thttpd.8.gz
+share/man/man1/makeweb.1.gz
+share/man/man1/thtpasswd.1.gz
+share/man/man8/redirect.8.gz
+share/man/man8/ssi.8.gz
+share/man/man8/syslogtocern.8.gz
+share/man/man8/thttpd.8.gz
sbin/makeweb
sbin/syslogtocern
sbin/thttpd