aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-07-29 07:58:07 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-07-29 07:58:53 +0000
commit346b0e795afbd973672e213dd310b9239ee7ff6c (patch)
tree719315557721ab045aecf642627ce6b631d5d52f
parentbc9384ecb330ab263c3d5eefda52ec641444e2c3 (diff)
downloadports-346b0e795afbd973672e213dd310b9239ee7ff6c.tar.gz
ports-346b0e795afbd973672e213dd310b9239ee7ff6c.zip
graphics/darktable: prepare for cmake-3.21 update
Fix build against cmake-3.21: the ninja generator in 3.21 suffers a regression (see https://gitlab.kitware.com/cmake/cmake/-/issues/22487) appending an invalid "-Wl,--no-as-needed" to the linker arguments for static libraries. Once this regression has been fixed upstream, this can be switch back to USES=cmake PR: 257191
-rw-r--r--graphics/darktable/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index a8f941c3f508..31051d4f0563 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -31,7 +31,11 @@ LIB_DEPENDS= libcolord-gtk.so:graphics/colord-gtk \
libsoup-2.4.so:devel/libsoup \
libtiff.so:graphics/tiff
-USES= cmake compiler:c++14-lang desktop-file-utils gl gnome jpeg \
+# Fix build against cmake-3.21: the ninja generator in 3.21 suffers a regression
+# (see https://gitlab.kitware.com/cmake/cmake/-/issues/22487) appending an invalid
+# "-Wl,--no-as-needed" to the linker arguments for static libraries.
+# Once this regression has been fixed upstream, this can be switch back to USES=cmake
+USES= cmake:noninja compiler:c++14-lang desktop-file-utils gl gnome jpeg \
perl5 pkgconfig shebangfix sqlite tar:xz xorg
USE_GL= glu
USE_GNOME= cairo gtk30 intltool librsvg2 libxml2