aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-02-05 15:29:45 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-02-05 15:50:15 +0000
commit347b5b85e274420b07a8ed58ef8dc1640d9fa69e (patch)
treed9f6f347144928ad814a22a5f8a0fcc7bafddedd
parente177d5bb97bab8de20eee13554508ae058460da4 (diff)
downloadports-347b5b85e274420b07a8ed58ef8dc1640d9fa69e.tar.gz
ports-347b5b85e274420b07a8ed58ef8dc1640d9fa69e.zip
sysutils/puppet6: Fix build with rubygem-concurrent-ruby 1.2.0+
- Bump PORTREVISION for package change Use ThreadLocalVar instead of RubyThreadLocalVar which was removed in 1.2.0. RubyThreadLocalVar is a private class and an implementation detail. Reference: https://github.com/ruby-concurrency/concurrent-ruby/pull/988 https://github.com/ruby-concurrency/concurrent-ruby/issues/986 https://github.com/puppetlabs/puppet/commit/9182bc3dd2576f409a6d01fb5c08d392670e90a2
-rw-r--r--sysutils/puppet6/Makefile2
-rw-r--r--sysutils/puppet6/files/patch-lib_puppet_thread__local.rb13
2 files changed, 14 insertions, 1 deletions
diff --git a/sysutils/puppet6/Makefile b/sysutils/puppet6/Makefile
index 93bfa21c18d0..328dad15f882 100644
--- a/sysutils/puppet6/Makefile
+++ b/sysutils/puppet6/Makefile
@@ -1,6 +1,6 @@
PORTNAME= puppet
PORTVERSION= 6.28.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= https://forge.puppet.com/v3/files/:forge
PKGNAMESUFFIX= 6
diff --git a/sysutils/puppet6/files/patch-lib_puppet_thread__local.rb b/sysutils/puppet6/files/patch-lib_puppet_thread__local.rb
new file mode 100644
index 000000000000..0966f4b86576
--- /dev/null
+++ b/sysutils/puppet6/files/patch-lib_puppet_thread__local.rb
@@ -0,0 +1,13 @@
+Reference: https://github.com/ruby-concurrency/concurrent-ruby/pull/988
+ https://github.com/ruby-concurrency/concurrent-ruby/issues/986
+ https://github.com/puppetlabs/puppet/commit/9182bc3dd2576f409a6d01fb5c08d392670e90a2
+
+--- lib/puppet/thread_local.rb.orig 2022-07-11 22:46:41 UTC
++++ lib/puppet/thread_local.rb
+@@ -3,5 +3,5 @@ require 'concurrent'
+ # We want to use the pure Ruby implementation even on JRuby. If we use the Java
+ # implementation of ThreadLocal, we end up leaking references to JRuby instances
+ # and preventing them from being garbage collected.
+-class Puppet::ThreadLocal < Concurrent::RubyThreadLocalVar
++class Puppet::ThreadLocal < Concurrent::ThreadLocalVar
+ end