aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-05-02 16:15:59 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-05-02 16:15:59 +0000
commit347bcbe270c56aa919c82cb9bbd5816c642c7f79 (patch)
treeb5e706a2eb39306ae8d63cd79881c5f2364fad13
parentbe6901feb18a14daca6823beedec65a23d5e07f4 (diff)
downloadports-347bcbe270c56aa919c82cb9bbd5816c642c7f79.tar.gz
ports-347bcbe270c56aa919c82cb9bbd5816c642c7f79.zip
flavorize mail/roundcube and plugins.
PR: 227715 Submitted by: mat Approved by: maintainers Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=468851
-rw-r--r--mail/roundcube-automatic_addressbook/Makefile4
-rw-r--r--mail/roundcube-carddav/Makefile7
-rw-r--r--mail/roundcube-contextmenu/Makefile4
-rw-r--r--mail/roundcube-groupvice/Makefile4
-rw-r--r--mail/roundcube-html5_notifier/Makefile6
-rw-r--r--mail/roundcube-login_info/Makefile4
-rw-r--r--mail/roundcube-markasjunk2/Makefile6
-rw-r--r--mail/roundcube-mobilecube/Makefile5
-rw-r--r--mail/roundcube-mvision2/Makefile4
-rw-r--r--mail/roundcube-sauserprefs/Makefile4
-rw-r--r--mail/roundcube-sieverules/Makefile6
-rw-r--r--mail/roundcube-thunderbird_labels/Makefile4
-rw-r--r--mail/roundcube-umich/Makefile4
-rw-r--r--mail/roundcube-veximaccountadmin/Makefile4
-rw-r--r--mail/roundcube/Makefile3
15 files changed, 48 insertions, 21 deletions
diff --git a/mail/roundcube-automatic_addressbook/Makefile b/mail/roundcube-automatic_addressbook/Makefile
index 08b711ba9273..9e8f275c6718 100644
--- a/mail/roundcube-automatic_addressbook/Makefile
+++ b/mail/roundcube-automatic_addressbook/Makefile
@@ -4,14 +4,16 @@ PORTNAME= automatic_addressbook
PORTVERSION= 0.4.3
CATEGORIES= mail
PKGNAMEPREFIX= roundcube-
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
MAINTAINER= andrej@ebert.su
COMMENT= Roundcube webmail automatic addressbook plugin
LICENSE= GPLv3
-RUN_DEPENDS= roundcube>=0.8:mail/roundcube
+RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=0.8:mail/roundcube@${PHP_FLAVOR}
+USES= php:flavors
USE_GITHUB= yes
GH_ACCOUNT= sblaisot
diff --git a/mail/roundcube-carddav/Makefile b/mail/roundcube-carddav/Makefile
index 8a69e87059f7..e91c987527bf 100644
--- a/mail/roundcube-carddav/Makefile
+++ b/mail/roundcube-carddav/Makefile
@@ -7,14 +7,15 @@ PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= https://github.com/blind-coder/rcmcarddav/releases/download/v${PORTVERSION}/
PKGNAMEPREFIX= roundcube-
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
MAINTAINER= gahr@FreeBSD.org
COMMENT= Roundcube CardDAV plugin
LICENSE= GPLv2
-BUILD_DEPENDS= roundcube>=1.0:mail/roundcube
-RUN_DEPENDS= roundcube>=1.0:mail/roundcube
+BUILD_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=1.0:mail/roundcube@${PHP_FLAVOR}
+RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=1.0:mail/roundcube@${PHP_FLAVOR}
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -27,7 +28,7 @@ NO_ARCH= yes
#GH_ACCOUNT= blind-coder
#GH_PROJECT= rcmcarddav
-USES= php tar:bz2
+USES= php:flavors tar:bz2
USE_PHP= simplexml sockets curl
WWWDIR= ${PREFIX}/www/roundcube/plugins/carddav
diff --git a/mail/roundcube-contextmenu/Makefile b/mail/roundcube-contextmenu/Makefile
index d2aac1f8eec6..c9f258a7c5cf 100644
--- a/mail/roundcube-contextmenu/Makefile
+++ b/mail/roundcube-contextmenu/Makefile
@@ -5,14 +5,16 @@ PORTNAME= contextmenu
PORTVERSION= 2.3
CATEGORIES= mail
PKGNAMEPREFIX= roundcube-
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
MAINTAINER= moiseev@mezonplus.ru
COMMENT= RoundCube webmail contextmenu plugin
LICENSE= GPLv3
-RUN_DEPENDS= roundcube>=1.3:mail/roundcube
+RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=1.3:mail/roundcube@${PHP_FLAVOR}
+USES= php:flavors
NO_BUILD= yes
NO_ARCH= yes
diff --git a/mail/roundcube-groupvice/Makefile b/mail/roundcube-groupvice/Makefile
index 098b072341f1..f1c018d4c64c 100644
--- a/mail/roundcube-groupvice/Makefile
+++ b/mail/roundcube-groupvice/Makefile
@@ -6,12 +6,14 @@ PORTVERSION= 0.1.2
CATEGORIES= mail
MASTER_SITES= ftp://renatasystems.org/pub/FreeBSD/ports/distfiles/
PKGNAMEPREFIX= roundcube-
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Theme for RoundCube Web Mail
-RUN_DEPENDS= roundcube>=0.2:mail/roundcube
+RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=0.2:mail/roundcube@${PHP_FLAVOR}
+USES= php:flavors
NO_BUILD= yes
NO_ARCH= yes
diff --git a/mail/roundcube-html5_notifier/Makefile b/mail/roundcube-html5_notifier/Makefile
index fe9423c9e3fd..28d56c38ae00 100644
--- a/mail/roundcube-html5_notifier/Makefile
+++ b/mail/roundcube-html5_notifier/Makefile
@@ -6,15 +6,17 @@ PORTVERSION= 0.6.2
DISTVERSIONPREFIX= v
CATEGORIES= mail
PKGNAMEPREFIX= roundcube-
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
MAINTAINER= meta@FreeBSD.org
COMMENT= HTML5 desktop notifier plugin for roundcube
LICENSE= GPLv3
-RUN_DEPENDS= roundcube>=1.0:mail/roundcube
-BUILD_DEPENDS= roundcube>=1.0:mail/roundcube
+RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=1.0:mail/roundcube@${PHP_FLAVOR}
+BUILD_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=1.0:mail/roundcube@${PHP_FLAVOR}
+USES= php:flavors
USE_GITHUB= yes
GH_ACCOUNT= stremlau
diff --git a/mail/roundcube-login_info/Makefile b/mail/roundcube-login_info/Makefile
index 5c2c6e1ece87..6b1c76896ff9 100644
--- a/mail/roundcube-login_info/Makefile
+++ b/mail/roundcube-login_info/Makefile
@@ -7,6 +7,7 @@ PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= https://www.std-soft.de/webmail/plugins/
PKGNAMEPREFIX= roundcube-
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
DISTNAME= ${PORTNAME}_rc0.5_v${DISTVERSION}
MAINTAINER= feld@FreeBSD.org
@@ -14,8 +15,9 @@ COMMENT= Roundcube login info plugin
LICENSE= GPLv2
-RUN_DEPENDS= roundcube>=0.5:mail/roundcube
+RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=0.5:mail/roundcube@${PHP_FLAVOR}
+USES= php:flavors
NO_BUILD= yes
NO_ARCH= yes
diff --git a/mail/roundcube-markasjunk2/Makefile b/mail/roundcube-markasjunk2/Makefile
index c200a9452aac..88a970c33ef8 100644
--- a/mail/roundcube-markasjunk2/Makefile
+++ b/mail/roundcube-markasjunk2/Makefile
@@ -5,15 +5,17 @@ PORTNAME= markasjunk2
PORTVERSION= 1.11.1
CATEGORIES= mail
PKGNAMEPREFIX= roundcube-
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
MAINTAINER= gahr@FreeBSD.org
COMMENT= Roundcube mark-as-junk / mark-as-not-junk plugin
LICENSE= GPLv3
-BUILD_DEPENDS= roundcube>=1.0:mail/roundcube
-RUN_DEPENDS= roundcube>=1.0:mail/roundcube
+BUILD_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=1.0:mail/roundcube@${PHP_FLAVOR}
+RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=1.0:mail/roundcube@${PHP_FLAVOR}
+USES= php:flavors
USE_GITHUB= yes
GH_ACCOUNT= JohnDoh
GH_PROJECT= Roundcube-Plugin-Mark-as-Junk-2
diff --git a/mail/roundcube-mobilecube/Makefile b/mail/roundcube-mobilecube/Makefile
index fae983a6a0f6..5d080eadb9f2 100644
--- a/mail/roundcube-mobilecube/Makefile
+++ b/mail/roundcube-mobilecube/Makefile
@@ -7,16 +7,17 @@ CATEGORIES= mail
MASTER_SITES= SF/${PORTNAME}/${THEME_VERSION}%20Beta/Build%20%23${THEME_BUILD}/
PKGNAMEPREFIX= roundcube-
DISTNAME= MobileCubeBeta%23${THEME_BUILD}
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Theme for RoundCube Web Mail
-RUN_DEPENDS= roundcube>=0.3:mail/roundcube
+RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=0.3:mail/roundcube@${PHP_FLAVOR}
THEME_VERSION?= 3.1.0
THEME_BUILD?= 030110A
-USES= zip
+USES= php:flavors zip
NO_BUILD= yes
NO_ARCH= yes
diff --git a/mail/roundcube-mvision2/Makefile b/mail/roundcube-mvision2/Makefile
index f25759b41437..a27834036c4c 100644
--- a/mail/roundcube-mvision2/Makefile
+++ b/mail/roundcube-mvision2/Makefile
@@ -8,12 +8,14 @@ CATEGORIES= mail
MASTER_SITES= http://roundcubethemes.net/downloads/ \
ftp://renatasystems.org/pub/FreeBSD/ports/distfiles/
PKGNAMEPREFIX= roundcube-
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Theme for RoundCube Web Mail
-RUN_DEPENDS= roundcube>=0.2:mail/roundcube
+RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=0.2:mail/roundcube@${PHP_FLAVOR}
+USES= php:flavors
NO_BUILD= yes
NO_ARCH= yes
diff --git a/mail/roundcube-sauserprefs/Makefile b/mail/roundcube-sauserprefs/Makefile
index fae9290b8361..03ab027c0ae3 100644
--- a/mail/roundcube-sauserprefs/Makefile
+++ b/mail/roundcube-sauserprefs/Makefile
@@ -8,6 +8,7 @@ CATEGORIES= mail
MASTER_SITES= http://www.tehinterweb.co.uk/roundcube/plugins/ \
LOCAL/bdrewery/${PORTNAME}/${PORTVERSION}/
PKGNAMEPREFIX= roundcube-
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
DISTNAME= ${PORTNAME}
MAINTAINER= stb@lassitu.de
@@ -15,8 +16,9 @@ COMMENT= Roundcube plugin to manage SpamAssassin prefs
LICENSE= GPLv3
-RUN_DEPENDS= roundcube>=0.8:mail/roundcube
+RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=0.8:mail/roundcube@${PHP_FLAVOR}
+USES= php:flavors
NO_BUILD= yes
NO_ARCH= yes
diff --git a/mail/roundcube-sieverules/Makefile b/mail/roundcube-sieverules/Makefile
index aae2abb667d1..87f11513bae4 100644
--- a/mail/roundcube-sieverules/Makefile
+++ b/mail/roundcube-sieverules/Makefile
@@ -6,15 +6,17 @@ DISTVERSION= 2.3
PORTEPOCH= 1
CATEGORIES= mail
PKGNAMEPREFIX= roundcube-
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
MAINTAINER= ports@bsdserwis.com
COMMENT= Roundcube webmail sieve plugin
LICENSE= GPLv3
-BUILD_DEPENDS= roundcube>=1.0:mail/roundcube
-RUN_DEPENDS= roundcube>=1.0:mail/roundcube
+BUILD_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=1.0:mail/roundcube@${PHP_FLAVOR}
+RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=1.0:mail/roundcube@${PHP_FLAVOR}
+USES= php:flavors
USE_GITHUB= yes
GH_ACCOUNT= johndoh
GH_PROJECT= roundcube-sieverules
diff --git a/mail/roundcube-thunderbird_labels/Makefile b/mail/roundcube-thunderbird_labels/Makefile
index 9bf8c6abdf69..ffcd903911b8 100644
--- a/mail/roundcube-thunderbird_labels/Makefile
+++ b/mail/roundcube-thunderbird_labels/Makefile
@@ -6,6 +6,7 @@ PORTVERSION= 1.1.4
DISTVERSIONPREFIX= v
CATEGORIES= mail
PKGNAMEPREFIX= roundcube-
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
MAINTAINER= moiseev@mezonplus.ru
COMMENT= Thunderbird Labels plugin for RoundCube webmail
@@ -13,8 +14,9 @@ COMMENT= Thunderbird Labels plugin for RoundCube webmail
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.md
-RUN_DEPENDS= roundcube>=0.5:mail/roundcube
+RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=0.5:mail/roundcube@${PHP_FLAVOR}
+USES= php:flavors
NO_BUILD= yes
NO_ARCH= yes
diff --git a/mail/roundcube-umich/Makefile b/mail/roundcube-umich/Makefile
index bb75177f652b..1018ac380f27 100644
--- a/mail/roundcube-umich/Makefile
+++ b/mail/roundcube-umich/Makefile
@@ -6,12 +6,14 @@ PORTVERSION= 20090813
CATEGORIES= mail
MASTER_SITES= ftp://renatasystems.org/pub/FreeBSD/ports/distfiles/
PKGNAMEPREFIX= roundcube-
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Theme for RoundCube Web Mail
-RUN_DEPENDS= roundcube>=0.2:mail/roundcube
+RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=0.2:mail/roundcube@${PHP_FLAVOR}
+USES= php:flavors
NO_BUILD= yes
NO_ARCH= yes
diff --git a/mail/roundcube-veximaccountadmin/Makefile b/mail/roundcube-veximaccountadmin/Makefile
index 719e9e03db93..faf1f31260aa 100644
--- a/mail/roundcube-veximaccountadmin/Makefile
+++ b/mail/roundcube-veximaccountadmin/Makefile
@@ -7,6 +7,7 @@ PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= http://axel.sjostedt.no/misc/files/
PKGNAMEPREFIX= roundcube-
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
DISTNAME= rcube_plg_veximaccountadmin
MAINTAINER= feld@FreeBSD.org
@@ -14,8 +15,9 @@ COMMENT= Roundcube vexim account admin plugin
LICENSE= GPLv3
-RUN_DEPENDS= roundcube>=0.9:mail/roundcube
+RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=0.9:mail/roundcube@${PHP_FLAVOR}
+USES= php:flavors
NO_BUILD= yes
PLIST_SUB+= PLUGINDIR="${PLUGINDIR}"
diff --git a/mail/roundcube/Makefile b/mail/roundcube/Makefile
index 7a591ca9a83d..33d2822d5e90 100644
--- a/mail/roundcube/Makefile
+++ b/mail/roundcube/Makefile
@@ -6,6 +6,7 @@ PORTEPOCH= 1
CATEGORIES?= mail www
MASTER_SITES= https://github.com/roundcube/roundcubemail/releases/download/${DISTVERSION}/
DISTNAME= ${PORTNAME}mail-${DISTVERSION}-complete
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
MAINTAINER?= ale@FreeBSD.org
COMMENT= Fully skinnable XHTML/CSS webmail written in PHP
@@ -20,7 +21,7 @@ RCUBECOMP= SQL config .htaccess index.php installer logs \
plugins program skins temp vendor
PORTDOCS= CHANGELOG INSTALL README.md UPGRADING
-USES= cpe php:web
+USES= cpe php:web,flavors
CPE_PRODUCT= webmail
CPE_VENDOR= roundcube