aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoralt2600@icloud.com <alt2600@icloud.com>2023-07-14 07:22:33 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2023-07-14 07:24:52 +0000
commit347cd7d336121850e3b6234d4d4ebea96ab42588 (patch)
tree5159214e2f46690ef63837199cac56003331e2d6
parentc3a413762d4f057b69e689df9ceeaf17a64419ec (diff)
downloadports-347cd7d336121850e3b6234d4d4ebea96ab42588.tar.gz
ports-347cd7d336121850e3b6234d4d4ebea96ab42588.zip
graphics/qgis-ltr: Use default Python version
cmake's FindPython.cmake always returns the highest found Python version, although the default version is needed here, since only for this usually further tools like SIP etc. are installed. Passing the path of the default version to Python_EXECUTABLE causes the cmake configuration to use it. Co-authored-by: Rainer Hurling <rhurlin@gwdg.de> PR: 272457 MFH: 2023Q3
-rw-r--r--graphics/qgis-ltr/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/graphics/qgis-ltr/Makefile b/graphics/qgis-ltr/Makefile
index f16b4eed3641..342c9dd4cd77 100644
--- a/graphics/qgis-ltr/Makefile
+++ b/graphics/qgis-ltr/Makefile
@@ -117,11 +117,13 @@ USE_QT= 3d buildtools:build core concurrent dbus declarative \
SHEBANG_FILES= src/plugins/grass/scripts/*.py
+# Python_EXECUTABLE: Use the default version if multiple Pythons are available
CMAKE_ARGS+= -DCMAKE_BUILD_TYPE:STRING=Release \
-DHAVE_PGCONFIG=1 \
-DWITH_INTERNAL_MDAL:BOOL=false \
-DPYRCC_PROGRAM:FILEPATH=${LOCALBASE}/bin/pyrcc5-${PYTHON_VER} \
-DPYUIC_PROGRAM:FILEPATH=${LOCALBASE}/bin/pyuic5-${PYTHON_VER} \
+ -DPython_EXECUTABLE=${PYTHON_CMD} \
-DQSCI_SIP_DIR:PATH=${PYQT_SIPDIR}/Qsci \
-DQWT_INCLUDE_DIR:PATH=${LOCALBASE}/include/qt5/qwt6 \
-DQWT_LIBRARY:FILEPATH=${LOCALBASE}/lib/qt5/libqwt6.so \