aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Baldwin <jhb@FreeBSD.org>2023-07-04 17:14:08 +0000
committerJohn Baldwin <jhb@FreeBSD.org>2023-07-04 17:14:14 +0000
commit348c10112de61df7e66ea2d5a190700213542caa (patch)
treed28b3231d03f304b09ff7857b8c8dd7fc5e44c1f
parent57ea9f921cac5a808010757b6f73e621b6898873 (diff)
downloadports-348c10112de61df7e66ea2d5a190700213542caa.tar.gz
ports-348c10112de61df7e66ea2d5a190700213542caa.zip
devel/freebsd-gcc9: Build with -std=c++11.
This works around errors from clang from LLVM16 due to -Wregister warnings that are fatal in the default C++ standard (C++17) used by clang 16.
-rw-r--r--devel/freebsd-gcc9/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/devel/freebsd-gcc9/Makefile b/devel/freebsd-gcc9/Makefile
index 79d93195ca76..fd4ca08eb754 100644
--- a/devel/freebsd-gcc9/Makefile
+++ b/devel/freebsd-gcc9/Makefile
@@ -26,6 +26,8 @@ TARGETARCH= ${FLAVOR}
USES= compiler:c++11-lang cpe gmake iconv libtool makeinfo tar:xz
CPE_VENDOR= gnu
+CXXFLAGS+= -std=c++11
+
PLIST_SUB= OPSYS=${OPSYS:tl} \
SUFFIX=${SUFFIX} \
TARGETARCH=${TARGETARCH} \