aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-01-29 17:40:22 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-01-29 17:40:22 +0000
commit34b667d1322519b131345d68fcb019aa166c647c (patch)
treef8441f64f36b85abf2c942cb6faa0afe9256b627
parent41e4f0ecb101a9834c418c58fb4c961b41a9c56e (diff)
downloadports-34b667d1322519b131345d68fcb019aa166c647c.tar.gz
ports-34b667d1322519b131345d68fcb019aa166c647c.zip
devel/poetry: New port: Python dependency management and packaging made easy
-rw-r--r--devel/Makefile1
-rw-r--r--devel/poetry/Makefile46
-rw-r--r--devel/poetry/distinfo3
-rw-r--r--devel/poetry/pkg-descr2
4 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ab0a6bcf427e..da059559ad94 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4095,6 +4095,7 @@
SUBDIR += pmd
SUBDIR += pmdk
SUBDIR += poco
+ SUBDIR += poetry
SUBDIR += popt
SUBDIR += poxml
SUBDIR += ppl
diff --git a/devel/poetry/Makefile b/devel/poetry/Makefile
new file mode 100644
index 000000000000..7dbd7b9e419e
--- /dev/null
+++ b/devel/poetry/Makefile
@@ -0,0 +1,46 @@
+PORTNAME= poetry
+DISTVERSION= 1.3.2
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMESUFFIX= -python-tool
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python dependency management and packaging made easy
+WWW= https://python-poetry.org/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+PY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}CacheControl>=0.12.9:www/py-cachecontrol@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cleo>0:devel/py-cleo@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}crashtest>=0.4.1:devel/py-crashtest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dulwich>0:devel/py-dulwich@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}filelock>=3.8.0:sysutils/py-filelock@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}html5lib>=1.0:www/py-html5lib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=4.4:devel/py-importlib-metadata@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jsonschema>=4.10.0:devel/py-jsonschema@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}keyring>=23.9.0:security/py-keyring@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lockfile>=0.12.2:devel/py-lockfile@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>=20.4:devel/py-packaging@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pexpect>=4.7.0:misc/py-pexpect@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pkginfo>=1.5:sysutils/py-pkginfo@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}platformdirs>=2.5.2:devel/py-platformdirs@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}poetry-core>0:devel/py-poetry-core@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}poetry-plugin-export>=1.2.0:devel/py-poetry-plugin-export@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests-toolbelt>=0.9.1<0.11.0:www/py-requests-toolbelt@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.18:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}shellingham>=1.5:devel/py-shellingham@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tomli>=2.0.1:textproc/py-tomli@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tomlkit>=0.11.1<1.0.0:textproc/py-tomlkit@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}trove-classifiers>=2022.5.19:devel/py-trove-classifiers@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}urllib3>=1.26.0:net/py-urllib3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}virtualenv>=20.4.3:devel/py-virtualenv@${PY_FLAVOR}
+BUILD_DEPENDS= ${PY_DEPENDS}
+RUN_DEPENDS= ${PY_DEPENDS}
+
+USES= python:3.7+
+USE_PYTHON= pep517 noflavors concurrent autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/poetry/distinfo b/devel/poetry/distinfo
new file mode 100644
index 000000000000..3f945e9b5391
--- /dev/null
+++ b/devel/poetry/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1675009621
+SHA256 (poetry-1.3.2.tar.gz) = 26ded25f0cf67943243ca4f0aafd47ec4668bdb62845dbb8c2b0e3d9cd280bf4
+SIZE (poetry-1.3.2.tar.gz) = 871903
diff --git a/devel/poetry/pkg-descr b/devel/poetry/pkg-descr
new file mode 100644
index 000000000000..40b7f0b579d5
--- /dev/null
+++ b/devel/poetry/pkg-descr
@@ -0,0 +1,2 @@
+Poetry helps you declare, manage and install dependencies of Python projects,
+ensuring you have the right stack everywhere.