aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2023-12-08 21:35:37 +0000
committerCy Schubert <cy@FreeBSD.org>2023-12-08 21:37:46 +0000
commit34cb0cf452407519af17610ec07e78fa6240e83a (patch)
tree1dd06b7045ac9de7152490b8b495bd6092a4347f
parenta4d87da5309a39c59cecb0f1a5ee7d7a4c634527 (diff)
downloadports-34cb0cf452407519af17610ec07e78fa6240e83a.tar.gz
ports-34cb0cf452407519af17610ec07e78fa6240e83a.zip
mail/exmh-devel: New port
mail/exmh-devel will track exmh development on Sourceforge proxied through my GH account.
-rw-r--r--mail/Makefile1
-rw-r--r--mail/exmh-devel/Makefile69
-rw-r--r--mail/exmh-devel/distinfo3
-rw-r--r--mail/exmh-devel/files/config.mh27
-rw-r--r--mail/exmh-devel/files/config.nmh27
-rw-r--r--mail/exmh-devel/files/patch-lib_exwin.tcl35
-rw-r--r--mail/exmh-devel/files/patch-lib_fdisp.tcl11
-rw-r--r--mail/exmh-devel/files/patch-lib_html__text.tcl20
-rw-r--r--mail/exmh-devel/pkg-descr21
-rw-r--r--mail/exmh-devel/pkg-plist230
-rw-r--r--mail/exmh-devel/scripts/build85
-rw-r--r--mail/exmh-devel/scripts/install46
12 files changed, 575 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 071282f342dd..d65e794153da 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -127,6 +127,7 @@
SUBDIR += exim-sa-exim
SUBDIR += exim-sqlite
SUBDIR += exipick
+ SUBDIR += exmh-devel
SUBDIR += exmh2
SUBDIR += ez-pine-gpg
SUBDIR += ezmlm
diff --git a/mail/exmh-devel/Makefile b/mail/exmh-devel/Makefile
new file mode 100644
index 000000000000..d179b5b5af8d
--- /dev/null
+++ b/mail/exmh-devel/Makefile
@@ -0,0 +1,69 @@
+# "+=" and "?=" lines are for sharing this Makefile with japanese/exmh2.
+
+PORTNAME= exmh
+PORTVERSION= ${COMMIT_DATE}
+CATEGORIES+= mail tk
+.if !defined(MASTERDIR)
+PKGNAMESUFFIX= -devel
+.endif
+
+MAINTAINER?= cy@FreeBSD.org
+COMMENT?= X11/TK based mail reader front end to MH
+WWW= http://www.beedub.com/exmh/
+
+USE_GITHUB= yes
+GH_ACCOUNT= cschuber
+GH_PROJECT= exmh
+GH_TAGNAME= be4b011
+COMMIT_DATE= 2022.09.28
+
+.if defined(JAPANESE_EXMH)
+RUN_DEPENDS= wish8.0jp:japanese/tk80
+BUILD_DEPENDS= tclsh8.0jp:japanese/tcl80
+WISH= wish8.0jp
+TCLSH= tclsh8.0jp
+.else
+USES= cpe tk:87
+.endif
+
+# exmh is pretty useless without this, but it's not needed to build it.
+.if defined(JAPANESE_EXMH)
+RUN_DEPENDS+= repl:japanese/mh
+.else
+RUN_DEPENDS+= repl:mail/nmh
+SCRIPTS_ENV+= USE_NMH=YES
+.endif
+
+# full mime support needs mmencode/mmdecode from metamail
+RUN_DEPENDS+= mmencode:mail/metamail
+
+# Additionally, exmh will use the following ports if present:
+# lang/expect
+# textproc/glimpse
+# security/gnupg
+# security/pgp
+# security/pgp5
+# mail/faces
+# audio/rplay
+
+PLIST_SUB= EXMH_VERSION=2.9.0
+
+NO_ARCH= yes
+
+.if defined(JAPANESE_EXMH)
+do-build:
+ @cd ${WRKSRC} && ${SETENV} PREFIX=${PREFIX} TCLSH=${TCLSH} \
+ WISH=${PREFIX}/bin/${WISH} WRKSRC=${WRKSRC} \
+ ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/build
+.else
+do-build:
+ @cd ${WRKSRC} && ${SETENV} PREFIX=${PREFIX} TCLSH=${TCLSH} \
+ WISH=${WISH} WRKSRC=${WRKSRC} \
+ ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/build
+.endif
+
+do-install:
+ @cd ${WRKSRC} && ${SETENV} PREFIX=${STAGEDIR}${PREFIX} \
+ WRKSRC=${WRKSRC} ${SH} ${SCRIPTDIR}/install
+
+.include <bsd.port.mk>
diff --git a/mail/exmh-devel/distinfo b/mail/exmh-devel/distinfo
new file mode 100644
index 000000000000..aa225de487dd
--- /dev/null
+++ b/mail/exmh-devel/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1702070915
+SHA256 (cschuber-exmh-2022.09.28-be4b011_GH0.tar.gz) = 479449564bf53c43b5848dbbabfe7107c013e485e8c0c34443387c974e60463e
+SIZE (cschuber-exmh-2022.09.28-be4b011_GH0.tar.gz) = 1002297
diff --git a/mail/exmh-devel/files/config.mh b/mail/exmh-devel/files/config.mh
new file mode 100644
index 000000000000..5a1f52b85bdb
--- /dev/null
+++ b/mail/exmh-devel/files/config.mh
@@ -0,0 +1,27 @@
+set wish !!WISH!!
+set exmh(version) {version !!VERSION!! !!DATE!!}
+set exmh(name) exmh
+set exmh(maintainer) welch@acm.org
+set mh_path !!PREFIX!!/bin
+set exmh(slocal) !!PREFIX!!/lib/mh/slocal
+set mime(dir) !!PREFIX!!/bin
+set mailcap_default !!PREFIX!!/etc/mailcap
+set mimetypes_default !!PREFIX!!/lib/exmh-!!VERSION!!/mime.types
+set exmh(expect) !!EXPECT!!
+set exmh(expectk) !!EXPECTK!!
+set faces(dir) !!FACES!!
+set faces(set,user) {local users usenix misc}
+set faces(set,unknown) {domains unknown}
+set faces(set,news) {news}
+set faces(defaultDomain) !!DOMAIN!!
+set faces(suffix) {xpm gif xbm}
+set pgp(gpg,path) !!GPG!!
+set pgp(pgp,path) !!PGP!!
+set pgp(pgp5,path) !!PGP5!!
+set pgp(pgp6,path) !!PGP6!!
+set glimpse(path) !!GLIMPSE!!
+set sound(cmd) !!PLAY!!
+set exmh(library) !!PREFIX!!/lib/exmh-!!VERSION!!
+set install(dir,bin) !!PREFIX!!/bin
+set install(dir,man) !!PREFIX!!/man/man1
+set install(dir,lib) !!PREFIX!!/lib/exmh-!!VERSION!!
diff --git a/mail/exmh-devel/files/config.nmh b/mail/exmh-devel/files/config.nmh
new file mode 100644
index 000000000000..a595ffbea417
--- /dev/null
+++ b/mail/exmh-devel/files/config.nmh
@@ -0,0 +1,27 @@
+set wish !!WISH!!
+set exmh(version) {version !!VERSION!! !!DATE!!}
+set exmh(name) exmh
+set exmh(maintainer) welch@acm.org
+set mh_path !!PREFIX!!/bin
+set exmh(slocal) !!PREFIX!!/libexec/nmh/slocal
+set mime(dir) !!PREFIX!!/bin
+set mailcap_default !!PREFIX!!/etc/mailcap
+set mimetypes_default !!PREFIX!!/lib/exmh-!!VERSION!!/mime.types
+set exmh(expect) !!EXPECT!!
+set exmh(expectk) !!EXPECTK!!
+set faces(dir) !!FACES!!
+set faces(set,user) {local users usenix misc}
+set faces(set,unknown) {domains unknown}
+set faces(set,news) {news}
+set faces(defaultDomain) !!DOMAIN!!
+set faces(suffix) {xpm gif xbm}
+set pgp(gpg,path) !!GPG!!
+set pgp(pgp,path) !!PGP!!
+set pgp(pgp5,path) !!PGP5!!
+set pgp(pgp6,path) !!PGP6!!
+set glimpse(path) !!GLIMPSE!!
+set sound(cmd) !!PLAY!!
+set exmh(library) !!PREFIX!!/lib/exmh-!!VERSION!!
+set install(dir,bin) !!PREFIX!!/bin
+set install(dir,man) !!PREFIX!!/man/man1
+set install(dir,lib) !!PREFIX!!/lib/exmh-!!VERSION!!
diff --git a/mail/exmh-devel/files/patch-lib_exwin.tcl b/mail/exmh-devel/files/patch-lib_exwin.tcl
new file mode 100644
index 000000000000..c4e739d62e0a
--- /dev/null
+++ b/mail/exmh-devel/files/patch-lib_exwin.tcl
@@ -0,0 +1,35 @@
+--- lib/exwin.tcl.orig 2017-11-09 20:42:24.000000000 -0800
++++ lib/exwin.tcl 2021-09-06 06:53:11.916007000 -0700
+@@ -101,12 +101,26 @@
+ }
+
+ proc mscroll {bindtag num} {
+- bind $bindtag <Button-5> [list %W yview scroll $num units]
+- bind $bindtag <Button-4> [list %W yview scroll -$num units]
+- bind $bindtag <Shift-Button-5> [list %W yview scroll 1 units]
+- bind $bindtag <Shift-Button-4> [list %W yview scroll -1 units]
+- bind $bindtag <Control-Button-5> [list %W yview scroll 1 pages]
+- bind $bindtag <Control-Button-4> [list %W yview scroll -1 pages]
++ # Prior to tcl 8.7a5:
++ # bind $bindtag <Button-5> [list %W yview scroll $num units]
++ # bind $bindtag <Button-4> [list %W yview scroll -$num units]
++ # bind $bindtag <Shift-Button-5> [list %W yview scroll 1 units]
++ # bind $bindtag <Shift-Button-4> [list %W yview scroll -1 units]
++ # bind $bindtag <Control-Button-5> [list %W yview scroll 1 pages]
++ # bind $bindtag <Control-Button-4> [list %W yview scroll -1 pages]
++
++ # tcl 8.7a5 and later. See
++ # https://core.tcl-lang.org/tips/doc/trunk/tip/474.md for more info:
++ bind $bindtag <MouseWheel> [ list tk::MouseWheel %W y %D [ expr 10/-$num ] pixels ]
++ bind $bindtag <Shift-MouseWheel> { tk::MouseWheel %W y %D -10 pixels }
++ bind $bindtag <Control-MouseWheel> { tk::MouseWheel %W y %D -1 pixels }
++}
++
++
++proc fmscroll {bindtag num} {
++ bind $bindtag <MouseWheel> [ list tk::MouseWheel %W y %D [ expr 200/-$num ] units ]
++ bind $bindtag <Shift-MouseWheel> { tk::MouseWheel %W y %D [expr 200/-10 ] units }
++ bind $bindtag <Control-MouseWheel> { tk::MouseWheel %W y %D -1 units }
+ }
+
+
diff --git a/mail/exmh-devel/files/patch-lib_fdisp.tcl b/mail/exmh-devel/files/patch-lib_fdisp.tcl
new file mode 100644
index 000000000000..262d80a1cf8f
--- /dev/null
+++ b/mail/exmh-devel/files/patch-lib_fdisp.tcl
@@ -0,0 +1,11 @@
+--- lib/fdisp.tcl.orig 2017-11-09 20:42:24.000000000 -0800
++++ lib/fdisp.tcl 2021-09-06 06:49:07.808426000 -0700
+@@ -254,7 +254,7 @@
+
+ # Enable wheelscroll if desired
+ if {$exwin(wheelEnabled)} {
+- mscroll $fdisp(canvas) 1
++ fmscroll $fdisp(canvas) 5
+ }
+
+ # fdisp popup color hack
diff --git a/mail/exmh-devel/files/patch-lib_html__text.tcl b/mail/exmh-devel/files/patch-lib_html__text.tcl
new file mode 100644
index 000000000000..88391545e54d
--- /dev/null
+++ b/mail/exmh-devel/files/patch-lib_html__text.tcl
@@ -0,0 +1,20 @@
+--- lib/html_text.tcl.orig 2017-11-09 20:42:24.000000000 -0800
++++ lib/html_text.tcl 2021-08-31 11:19:25.451174000 -0700
+@@ -60,7 +60,7 @@
+ }
+ set state(tag) $tag
+ $win dump -tag -text -window -command \
+- [list TextUndoTagAddProc state $win] $m1 $m2
++ [list TextUndoTagAddProc state $win] $m1 $m2 tag
+ TextUndoTagAdd state $win [$win index $m2]
+ $win tag add $tag $m1 $m2
+ }
+@@ -179,7 +179,7 @@
+ unset state(ix)
+ }
+ }
+-proc TextUndoTagAddProc {stateVar win key value ix} {
++proc TextUndoTagAddProc {stateVar win key value ix tag} {
+ upvar $stateVar state
+ switch -- $key {
+ tagon {
diff --git a/mail/exmh-devel/pkg-descr b/mail/exmh-devel/pkg-descr
new file mode 100644
index 000000000000..723a97c59cf7
--- /dev/null
+++ b/mail/exmh-devel/pkg-descr
@@ -0,0 +1,21 @@
+exmh is a TCL/TK based interface to the MH mail system. It provides
+the usual layer on top of MH commands, as well as many other features:
+
+ MIME support! Displays richtext and enriched directly.
+ Color feedback in the scan listing.
+ A colour coded folder display with one label per folder.
+ Smart scan caching. News read/post. koi8-r support.
+ Facesaver bitmap display. Ispell support.
+ Background inc. You can set exmh to run inc periodically.
+ Searching over folder listing and message body.
+ A dialog-box interface to MH pick.
+ An editor with emacs-like bindings and MIME support.
+ Glimpse interface. You can index all your mail with glimpse
+ and search for messages by content.
+ User preferences. You can tune exmh through a dialog box.
+ User hacking support. A user library of TCL routines is supported.
+
+IMPORTANT: exmh depends on the TK send facility for its background
+processing. With TK 3.3, send now uses xauthority mechanisms by default,
+unless you compile TK with -DTK_NO_SECURITY. Generally, this means that
+you **MUST** must run xdm to start your Xserver.
diff --git a/mail/exmh-devel/pkg-plist b/mail/exmh-devel/pkg-plist
new file mode 100644
index 000000000000..d060d63b0826
--- /dev/null
+++ b/mail/exmh-devel/pkg-plist
@@ -0,0 +1,230 @@
+@mode 555
+@owner bin
+@group bin
+bin/exmh
+bin/exmh-async
+bin/exmh-bg
+bin/exmh-strip
+bin/ftp.expect
+bin/inc.expect
+@owner bin
+@group bin
+@dir lib/exmh-%%EXMH_VERSION%%
+@mode 444
+lib/exmh-%%EXMH_VERSION%%/PgpDecryptExpect
+lib/exmh-%%EXMH_VERSION%%/addr.tcl
+lib/exmh-%%EXMH_VERSION%%/aliases.tcl
+lib/exmh-%%EXMH_VERSION%%/app-defaults
+lib/exmh-%%EXMH_VERSION%%/app-defaults-color
+lib/exmh-%%EXMH_VERSION%%/app-defaults-mono
+lib/exmh-%%EXMH_VERSION%%/audit.tcl
+lib/exmh-%%EXMH_VERSION%%/autorefile.tcl
+lib/exmh-%%EXMH_VERSION%%/background.tcl
+lib/exmh-%%EXMH_VERSION%%/base64.tcl
+lib/exmh-%%EXMH_VERSION%%/bindings.tcl
+lib/exmh-%%EXMH_VERSION%%/bitmaps/abort.xbm
+lib/exmh-%%EXMH_VERSION%%/bitmaps/address.xbm
+lib/exmh-%%EXMH_VERSION%%/bitmaps/bind.xbm
+lib/exmh-%%EXMH_VERSION%%/bitmaps/bitmaps.defaults
+lib/exmh-%%EXMH_VERSION%%/bitmaps/commit.xbm
+lib/exmh-%%EXMH_VERSION%%/bitmaps/compose.xbm
+lib/exmh-%%EXMH_VERSION%%/bitmaps/delete.xbm
+lib/exmh-%%EXMH_VERSION%%/bitmaps/forward.xbm
+lib/exmh-%%EXMH_VERSION%%/bitmaps/getmail.xbm
+lib/exmh-%%EXMH_VERSION%%/bitmaps/help.xbm
+lib/exmh-%%EXMH_VERSION%%/bitmaps/link.xbm
+lib/exmh-%%EXMH_VERSION%%/bitmaps/move.xbm
+lib/exmh-%%EXMH_VERSION%%/bitmaps/new.xbm
+lib/exmh-%%EXMH_VERSION%%/bitmaps/phone.xbm
+lib/exmh-%%EXMH_VERSION%%/bitmaps/pref.xbm
+lib/exmh-%%EXMH_VERSION%%/bitmaps/quote.xbm
+lib/exmh-%%EXMH_VERSION%%/bitmaps/scan.xbm
+lib/exmh-%%EXMH_VERSION%%/bitmaps/search.xbm
+lib/exmh-%%EXMH_VERSION%%/bitmaps/send.xbm
+lib/exmh-%%EXMH_VERSION%%/bitmaps/sign.xbm
+lib/exmh-%%EXMH_VERSION%%/bitmaps/unmark.xbm
+lib/exmh-%%EXMH_VERSION%%/bitmaps/write.xbm
+lib/exmh-%%EXMH_VERSION%%/bogo.tcl
+lib/exmh-%%EXMH_VERSION%%/busy.tcl
+lib/exmh-%%EXMH_VERSION%%/buttons.tcl
+lib/exmh-%%EXMH_VERSION%%/calendar.tcl
+lib/exmh-%%EXMH_VERSION%%/clink.au
+lib/exmh-%%EXMH_VERSION%%/crypt.tcl
+lib/exmh-%%EXMH_VERSION%%/cutbuffer.tcl
+lib/exmh-%%EXMH_VERSION%%/dragNdrop.tcl
+lib/exmh-%%EXMH_VERSION%%/drip.au
+lib/exmh-%%EXMH_VERSION%%/editor.tcl
+lib/exmh-%%EXMH_VERSION%%/env.tcl
+lib/exmh-%%EXMH_VERSION%%/error.tcl
+lib/exmh-%%EXMH_VERSION%%/exec.tcl
+lib/exmh-%%EXMH_VERSION%%/exmh.bitmap
+lib/exmh-%%EXMH_VERSION%%/extrasInit.tcl
+lib/exmh-%%EXMH_VERSION%%/exwin.tcl
+lib/exmh-%%EXMH_VERSION%%/faces.tcl
+lib/exmh-%%EXMH_VERSION%%/fcache.tcl
+lib/exmh-%%EXMH_VERSION%%/fdisp.tcl
+lib/exmh-%%EXMH_VERSION%%/fdispColor.tcl
+lib/exmh-%%EXMH_VERSION%%/fdispPopup.tcl
+lib/exmh-%%EXMH_VERSION%%/fileselect.tcl
+lib/exmh-%%EXMH_VERSION%%/find.tcl
+lib/exmh-%%EXMH_VERSION%%/flag.tcl
+lib/exmh-%%EXMH_VERSION%%/flagdown.bitmap
+lib/exmh-%%EXMH_VERSION%%/flagdown.gif
+lib/exmh-%%EXMH_VERSION%%/flagdown.mask
+lib/exmh-%%EXMH_VERSION%%/flagspool.bitmap
+lib/exmh-%%EXMH_VERSION%%/flagspool.gif
+lib/exmh-%%EXMH_VERSION%%/flagspool.mask
+lib/exmh-%%EXMH_VERSION%%/flagup.bitmap
+lib/exmh-%%EXMH_VERSION%%/flagup.gif
+lib/exmh-%%EXMH_VERSION%%/flagup.mask
+lib/exmh-%%EXMH_VERSION%%/flist.tcl
+lib/exmh-%%EXMH_VERSION%%/folder.tcl
+lib/exmh-%%EXMH_VERSION%%/folderNew.tcl
+lib/exmh-%%EXMH_VERSION%%/fontsel.tcl
+lib/exmh-%%EXMH_VERSION%%/ftoc.tcl
+lib/exmh-%%EXMH_VERSION%%/ftocFind.tcl
+lib/exmh-%%EXMH_VERSION%%/ftp_get.tcl
+lib/exmh-%%EXMH_VERSION%%/getnews.tcl
+lib/exmh-%%EXMH_VERSION%%/glimpse.tcl
+lib/exmh-%%EXMH_VERSION%%/help.tcl
+lib/exmh-%%EXMH_VERSION%%/hourglass.bitmap
+lib/exmh-%%EXMH_VERSION%%/hourglass.mask
+lib/exmh-%%EXMH_VERSION%%/hourglass1.bitmap
+lib/exmh-%%EXMH_VERSION%%/hourglass2.bitmap
+lib/exmh-%%EXMH_VERSION%%/hourglass2.mask
+lib/exmh-%%EXMH_VERSION%%/html.tcl
+lib/exmh-%%EXMH_VERSION%%/html/AddrEdit.html
+lib/exmh-%%EXMH_VERSION%%/html/AddressBk.html
+lib/exmh-%%EXMH_VERSION%%/html/AliasAddr.html
+lib/exmh-%%EXMH_VERSION%%/html/Aliases.html
+lib/exmh-%%EXMH_VERSION%%/html/Bindings.html
+lib/exmh-%%EXMH_VERSION%%/html/DSN-MDN.html
+lib/exmh-%%EXMH_VERSION%%/html/Font.html
+lib/exmh-%%EXMH_VERSION%%/html/Import.html
+lib/exmh-%%EXMH_VERSION%%/html/Intro.html
+lib/exmh-%%EXMH_VERSION%%/html/Keys.html
+lib/exmh-%%EXMH_VERSION%%/html/Lists.html
+lib/exmh-%%EXMH_VERSION%%/html/PGP.html
+lib/exmh-%%EXMH_VERSION%%/html/Preferences.html
+lib/exmh-%%EXMH_VERSION%%/html/Reply.html
+lib/exmh-%%EXMH_VERSION%%/html/Search.html
+lib/exmh-%%EXMH_VERSION%%/html/Sedit.html
+lib/exmh-%%EXMH_VERSION%%/html/Seditpref.html
+lib/exmh-%%EXMH_VERSION%%/html/Y2K.html
+lib/exmh-%%EXMH_VERSION%%/html/blu-ball.gif
+lib/exmh-%%EXMH_VERSION%%/html/bugfixes.html
+lib/exmh-%%EXMH_VERSION%%/html/copyright.html
+lib/exmh-%%EXMH_VERSION%%/html/custom.html
+lib/exmh-%%EXMH_VERSION%%/html/exmh-fans.html
+lib/exmh-%%EXMH_VERSION%%/html/exmh-faq.html
+lib/exmh-%%EXMH_VERSION%%/html/exmh.README.html
+lib/exmh-%%EXMH_VERSION%%/html/exmh.pref.gif
+lib/exmh-%%EXMH_VERSION%%/html/exmh.snap1.gif
+lib/exmh-%%EXMH_VERSION%%/html/guide.html
+lib/exmh-%%EXMH_VERSION%%/html/index.html
+lib/exmh-%%EXMH_VERSION%%/html/left-arrow.gif
+lib/exmh-%%EXMH_VERSION%%/html/maillist.html
+lib/exmh-%%EXMH_VERSION%%/html/mime.attack.html
+lib/exmh-%%EXMH_VERSION%%/html/newfeatures.html
+lib/exmh-%%EXMH_VERSION%%/html/overview.html
+lib/exmh-%%EXMH_VERSION%%/html/ppp.howto.html
+lib/exmh-%%EXMH_VERSION%%/html/red-ball.gif
+lib/exmh-%%EXMH_VERSION%%/html/reference.html
+lib/exmh-%%EXMH_VERSION%%/html/right-arrow.gif
+lib/exmh-%%EXMH_VERSION%%/html/software.html
+lib/exmh-%%EXMH_VERSION%%/html/symlink.html
+lib/exmh-%%EXMH_VERSION%%/html/tutorial.html
+lib/exmh-%%EXMH_VERSION%%/html/whatis.html
+lib/exmh-%%EXMH_VERSION%%/html/yel-ball.gif
+lib/exmh-%%EXMH_VERSION%%/html_cache.tcl
+lib/exmh-%%EXMH_VERSION%%/html_content.tcl
+lib/exmh-%%EXMH_VERSION%%/html_dpackage.tcl
+lib/exmh-%%EXMH_VERSION%%/html_formtag.tcl
+lib/exmh-%%EXMH_VERSION%%/html_frame.tcl
+lib/exmh-%%EXMH_VERSION%%/html_get_http.tcl
+lib/exmh-%%EXMH_VERSION%%/html_head.tcl
+lib/exmh-%%EXMH_VERSION%%/html_hr.tcl
+lib/exmh-%%EXMH_VERSION%%/html_images.tcl
+lib/exmh-%%EXMH_VERSION%%/html_links.tcl
+lib/exmh-%%EXMH_VERSION%%/html_maps.tcl
+lib/exmh-%%EXMH_VERSION%%/html_stubs.tcl
+lib/exmh-%%EXMH_VERSION%%/html_tags.tcl
+lib/exmh-%%EXMH_VERSION%%/html_text.tcl
+lib/exmh-%%EXMH_VERSION%%/http_proxy.tcl
+lib/exmh-%%EXMH_VERSION%%/import.tcl
+lib/exmh-%%EXMH_VERSION%%/inc.tcl
+lib/exmh-%%EXMH_VERSION%%/ispell.tcl
+lib/exmh-%%EXMH_VERSION%%/labels.tcl
+lib/exmh-%%EXMH_VERSION%%/linethru.bitmap
+lib/exmh-%%EXMH_VERSION%%/loaderror.ppm
+lib/exmh-%%EXMH_VERSION%%/loading.ppm
+lib/exmh-%%EXMH_VERSION%%/mailcap.tcl
+lib/exmh-%%EXMH_VERSION%%/main.tcl
+lib/exmh-%%EXMH_VERSION%%/mbempty.bitmap
+lib/exmh-%%EXMH_VERSION%%/mbtidy.bitmap
+lib/exmh-%%EXMH_VERSION%%/mbuntidy.bitmap
+lib/exmh-%%EXMH_VERSION%%/mh.tcl
+lib/exmh-%%EXMH_VERSION%%/mime.tcl
+lib/exmh-%%EXMH_VERSION%%/mime.types
+lib/exmh-%%EXMH_VERSION%%/mimencode.tcl
+lib/exmh-%%EXMH_VERSION%%/mimeSun.tcl
+lib/exmh-%%EXMH_VERSION%%/mosaic.tcl
+lib/exmh-%%EXMH_VERSION%%/msg.tcl
+lib/exmh-%%EXMH_VERSION%%/msgShow.tcl
+lib/exmh-%%EXMH_VERSION%%/pgpBase.tcl
+lib/exmh-%%EXMH_VERSION%%/pgpEWN.tcl
+lib/exmh-%%EXMH_VERSION%%/pgpExec.tcl
+lib/exmh-%%EXMH_VERSION%%/pgpGpg.tcl
+lib/exmh-%%EXMH_VERSION%%/pgpMain.tcl
+lib/exmh-%%EXMH_VERSION%%/pgpMatch.tcl
+lib/exmh-%%EXMH_VERSION%%/pgpMisc.tcl
+lib/exmh-%%EXMH_VERSION%%/pgpOld.tcl
+lib/exmh-%%EXMH_VERSION%%/pgpPgp2.tcl
+lib/exmh-%%EXMH_VERSION%%/pgpPgp5.tcl
+lib/exmh-%%EXMH_VERSION%%/pgpPgp65.tcl
+lib/exmh-%%EXMH_VERSION%%/pgpShared.tcl
+lib/exmh-%%EXMH_VERSION%%/pgpWWW.tcl
+lib/exmh-%%EXMH_VERSION%%/pick.tcl
+lib/exmh-%%EXMH_VERSION%%/pop.tcl
+lib/exmh-%%EXMH_VERSION%%/post.tcl
+lib/exmh-%%EXMH_VERSION%%/preferences.tcl
+lib/exmh-%%EXMH_VERSION%%/print.tcl
+lib/exmh-%%EXMH_VERSION%%/ps.tcl
+lib/exmh-%%EXMH_VERSION%%/quote.tcl
+lib/exmh-%%EXMH_VERSION%%/receipt.tcl
+lib/exmh-%%EXMH_VERSION%%/report.tcl
+lib/exmh-%%EXMH_VERSION%%/rich2tk.tcl
+lib/exmh-%%EXMH_VERSION%%/scan.tcl
+lib/exmh-%%EXMH_VERSION%%/sedit.tcl
+lib/exmh-%%EXMH_VERSION%%/seditBind.tcl
+lib/exmh-%%EXMH_VERSION%%/seditCompose.tcl
+lib/exmh-%%EXMH_VERSION%%/seditEnriched.tcl
+lib/exmh-%%EXMH_VERSION%%/seditExtras.tcl
+lib/exmh-%%EXMH_VERSION%%/seditMime.tcl
+lib/exmh-%%EXMH_VERSION%%/seditQP.tcl
+lib/exmh-%%EXMH_VERSION%%/seditSel.tcl
+lib/exmh-%%EXMH_VERSION%%/select.tcl
+lib/exmh-%%EXMH_VERSION%%/send.tcl
+lib/exmh-%%EXMH_VERSION%%/sequences.tcl
+lib/exmh-%%EXMH_VERSION%%/seqwin.tcl
+lib/exmh-%%EXMH_VERSION%%/sound.tcl
+lib/exmh-%%EXMH_VERSION%%/source.tcl
+lib/exmh-%%EXMH_VERSION%%/stacktrace.tcl
+lib/exmh-%%EXMH_VERSION%%/tclIndex
+lib/exmh-%%EXMH_VERSION%%/text.tcl
+lib/exmh-%%EXMH_VERSION%%/textButton.tcl
+lib/exmh-%%EXMH_VERSION%%/textSelect.tcl
+lib/exmh-%%EXMH_VERSION%%/thread.tcl
+lib/exmh-%%EXMH_VERSION%%/timer.bitmap
+lib/exmh-%%EXMH_VERSION%%/tioga.tcl
+lib/exmh-%%EXMH_VERSION%%/uri.tcl
+lib/exmh-%%EXMH_VERSION%%/url.bitmap
+lib/exmh-%%EXMH_VERSION%%/urlFace.tcl
+lib/exmh-%%EXMH_VERSION%%/user.tcl
+lib/exmh-%%EXMH_VERSION%%/utils.tcl
+lib/exmh-%%EXMH_VERSION%%/widgetMenu.tcl
+lib/exmh-%%EXMH_VERSION%%/widgetText.tcl
+lib/exmh-%%EXMH_VERSION%%/widgets.tcl
+lib/exmh-%%EXMH_VERSION%%/xns.tcl
+lib/exmh-%%EXMH_VERSION%%/xnsgetmail.exp
+man/man1/exmh.1.gz
diff --git a/mail/exmh-devel/scripts/build b/mail/exmh-devel/scripts/build
new file mode 100644
index 000000000000..1a6bfdd9cc56
--- /dev/null
+++ b/mail/exmh-devel/scripts/build
@@ -0,0 +1,85 @@
+#! /bin/sh
+
+VERSION="`sed -ne 's/^set vers \(.*\)/\1/p' ${WRKSRC}/exmh.install`"
+DATE="`sed -ne 's/^set date \(.*\)/\1/p' ${WRKSRC}/exmh.install`"
+
+SEDFILE=sed.$$
+if [ x${USE_NMH} = xYES ] ; then
+ CONFIGFILE=config.nmh
+else
+ CONFIGFILE=config.mh
+fi
+
+EXPECT="{}"
+EXPECTK="{}"
+FACES="{}"
+DOMAIN="{}"
+GPG="{}"
+PGP="{}"
+PGP5="{}"
+PGP6="{}"
+GLIMPSE="{}"
+PLAY="{}"
+
+if [ -f ${PREFIX}/bin/expect ]; then
+ EXPECT=${PREFIX}/bin/expect #executable
+fi
+if [ -f ${PREFIX}/bin/expectk ]; then
+ EXPECTK=${PREFIX}/bin/expectk #executable
+fi
+
+if [ -d ${PREFIX}/share/faces ]; then
+ FACES=${PREFIX}/share/faces #dir
+ shortname="`hostname -s`"
+ domain="`hostname | sed -e s/^${shortname}// -e s/^.// | tr A-Z a-z`"
+ if [ "${domain}" != "" ]; then
+ DOMAIN="{${domain}}"
+ fi
+fi
+
+GPG=${PREFIX}/bin #bindir
+PGP=${PREFIX}/bin #bindir
+PGP5=${PREFIX}/bin #bindir
+PGP6=${PREFIX}/bin #bindir
+
+if [ -f ${PREFIX}/bin/glimpse ]; then
+ GLIMPSE=${PREFIX}/bin #bindir
+fi
+
+if [ -f ${PREFIX}/bin/rplay ]; then
+ PLAY=${PREFIX}/bin/rplay #executable
+fi
+
+echo "s@^#!wish@#!${WISH}@" >${SEDFILE}
+if [ "${EXPECT}" != "{}" ]; then
+ echo "s@^#!expect@#!${EXPECT}@" >>${SEDFILE}
+fi
+echo "/^#CONFIGURATION/a\\" >>${SEDFILE}
+
+sed <${FILESDIR}/${CONFIGFILE} \
+ -e "s+!!PREFIX!!+${PREFIX}+g" \
+ -e "s+!!WISH!!+${WISH}+g" \
+ -e "s+!!EXPECT!!+${EXPECT}+g" \
+ -e "s+!!EXPECTK!!+${EXPECTK}+g" \
+ -e "s+!!FACES!!+${FACES}+g" \
+ -e "s+!!DOMAIN!!+${DOMAIN}+g" \
+ -e "s+!!GPG!!+${GPG}+g" \
+ -e "s+!!PGP!!+${PGP}+g" \
+ -e "s+!!PGP5!!+${PGP5}+g" \
+ -e "s+!!PGP6!!+${PGP6}+g" \
+ -e "s+!!GLIMPSE!!+${GLIMPSE}+g" \
+ -e "s+!!PLAY!!+${PLAY}+g" \
+ -e "s+!!VERSION!!+${VERSION}+g" \
+ -e "s+!!DATE!!+${DATE}+g" \
+ | sed -e 's/$/\\/' -e '$ s/.$//' >> ${SEDFILE}
+
+for i in exmh-async exmh-bg exmh-strip exmh ftp.expect inc.expect
+do
+ echo "sed -f ${SEDFILE} < $i.MASTER > $i"
+ sed -f ${SEDFILE} < $i.MASTER > $i
+done
+
+rm -f ${SEDFILE}
+
+echo "cd lib ; echo 'auto_mkindex . *.tcl ; exit' | ${TCLSH}"
+cd lib ; echo 'auto_mkindex . *.tcl ; exit' | ${TCLSH}
diff --git a/mail/exmh-devel/scripts/install b/mail/exmh-devel/scripts/install
new file mode 100644
index 000000000000..2cce7079f859
--- /dev/null
+++ b/mail/exmh-devel/scripts/install
@@ -0,0 +1,46 @@
+#! /bin/sh
+
+VERSION="`sed -ne 's/^set vers \(.*\)/\1/p' ${WRKSRC}/exmh.install`"
+
+# Rename while installing..
+for i in exmh
+do
+ echo "install -c $i.l ${PREFIX}/man/man1/$i.1"
+ install -c $i.l ${PREFIX}/man/man1/$i.1
+done
+
+BINS="exmh-async exmh-bg exmh-strip exmh ftp.expect inc.expect"
+
+echo "install -c ${BINS} ${PREFIX}/bin"
+install -c ${BINS} ${PREFIX}/bin
+
+if [ ! -d ${PREFIX}/lib/exmh-${VERSION} ]
+then
+ echo "mkdir ${PREFIX}/lib/exmh-${VERSION}"
+ mkdir ${PREFIX}/lib/exmh-${VERSION}
+fi
+
+LIBFILES='lib/*.tcl lib/*.bitmap lib/*.gif lib/*.ppm lib/help.* lib/tclIndex lib/app-defaults lib/app-defaults-* lib/*.mask lib/*.exp lib/mime.types lib/*.au lib/PgpDecryptExpect'
+
+echo "install -c ${LIBFILES} ${PREFIX}/lib/exmh-${VERSION}"
+install -c ${LIBFILES} ${PREFIX}/lib/exmh-${VERSION}
+
+if [ ! -d ${PREFIX}/lib/exmh-${VERSION}/html ]
+then
+ echo "mkdir ${PREFIX}/lib/exmh-${VERSION}/html"
+ mkdir ${PREFIX}/lib/exmh-${VERSION}/html
+fi
+
+echo "install -c lib/html/* lib/html/*.gif ${PREFIX}/lib/exmh-${VERSION}/html"
+install -c lib/html/*.html lib/html/*.gif ${PREFIX}/lib/exmh-${VERSION}/html
+
+if [ ! -d ${PREFIX}/lib/exmh-${VERSION}/bitmaps ]
+then
+ echo "mkdir ${PREFIX}/lib/exmh-${VERSION}/bitmaps"
+ mkdir ${PREFIX}/lib/exmh-${VERSION}/bitmaps
+fi
+
+echo "install -c lib/bitmaps/bitmaps.defaults lib/bitmaps/*.xbm ${PREFIX}/lib/exmh-${VERSION}/bitmaps"
+install -c lib/bitmaps/bitmaps.defaults lib/bitmaps/*.xbm ${PREFIX}/lib/exmh-${VERSION}/bitmaps
+
+