aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-08-26 23:16:44 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-08-26 23:19:04 +0000
commit34f7297957d105d8ba5ab0b036957bcaab478069 (patch)
tree742a61521bfd4ea58e52d0a1215cbbcef432c450
parent5e70841f87b2d316acc170b0f550e4eab205b6e2 (diff)
downloadports-34f7297957d105d8ba5ab0b036957bcaab478069.tar.gz
ports-34f7297957d105d8ba5ab0b036957bcaab478069.zip
devel/py-regress: Add py-regress 0.4.0
regress is a backtracking regular expression engine implemented in Rust, which targets JavaScript regular expression syntax. It's fast, Unicode-aware, has few dependencies, and has a big test suite. It makes fewer guarantees than the regex crate but it enables more syntactic features, such as backreferences and lookaround assertions.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-regress/Makefile26
-rw-r--r--devel/py-regress/Makefile.crates37
-rw-r--r--devel/py-regress/distinfo77
-rw-r--r--devel/py-regress/pkg-descr6
5 files changed, 147 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ef5551396b18..e99f339e16e3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5479,6 +5479,7 @@
SUBDIR += py-rednose
SUBDIR += py-reedsolo
SUBDIR += py-referencing
+ SUBDIR += py-regress
SUBDIR += py-remote-pdb
SUBDIR += py-repoze.lru
SUBDIR += py-repoze.sphinx.autointerface
diff --git a/devel/py-regress/Makefile b/devel/py-regress/Makefile
new file mode 100644
index 000000000000..3d1ed318ce75
--- /dev/null
+++ b/devel/py-regress/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= regress
+PORTVERSION= 0.4.0
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python bindings to Rust's regress ECMA regular expressions library
+WWW= https://github.com/ridiculousfish/regress
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}maturin>=1.0<2.0:devel/py-maturin@${PY_FLAVOR}
+
+USES= cargo python
+USE_PYTHON= autoplist concurrent pep517
+
+CARGO_BUILD= no
+CARGO_INSTALL= no
+
+post-install:
+ ${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
+
+.include <bsd.port.mk>
diff --git a/devel/py-regress/Makefile.crates b/devel/py-regress/Makefile.crates
new file mode 100644
index 000000000000..0d7c113676b0
--- /dev/null
+++ b/devel/py-regress/Makefile.crates
@@ -0,0 +1,37 @@
+CARGO_CRATES= ahash-0.8.3 \
+ autocfg-1.1.0 \
+ bitflags-1.3.2 \
+ cfg-if-1.0.0 \
+ hashbrown-0.13.2 \
+ indoc-1.0.9 \
+ libc-0.2.147 \
+ lock_api-0.4.10 \
+ memchr-2.5.0 \
+ memoffset-0.9.0 \
+ once_cell-1.18.0 \
+ parking_lot-0.12.1 \
+ parking_lot_core-0.9.8 \
+ proc-macro2-1.0.66 \
+ pyo3-0.19.2 \
+ pyo3-build-config-0.19.2 \
+ pyo3-ffi-0.19.2 \
+ pyo3-macros-0.19.2 \
+ pyo3-macros-backend-0.19.2 \
+ quote-1.0.33 \
+ redox_syscall-0.3.5 \
+ regress-0.7.1 \
+ scopeguard-1.2.0 \
+ smallvec-1.11.0 \
+ syn-1.0.109 \
+ target-lexicon-0.12.11 \
+ unicode-ident-1.0.11 \
+ unindent-0.1.11 \
+ version_check-0.9.4 \
+ windows-targets-0.48.5 \
+ windows_aarch64_gnullvm-0.48.5 \
+ windows_aarch64_msvc-0.48.5 \
+ windows_i686_gnu-0.48.5 \
+ windows_i686_msvc-0.48.5 \
+ windows_x86_64_gnu-0.48.5 \
+ windows_x86_64_gnullvm-0.48.5 \
+ windows_x86_64_msvc-0.48.5
diff --git a/devel/py-regress/distinfo b/devel/py-regress/distinfo
new file mode 100644
index 000000000000..784606af4072
--- /dev/null
+++ b/devel/py-regress/distinfo
@@ -0,0 +1,77 @@
+TIMESTAMP = 1693091280
+SHA256 (regress-0.4.0.tar.gz) = 5ebb0c5a092b524e7a49f899be06f6ce0291eecf23366ac87cb743e52a824dd8
+SIZE (regress-0.4.0.tar.gz) = 9097
+SHA256 (rust/crates/ahash-0.8.3.crate) = 2c99f64d1e06488f620f932677e24bc6e2897582980441ae90a671415bd7ec2f
+SIZE (rust/crates/ahash-0.8.3.crate) = 42416
+SHA256 (rust/crates/autocfg-1.1.0.crate) = d468802bab17cbc0cc575e9b053f41e72aa36bfa6b7f55e3529ffa43161b97fa
+SIZE (rust/crates/autocfg-1.1.0.crate) = 13272
+SHA256 (rust/crates/bitflags-1.3.2.crate) = bef38d45163c2f1dde094a7dfd33ccf595c92905c8f8f4fdc18d06fb1037718a
+SIZE (rust/crates/bitflags-1.3.2.crate) = 23021
+SHA256 (rust/crates/cfg-if-1.0.0.crate) = baf1de4339761588bc0619e3cbc0120ee582ebb74b53b4efbf79117bd2da40fd
+SIZE (rust/crates/cfg-if-1.0.0.crate) = 7934
+SHA256 (rust/crates/hashbrown-0.13.2.crate) = 43a3c133739dddd0d2990f9a4bdf8eb4b21ef50e4851ca85ab661199821d510e
+SIZE (rust/crates/hashbrown-0.13.2.crate) = 105265
+SHA256 (rust/crates/indoc-1.0.9.crate) = bfa799dd5ed20a7e349f3b4639aa80d74549c81716d9ec4f994c9b5815598306
+SIZE (rust/crates/indoc-1.0.9.crate) = 13475
+SHA256 (rust/crates/libc-0.2.147.crate) = b4668fb0ea861c1df094127ac5f1da3409a82116a4ba74fca2e58ef927159bb3
+SIZE (rust/crates/libc-0.2.147.crate) = 686772
+SHA256 (rust/crates/lock_api-0.4.10.crate) = c1cc9717a20b1bb222f333e6a92fd32f7d8a18ddc5a3191a11af45dcbf4dcd16
+SIZE (rust/crates/lock_api-0.4.10.crate) = 26713
+SHA256 (rust/crates/memchr-2.5.0.crate) = 2dffe52ecf27772e601905b7522cb4ef790d2cc203488bbd0e2fe85fcb74566d
+SIZE (rust/crates/memchr-2.5.0.crate) = 65812
+SHA256 (rust/crates/memoffset-0.9.0.crate) = 5a634b1c61a95585bd15607c6ab0c4e5b226e695ff2800ba0cdccddf208c406c
+SIZE (rust/crates/memoffset-0.9.0.crate) = 9033
+SHA256 (rust/crates/once_cell-1.18.0.crate) = dd8b5dd2ae5ed71462c540258bedcb51965123ad7e7ccf4b9a8cafaa4a63576d
+SIZE (rust/crates/once_cell-1.18.0.crate) = 32969
+SHA256 (rust/crates/parking_lot-0.12.1.crate) = 3742b2c103b9f06bc9fff0a37ff4912935851bee6d36f3c02bcc755bcfec228f
+SIZE (rust/crates/parking_lot-0.12.1.crate) = 40967
+SHA256 (rust/crates/parking_lot_core-0.9.8.crate) = 93f00c865fe7cabf650081affecd3871070f26767e7b2070a3ffae14c654b447
+SIZE (rust/crates/parking_lot_core-0.9.8.crate) = 32383
+SHA256 (rust/crates/proc-macro2-1.0.66.crate) = 18fb31db3f9bddb2ea821cde30a9f70117e3f119938b5ee630b7403aa6e2ead9
+SIZE (rust/crates/proc-macro2-1.0.66.crate) = 43575
+SHA256 (rust/crates/pyo3-0.19.2.crate) = e681a6cfdc4adcc93b4d3cf993749a4552018ee0a9b65fc0ccfad74352c72a38
+SIZE (rust/crates/pyo3-0.19.2.crate) = 418228
+SHA256 (rust/crates/pyo3-build-config-0.19.2.crate) = 076c73d0bc438f7a4ef6fdd0c3bb4732149136abd952b110ac93e4edb13a6ba5
+SIZE (rust/crates/pyo3-build-config-0.19.2.crate) = 29206
+SHA256 (rust/crates/pyo3-ffi-0.19.2.crate) = e53cee42e77ebe256066ba8aa77eff722b3bb91f3419177cf4cd0f304d3284d9
+SIZE (rust/crates/pyo3-ffi-0.19.2.crate) = 66500
+SHA256 (rust/crates/pyo3-macros-0.19.2.crate) = dfeb4c99597e136528c6dd7d5e3de5434d1ceaf487436a3f03b2d56b6fc9efd1
+SIZE (rust/crates/pyo3-macros-0.19.2.crate) = 7173
+SHA256 (rust/crates/pyo3-macros-backend-0.19.2.crate) = 947dc12175c254889edc0c02e399476c2f652b4b9ebd123aa655c224de259536
+SIZE (rust/crates/pyo3-macros-backend-0.19.2.crate) = 49962
+SHA256 (rust/crates/quote-1.0.33.crate) = 5267fca4496028628a95160fc423a33e8b2e6af8a5302579e322e4b520293cae
+SIZE (rust/crates/quote-1.0.33.crate) = 28090
+SHA256 (rust/crates/redox_syscall-0.3.5.crate) = 567664f262709473930a4bf9e51bf2ebf3348f2e748ccc50dea20646858f8f29
+SIZE (rust/crates/redox_syscall-0.3.5.crate) = 23404
+SHA256 (rust/crates/regress-0.7.1.crate) = 4ed9969cad8051328011596bf549629f1b800cf1731e7964b1eef8dfc480d2c2
+SIZE (rust/crates/regress-0.7.1.crate) = 248686
+SHA256 (rust/crates/scopeguard-1.2.0.crate) = 94143f37725109f92c262ed2cf5e59bce7498c01bcc1502d7b9afe439a4e9f49
+SIZE (rust/crates/scopeguard-1.2.0.crate) = 11619
+SHA256 (rust/crates/smallvec-1.11.0.crate) = 62bb4feee49fdd9f707ef802e22365a35de4b7b299de4763d44bfea899442ff9
+SIZE (rust/crates/smallvec-1.11.0.crate) = 34680
+SHA256 (rust/crates/syn-1.0.109.crate) = 72b64191b275b66ffe2469e8af2c1cfe3bafa67b529ead792a6d0160888b4237
+SIZE (rust/crates/syn-1.0.109.crate) = 237611
+SHA256 (rust/crates/target-lexicon-0.12.11.crate) = 9d0e916b1148c8e263850e1ebcbd046f333e0683c724876bb0da63ea4373dc8a
+SIZE (rust/crates/target-lexicon-0.12.11.crate) = 24594
+SHA256 (rust/crates/unicode-ident-1.0.11.crate) = 301abaae475aa91687eb82514b328ab47a211a533026cb25fc3e519b86adfc3c
+SIZE (rust/crates/unicode-ident-1.0.11.crate) = 42067
+SHA256 (rust/crates/unindent-0.1.11.crate) = e1766d682d402817b5ac4490b3c3002d91dfa0d22812f341609f97b08757359c
+SIZE (rust/crates/unindent-0.1.11.crate) = 7700
+SHA256 (rust/crates/version_check-0.9.4.crate) = 49874b5167b65d7193b8aba1567f5c7d93d001cafc34600cee003eda787e483f
+SIZE (rust/crates/version_check-0.9.4.crate) = 14895
+SHA256 (rust/crates/windows-targets-0.48.5.crate) = 9a2fa6e2155d7247be68c096456083145c183cbbbc2764150dda45a87197940c
+SIZE (rust/crates/windows-targets-0.48.5.crate) = 6904
+SHA256 (rust/crates/windows_aarch64_gnullvm-0.48.5.crate) = 2b38e32f0abccf9987a4e3079dfb67dcd799fb61361e53e2882c3cbaf0d905d8
+SIZE (rust/crates/windows_aarch64_gnullvm-0.48.5.crate) = 418492
+SHA256 (rust/crates/windows_aarch64_msvc-0.48.5.crate) = dc35310971f3b2dbbf3f0690a219f40e2d9afcf64f9ab7cc1be722937c26b4bc
+SIZE (rust/crates/windows_aarch64_msvc-0.48.5.crate) = 798483
+SHA256 (rust/crates/windows_i686_gnu-0.48.5.crate) = a75915e7def60c94dcef72200b9a8e58e5091744960da64ec734a6c6e9b3743e
+SIZE (rust/crates/windows_i686_gnu-0.48.5.crate) = 844891
+SHA256 (rust/crates/windows_i686_msvc-0.48.5.crate) = 8f55c233f70c4b27f66c523580f78f1004e8b5a8b659e05a4eb49d4166cca406
+SIZE (rust/crates/windows_i686_msvc-0.48.5.crate) = 864300
+SHA256 (rust/crates/windows_x86_64_gnu-0.48.5.crate) = 53d40abd2583d23e4718fddf1ebec84dbff8381c07cae67ff7768bbf19c6718e
+SIZE (rust/crates/windows_x86_64_gnu-0.48.5.crate) = 801619
+SHA256 (rust/crates/windows_x86_64_gnullvm-0.48.5.crate) = 0b7b52767868a23d5bab768e390dc5f5c55825b6d30b86c844ff2dc7414044cc
+SIZE (rust/crates/windows_x86_64_gnullvm-0.48.5.crate) = 418486
+SHA256 (rust/crates/windows_x86_64_msvc-0.48.5.crate) = ed94fce61571a4006852b7389a063ab983c02eb1bb37b47f8272ce92d06d9538
+SIZE (rust/crates/windows_x86_64_msvc-0.48.5.crate) = 798412
diff --git a/devel/py-regress/pkg-descr b/devel/py-regress/pkg-descr
new file mode 100644
index 000000000000..0cd754901f3f
--- /dev/null
+++ b/devel/py-regress/pkg-descr
@@ -0,0 +1,6 @@
+regress is a backtracking regular expression engine implemented in Rust, which
+targets JavaScript regular expression syntax.
+
+It's fast, Unicode-aware, has few dependencies, and has a big test suite. It
+makes fewer guarantees than the regex crate but it enables more syntactic
+features, such as backreferences and lookaround assertions.