aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-27 15:45:33 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-27 15:45:33 +0000
commit35cb4f7cea6ea13d70b5266f216143f65446b762 (patch)
tree65b01302637474ae835d7e9b9e78ef555c203ba9
parent5682397c0b7d7790abd816a9547cb5d8f80837c5 (diff)
downloadports-35cb4f7cea6ea13d70b5266f216143f65446b762.tar.gz
ports-35cb4f7cea6ea13d70b5266f216143f65446b762.zip
devel/astyle: Update to 3.2.1
-rw-r--r--devel/astyle/Makefile23
-rw-r--r--devel/astyle/distinfo6
-rw-r--r--devel/astyle/files/patch-build_clang_Makefile11
-rw-r--r--devel/astyle/files/patch-build_gcc_Makefile11
-rw-r--r--devel/astyle/files/patch-src_astyle__main.cpp13
-rw-r--r--devel/astyle/pkg-plist16
6 files changed, 29 insertions, 51 deletions
diff --git a/devel/astyle/Makefile b/devel/astyle/Makefile
index 8e7a00661605..a351ebddc51d 100644
--- a/devel/astyle/Makefile
+++ b/devel/astyle/Makefile
@@ -1,38 +1,35 @@
PORTNAME= astyle
-PORTVERSION= 3.1
-PORTREVISION= 3
+PORTVERSION= 3.2.1
CATEGORIES= devel textproc
-MASTER_SITES= SF/astyle/astyle/astyle%20${PORTVERSION}
-DISTNAME= ${PORTNAME}_${PORTVERSION}_linux
+MASTER_SITES= SF/astyle/astyle/astyle%20${PORTVERSION:R}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Source code indenter and formatter for C, C++, C\#, and Java
-WWW= http://astyle.sourceforge.net/
+WWW= https://astyle.sourceforge.net/ \
+ https://gitlab.com/saalen/astyle
LICENSE= MIT
-LICENSE_FILE= ${WRKDIR}/astyle/LICENSE.md
+LICENSE_FILE= ${WRKSRC}/../../LICENSE.md
-USES= compiler:c++11-lang dos2unix gmake
+USES= compiler:c++11-lang dos2unix gmake tar:bz2
ALL_TARGET= astyle
-WRKSRC= ${WRKDIR}/astyle/build/${CHOSEN_COMPILER_TYPE}
+MAKE_ENV= CXX="${CXX}"
+WRKSRC_SUBDIR= build/${CHOSEN_COMPILER_TYPE}
DOS2UNIX_GLOB= *.ini
OPTIONS_DEFINE= DOCS EXAMPLES
-post-patch:
- @${REINPLACE_CMD} -e 's|%%CXX%%|${CXX}|' ${WRKSRC}/${MAKEFILE}
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/astyle ${STAGEDIR}${PREFIX}/bin
do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKDIR}/astyle/doc/* ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/../../doc/* ${STAGEDIR}${DOCSDIR}
do-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKDIR}/astyle/file/* ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/../../file/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/devel/astyle/distinfo b/devel/astyle/distinfo
index f670b0f60e2f..283b91a23f2b 100644
--- a/devel/astyle/distinfo
+++ b/devel/astyle/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1516007468
-SHA256 (astyle_3.1_linux.tar.gz) = cbcc4cf996294534bb56f025d6f199ebfde81aa4c271ccbd5ee1c1a3192745d7
-SIZE (astyle_3.1_linux.tar.gz) = 185589
+TIMESTAMP = 1682354468
+SHA256 (astyle-3.2.1.tar.bz2) = 191576fbd1f4abe55a25769c176da78294ec590f96f27037a4746bda0f84fe60
+SIZE (astyle-3.2.1.tar.bz2) = 224540
diff --git a/devel/astyle/files/patch-build_clang_Makefile b/devel/astyle/files/patch-build_clang_Makefile
deleted file mode 100644
index 560ab96f0652..000000000000
--- a/devel/astyle/files/patch-build_clang_Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- ../../build/clang/Makefile.orig 2018-01-11 17:18:18 UTC
-+++ ../../build/clang/Makefile
-@@ -37,7 +37,7 @@ objdir = obj
- ipath=$(prefix)/bin
- CBASEFLAGS = -Wall -Wextra -fno-rtti -fno-exceptions -std=c++11
- JAVAINCS = -I$(JAVA_HOME)/include -I$(JAVA_HOME)/include/linux
--CXX = clang++
-+CXX = %%CXX%%
- INSTALL=install -o $(USER) -g $(USER)
-
- # Library's major version number -- Increment in case of incompatible API
diff --git a/devel/astyle/files/patch-build_gcc_Makefile b/devel/astyle/files/patch-build_gcc_Makefile
deleted file mode 100644
index 038d6e645f08..000000000000
--- a/devel/astyle/files/patch-build_gcc_Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- ../../build/gcc/Makefile.orig 2018-01-11 17:18:18 UTC
-+++ ../../build/gcc/Makefile
-@@ -37,7 +37,7 @@ objdir = obj
- ipath=$(prefix)/bin
- CBASEFLAGS = -Wall -Wextra -fno-rtti -fno-exceptions -std=c++11
- JAVAINCS = -I$(JAVA_HOME)/include -I$(JAVA_HOME)/include/linux
--CXX = g++
-+CXX = %%CXX%%
- INSTALL=install -o $(USER) -g $(USER)
-
- # Library's major version number -- Increment in case of incompatible API
diff --git a/devel/astyle/files/patch-src_astyle__main.cpp b/devel/astyle/files/patch-src_astyle__main.cpp
deleted file mode 100644
index 3ad3c79f366b..000000000000
--- a/devel/astyle/files/patch-src_astyle__main.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- ../../src/astyle_main.cpp.orig 2018-11-28 00:32:16.924868000 +0100
-+++ ../../src/astyle_main.cpp 2018-11-28 00:33:36.071105000 +0100
-@@ -46,6 +46,10 @@
- #ifdef _WIN32
- #undef UNICODE // use ASCII windows functions
- #include <windows.h>
-+#elif defined(__FreeBSD__)
-+ #include <dirent.h>
-+ #include <sys/syslimits.h>
-+ #include <unistd.h>
- #else
- #include <dirent.h>
- #include <unistd.h>
diff --git a/devel/astyle/pkg-plist b/devel/astyle/pkg-plist
index afda622667eb..ad4638c73fcc 100644
--- a/devel/astyle/pkg-plist
+++ b/devel/astyle/pkg-plist
@@ -1,12 +1,28 @@
bin/astyle
%%PORTDOCS%%%%DOCSDIR%%/astyle.html
+%%PORTDOCS%%%%DOCSDIR%%/development.html
+%%PORTDOCS%%%%DOCSDIR%%/favicon.ico
+%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/install.html
+%%PORTDOCS%%%%DOCSDIR%%/links.html
%%PORTDOCS%%%%DOCSDIR%%/news.html
+%%PORTDOCS%%%%DOCSDIR%%/newsArchives.html
%%PORTDOCS%%%%DOCSDIR%%/notes.html
+%%PORTDOCS%%%%DOCSDIR%%/notesArchives.html
+%%PORTDOCS%%%%DOCSDIR%%/scripts.html
%%PORTDOCS%%%%DOCSDIR%%/styles.css
+%%PORTDOCS%%%%DOCSDIR%%/subversion.html
+%%PORTDOCS%%%%DOCSDIR%%/vsinstall.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/allman.ini
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/astyle.ini
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chromium.ini
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/clang-chromium.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/clang-google.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/clang-llvm.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/clang-mozilla.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/clang-visualstudio.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/clang-webkit.yaml
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gnu.ini
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/google.ini
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/horstmann.ini