aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-02-04 06:32:57 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-02-04 06:58:52 +0000
commit3604fc3235289e9c35c6b94289d3db523f357aab (patch)
tree0245f6637ef49a8dd11ef8861ca1a07629416b5a
parent4a39c486b8338ecbfd0de60109cc27a9206c9ca2 (diff)
downloadports-3604fc3235289e9c35c6b94289d3db523f357aab.tar.gz
ports-3604fc3235289e9c35c6b94289d3db523f357aab.zip
devel/py-find-libpython: New port: Finds the libpython associated with your environment
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-find-libpython/Makefile25
-rw-r--r--devel/py-find-libpython/distinfo3
-rw-r--r--devel/py-find-libpython/pkg-descr4
4 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 17d4d490dac4..a6797c883b2d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4565,6 +4565,7 @@
SUBDIR += py-filedepot
SUBDIR += py-filemagic
SUBDIR += py-filetype
+ SUBDIR += py-find-libpython
SUBDIR += py-findlibs
SUBDIR += py-findpython
SUBDIR += py-first
diff --git a/devel/py-find-libpython/Makefile b/devel/py-find-libpython/Makefile
new file mode 100644
index 000000000000..7bcb691dcbee
--- /dev/null
+++ b/devel/py-find-libpython/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= find-libpython
+PORTVERSION= 0.3.0
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME:S/-/_/}-${DISTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Finds the libpython associated with your environment
+WWW= https://github.com/ktbarrett/find_libpython
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= pep517 autoplist pytest
+
+NO_ARCH= yes
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
+.include <bsd.port.mk>
diff --git a/devel/py-find-libpython/distinfo b/devel/py-find-libpython/distinfo
new file mode 100644
index 000000000000..3b1881a6ab1f
--- /dev/null
+++ b/devel/py-find-libpython/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1675492021
+SHA256 (find_libpython-0.3.0.tar.gz) = 6e7fe5d9af7fad6dc066cb5515a0e9c90a71f1feb2bb2f8e4cdbb4f83276e9e5
+SIZE (find_libpython-0.3.0.tar.gz) = 10754
diff --git a/devel/py-find-libpython/pkg-descr b/devel/py-find-libpython/pkg-descr
new file mode 100644
index 000000000000..eb6cabd99069
--- /dev/null
+++ b/devel/py-find-libpython/pkg-descr
@@ -0,0 +1,4 @@
+The find-libpython library is designed to find the path to the libpython dynamic
+library for the current Python environment. It should work with many types of
+installations, whether it be conda-managed, system-managed, or otherwise. And it
+should function on Windows, Mac OS/OS X, and any Linux distribution.