aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-03-27 15:02:03 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-03-27 21:27:39 +0000
commit36282a180ba110d49d04fac997d4e11bd23726fc (patch)
tree928cbdf592875d76dcf1e1103987f03979f7ff18
parent07bf80320fa30852bc43407335e959b950661e44 (diff)
downloadports-36282a180ba110d49d04fac997d4e11bd23726fc.tar.gz
ports-36282a180ba110d49d04fac997d4e11bd23726fc.zip
devel/py-treelib: New port: Python 2/3 implementation of tree structure
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-treelib/Makefile24
-rw-r--r--devel/py-treelib/distinfo3
-rw-r--r--devel/py-treelib/pkg-descr6
4 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 06e6dae40b7f..73442b7f68fb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5535,6 +5535,7 @@
SUBDIR += py-transaction
SUBDIR += py-transitions
SUBDIR += py-tree-format
+ SUBDIR += py-treelib
SUBDIR += py-trimesh
SUBDIR += py-trove-classifiers
SUBDIR += py-ttictoc
diff --git a/devel/py-treelib/Makefile b/devel/py-treelib/Makefile
new file mode 100644
index 000000000000..61f0c7f8ce43
--- /dev/null
+++ b/devel/py-treelib/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= treelib
+DISTVERSION= 1.6.3
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python 2/3 implementation of tree structure
+WWW= https://treelib.readthedocs.io/en/latest/
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.13.0:devel/py-six@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}black>0:devel/py-black@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}coverage>=4.4.1:devel/py-coverage@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}flake8>=5.0.0:devel/py-flake8@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}flake8-black>=0.3.6:devel/py-flake8-black@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist pytest
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-treelib/distinfo b/devel/py-treelib/distinfo
new file mode 100644
index 000000000000..9c804f6655b0
--- /dev/null
+++ b/devel/py-treelib/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1679950372
+SHA256 (treelib-1.6.3.tar.gz) = a0db5fd55d6cb4f307aecef4de184920a75db95e45f80e5860adf38718a2970a
+SIZE (treelib-1.6.3.tar.gz) = 25285
diff --git a/devel/py-treelib/pkg-descr b/devel/py-treelib/pkg-descr
new file mode 100644
index 000000000000..3d40d2d9504d
--- /dev/null
+++ b/devel/py-treelib/pkg-descr
@@ -0,0 +1,6 @@
+Treelib implements the tree structure in Python.
+
+Tree is an important data structure in computer science. Examples are shown in
+ML algorithm designs such as random forest tree and software engineering such
+as file system index. treelib is created to provide an efficient implementation
+of tree data structure in Python.