aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-10-23 01:53:25 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-10-23 01:53:25 +0000
commit362ade45f8500addacff204e1e10b9eea2d24e6a (patch)
tree74adab348d2d3e67ccd177ac85a245380c79f6eb
parentd3566f3e6f5d3f23f1339c1434662520b3dc97ef (diff)
downloadports-362ade45f8500addacff204e1e10b9eea2d24e6a.tar.gz
ports-362ade45f8500addacff204e1e10b9eea2d24e6a.zip
net-p2p/monero-cli: fix build on i386
This crypto code is for amd64 only. Don't attempt to build it on i386. Approved by: portmgr (build fix blanket)
-rw-r--r--net-p2p/monero-cli/Makefile1
-rw-r--r--net-p2p/monero-cli/files/patch-src_crypto_CMakeLists.txt11
2 files changed, 11 insertions, 1 deletions
diff --git a/net-p2p/monero-cli/Makefile b/net-p2p/monero-cli/Makefile
index 7f44f7489793..c8737e923599 100644
--- a/net-p2p/monero-cli/Makefile
+++ b/net-p2p/monero-cli/Makefile
@@ -11,7 +11,6 @@ WWW= https://getmonero.org/
LICENSE= BSD3CLAUSE
BROKEN_SSL= libressl
-BROKEN_i386= fails to compile: register r15d is only available in 64-bit mode
BROKEN_aarch64= fails to compile: uses unavailable HWCAP_AES and getauxval
LIB_DEPENDS= \
diff --git a/net-p2p/monero-cli/files/patch-src_crypto_CMakeLists.txt b/net-p2p/monero-cli/files/patch-src_crypto_CMakeLists.txt
new file mode 100644
index 000000000000..20d27ee524e0
--- /dev/null
+++ b/net-p2p/monero-cli/files/patch-src_crypto_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- src/crypto/CMakeLists.txt.orig 2023-10-23 03:21:28 UTC
++++ src/crypto/CMakeLists.txt
+@@ -50,7 +50,7 @@ set(crypto_sources
+ CryptonightR_JIT.c
+ tree-hash.c)
+
+-if(ARCH_ID STREQUAL "i386" OR ARCH_ID STREQUAL "x86_64" OR ARCH_ID STREQUAL "x86-64" OR ARCH_ID STREQUAL "amd64")
++if(ARCH_ID STREQUAL "x86_64" OR ARCH_ID STREQUAL "x86-64" OR ARCH_ID STREQUAL "amd64")
+ list(APPEND crypto_sources CryptonightR_template.S)
+ endif()
+