aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-05 15:36:41 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-05 18:09:00 +0000
commit363f2d568101ea145a156679a8b10c3fbbc5fb87 (patch)
tree2b127f8275ffaa03eb0f26c9f00a20f00d0a59d8
parentcf36cf6227e4084b9298ed11160fb7c418fd782b (diff)
downloadports-363f2d568101ea145a156679a8b10c3fbbc5fb87.tar.gz
ports-363f2d568101ea145a156679a8b10c3fbbc5fb87.zip
x11/gromit: Fix build on llvm15
- Add missing DEPENDS - Refresh patches
-rw-r--r--x11/gromit/Makefile14
-rw-r--r--x11/gromit/files/patch-Makefile4
2 files changed, 14 insertions, 4 deletions
diff --git a/x11/gromit/Makefile b/x11/gromit/Makefile
index 63e514833e7e..8fb2f1302595 100644
--- a/x11/gromit/Makefile
+++ b/x11/gromit/Makefile
@@ -11,14 +11,24 @@ WWW= https://www.home.unix-ag.org/simon/gromit/
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libharfbuzz.so:print/harfbuzz
+
USES= gnome pkgconfig xorg
-USE_GNOME= gtk20
+USE_GNOME= cairo gdkpixbuf2 gtk20
USE_XORG= x11
DOCS= AUTHORS ChangeLog README
OPTIONS_DEFINE= DOCS
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=int-conversion
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gromit ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
@@ -28,4 +38,4 @@ do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/gromit/files/patch-Makefile b/x11/gromit/files/patch-Makefile
index e0309e0a8bd6..aa8153a5752e 100644
--- a/x11/gromit/files/patch-Makefile
+++ b/x11/gromit/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig
+--- Makefile.orig 2004-10-13 22:04:27 UTC
+++ Makefile
-@@ -7,4 +7,4 @@
+@@ -7,4 +7,4 @@ propertywatch: propertywatch.c
gcc -o propertywatch propertywatch.c `gtk-config --libs --cflags`
gromit: gromit.c Makefile