aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2024-07-01 21:46:46 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2024-07-01 21:46:46 +0000
commit3653c88dfeb3bbc5e9ad572b65276f5d8807693b (patch)
tree5280b9e343c66727857c0677f1e862879772c350
parent6313182221553556a22cfdff21a60198487e8523 (diff)
irc/ircd-ratbox: Unbreak with modern OpenSSL
- Bump PORTREVISION Approved by: blanket
-rw-r--r--irc/ircd-ratbox/Makefile2
-rw-r--r--irc/ircd-ratbox/files/patch-libratbox_src_openssl.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/irc/ircd-ratbox/Makefile b/irc/ircd-ratbox/Makefile
index 43f2c284fdce..1fa77580afe2 100644
--- a/irc/ircd-ratbox/Makefile
+++ b/irc/ircd-ratbox/Makefile
@@ -1,6 +1,6 @@
PORTNAME= ircd-ratbox
PORTVERSION= 3.0.10
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= irc
MASTER_SITES= http://www.ratbox.org/download/ \
http://www.ratbox.org/download/old/
diff --git a/irc/ircd-ratbox/files/patch-libratbox_src_openssl.c b/irc/ircd-ratbox/files/patch-libratbox_src_openssl.c
new file mode 100644
index 000000000000..69db1316de0a
--- /dev/null
+++ b/irc/ircd-ratbox/files/patch-libratbox_src_openssl.c
@@ -0,0 +1,11 @@
+--- libratbox/src/openssl.c.orig 2024-07-01 21:36:08 UTC
++++ libratbox/src/openssl.c
+@@ -299,7 +299,7 @@ rb_init_ssl(void)
+ /* Disable SSLv2, make the client use our settings */
+ SSL_CTX_set_options(ssl_server_ctx, SSL_OP_NO_SSLv2 | SSL_OP_CIPHER_SERVER_PREFERENCE);
+
+- ssl_client_ctx = SSL_CTX_new(TLSv1_client_method());
++ ssl_client_ctx = SSL_CTX_new(TLS_client_method());
+
+ if(ssl_client_ctx == NULL)
+ {