aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2011-09-01 18:32:45 +0000
committerFlorian Smeets <flo@FreeBSD.org>2011-09-01 18:32:45 +0000
commit366bee7eecbe976cbbaeccb94e3e97f6aa178025 (patch)
tree7710e672666df8e153d2efad8739673240f5209c
parent87e0985ec08274e47bdc0e5e3d4c7836fcfd186b (diff)
downloadports-366bee7eecbe976cbbaeccb94e3e97f6aa178025.tar.gz
ports-366bee7eecbe976cbbaeccb94e3e97f6aa178025.zip
- add $command_args for all calls to $command in rc.d/squid (ports/156737)
- Bump PORTREVISION for this change. PR: ports/160372 Submitted by: Thomas-Martin Seck <tmseck@web.de>
Notes
Notes: svn path=/head/; revision=280999
-rw-r--r--www/squid30/Makefile1
-rw-r--r--www/squid30/files/squid.in6
2 files changed, 4 insertions, 3 deletions
diff --git a/www/squid30/Makefile b/www/squid30/Makefile
index 7c8f1163a3b7..009371d99f1a 100644
--- a/www/squid30/Makefile
+++ b/www/squid30/Makefile
@@ -61,6 +61,7 @@
PORTNAME= squid
PORTVERSION= 3.0.${SQUID_STABLE_VER}
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
http://mirrors.ccs.neu.edu/Squid/ \
diff --git a/www/squid30/files/squid.in b/www/squid30/files/squid.in
index c38878660b8c..fdbae3b7924a 100644
--- a/www/squid30/files/squid.in
+++ b/www/squid30/files/squid.in
@@ -41,7 +41,7 @@
#
squid_checkrunning() {
- ${command} ${squid_flags} -k check 2>/dev/null
+ ${command} ${command_args} ${squid_flags} -k check 2>/dev/null
}
squid_setfib() {
@@ -55,7 +55,7 @@ squid_setfib() {
squid_stop() {
echo "Stopping ${name}."
- ${command} ${squid_flags} -k shutdown
+ ${command} ${command_args} ${squid_flags} -k shutdown
run_rc_command poll
}
@@ -66,7 +66,7 @@ rcvar=${name}_enable
command=%%PREFIX%%/sbin/squid
extra_commands=reload
-reload_cmd="${command} ${squid_flags} -k reconfigure"
+reload_cmd="${command} ${command_args} ${squid_flags} -k reconfigure"
start_precmd="squid_setfib"
stop_precmd="squid_checkrunning"
stop_cmd="squid_stop"