aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-11-01 07:56:03 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-11-01 07:56:03 +0000
commit36a15066d7384f15eebaccb65ece54c575506b68 (patch)
tree0e618f09d51c48838a157dd45481b2f634f58c03
parentee0300e816b2f2f45f1cce29d64da24fd42ac8ad (diff)
downloadports-36a15066d7384f15eebaccb65ece54c575506b68.tar.gz
ports-36a15066d7384f15eebaccb65ece54c575506b68.zip
devel/rubygem-activejob71: Add rubygem-activejob71 7.1.1
Active Job is a framework for declaring jobs and making them run on a variety of queuing backends. These jobs can be everything from regularly scheduled clean-ups, to billing charges, to mailings -- anything that can be chopped up into small units of work and run in parallel. It also serves as the backend for Action Mailer's #deliver_later functionality that makes it easy to turn any mailing into a job for running later. That's one of the most common jobs in a modern web application: sending emails outside the request-response cycle, so the user doesn't have to wait on it. The main point is to ensure that all Rails apps will have a job infrastructure in place, even if it's in the form of an "immediate runner". We can then have framework features and other gems build on top of that, without having to worry about API differences between Delayed Job and Resque. Picking your queuing backend becomes more of an operational concern, then. And you'll be able to switch between them without having to rewrite your jobs.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-activejob71/Makefile27
-rw-r--r--devel/rubygem-activejob71/distinfo3
-rw-r--r--devel/rubygem-activejob71/pkg-descr16
4 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2bda70b7e193..c4f6bd8e61d0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -6062,6 +6062,7 @@
SUBDIR += rubygem-activejob60
SUBDIR += rubygem-activejob61
SUBDIR += rubygem-activejob70
+ SUBDIR += rubygem-activejob71
SUBDIR += rubygem-activemessaging
SUBDIR += rubygem-activerecord-deprecated_finders
SUBDIR += rubygem-activesupport4
diff --git a/devel/rubygem-activejob71/Makefile b/devel/rubygem-activejob71/Makefile
new file mode 100644
index 000000000000..39a456018e79
--- /dev/null
+++ b/devel/rubygem-activejob71/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= activejob
+PORTVERSION= 7.1.1
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 71
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Declare job classes that can be run by a variety of queuing backends
+WWW= https://github.com/rails/rails/tree/main/activejob \
+ https://rubyonrails.org/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+RUN_DEPENDS= rubygem-activesupport71>=${PORTVERSION}<${PORTVERSION}_99:devel/rubygem-activesupport71 \
+ rubygem-globalid-rails71>=0.3.6:databases/rubygem-globalid-rails71
+
+USES= cpe gem
+
+NO_ARCH= yes
+
+CPE_VENDOR= rubyonrails
+CPE_PRODUCT= active_job
+
+PORTSCOUT= limit:^7\.1\.
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-activejob71/distinfo b/devel/rubygem-activejob71/distinfo
new file mode 100644
index 000000000000..f713bba4aef0
--- /dev/null
+++ b/devel/rubygem-activejob71/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1697330174
+SHA256 (rubygem/activejob-7.1.1.gem) = a565b3d575b1b2750a97ef0a99f81dc13aafba0ecffa10227ea86a04a9fc17e2
+SIZE (rubygem/activejob-7.1.1.gem) = 37376
diff --git a/devel/rubygem-activejob71/pkg-descr b/devel/rubygem-activejob71/pkg-descr
new file mode 100644
index 000000000000..d618ca834e3c
--- /dev/null
+++ b/devel/rubygem-activejob71/pkg-descr
@@ -0,0 +1,16 @@
+Active Job is a framework for declaring jobs and making them run on a variety of
+queuing backends. These jobs can be everything from regularly scheduled
+clean-ups, to billing charges, to mailings -- anything that can be chopped up
+into small units of work and run in parallel.
+
+It also serves as the backend for Action Mailer's #deliver_later functionality
+that makes it easy to turn any mailing into a job for running later. That's one
+of the most common jobs in a modern web application: sending emails outside the
+request-response cycle, so the user doesn't have to wait on it.
+
+The main point is to ensure that all Rails apps will have a job infrastructure
+in place, even if it's in the form of an "immediate runner". We can then have
+framework features and other gems build on top of that, without having to worry
+about API differences between Delayed Job and Resque. Picking your queuing
+backend becomes more of an operational concern, then. And you'll be able to
+switch between them without having to rewrite your jobs.