aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 12:20:54 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 12:58:45 +0000
commit36a53a27af3b9687965405f0cfd28aaae67226d9 (patch)
treeebdc8f503ce6427a0ec461c8c632b7e9a15e5715
parent3594a4bda1c36a211fc91f5ecc6545f174d02505 (diff)
downloadports-36a53a27af3b9687965405f0cfd28aaae67226d9.tar.gz
ports-36a53a27af3b9687965405f0cfd28aaae67226d9.zip
devel/py-about-time: Add py-about-time 4.2.1
about-time is a cool helper for tracking time and throughput of code blocks, with beautiful human friendly renditions.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-about-time/Makefile19
-rw-r--r--devel/py-about-time/distinfo3
-rw-r--r--devel/py-about-time/files/patch-setup.py10
-rw-r--r--devel/py-about-time/pkg-descr2
5 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c008521625ab..f51398d43283 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4147,6 +4147,7 @@
SUBDIR += py-QtPy
SUBDIR += py-RPyC
SUBDIR += py-ZopeUndo
+ SUBDIR += py-about-time
SUBDIR += py-absl
SUBDIR += py-absl-py
SUBDIR += py-adb
diff --git a/devel/py-about-time/Makefile b/devel/py-about-time/Makefile
new file mode 100644
index 000000000000..f33da66df347
--- /dev/null
+++ b/devel/py-about-time/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= about-time
+PORTVERSION= 4.2.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Easily measure timing and throughput of code blocks
+WWW= https://github.com/rsalmei/about-time
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-about-time/distinfo b/devel/py-about-time/distinfo
new file mode 100644
index 000000000000..40829d1322a0
--- /dev/null
+++ b/devel/py-about-time/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1674588042
+SHA256 (about-time-4.2.1.tar.gz) = 6a538862d33ce67d997429d14998310e1dbfda6cb7d9bbfbf799c4709847fece
+SIZE (about-time-4.2.1.tar.gz) = 15380
diff --git a/devel/py-about-time/files/patch-setup.py b/devel/py-about-time/files/patch-setup.py
new file mode 100644
index 000000000000..f86b637ac3dc
--- /dev/null
+++ b/devel/py-about-time/files/patch-setup.py
@@ -0,0 +1,10 @@
+--- setup.py.orig 2022-12-21 04:14:53 UTC
++++ setup.py
+@@ -53,7 +53,6 @@ setup(
+ ],
+ keywords='python track tracker time code blocks monitor statistics analytics'.split(),
+ packages=find_packages(),
+- data_files=[('', ['LICENSE'])],
+ python_requires='>=3.7, <4',
+ install_requires=[],
+ )
diff --git a/devel/py-about-time/pkg-descr b/devel/py-about-time/pkg-descr
new file mode 100644
index 000000000000..3c158097f9de
--- /dev/null
+++ b/devel/py-about-time/pkg-descr
@@ -0,0 +1,2 @@
+about-time is a cool helper for tracking time and throughput of code blocks,
+with beautiful human friendly renditions.