aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2022-05-27 17:13:01 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2022-05-27 17:18:33 +0000
commit3719f5e06662079e80fd9698370ef32a2b75469c (patch)
tree2a50f2166892105d4fbc61918e036ff01f6a8c52
parentf53a8fb84abaea26c771ce81d2928cc2c4015c17 (diff)
downloadports-3719f5e06662079e80fd9698370ef32a2b75469c.tar.gz
ports-3719f5e06662079e80fd9698370ef32a2b75469c.zip
www/gitlab-ce: major update to 15.0.0
Changelog: https://about.gitlab.com/releases/2022/05/22/gitlab-15-0-released/ This commit also includes a not so strict restriction on rails61. This is not tested by gitlab itself, but my tests showed that it should work. This fixes a regression introduced by: 2dd5a4751e19c9a02911d797d67fff6ec9f09da4 PR: 263688
-rw-r--r--www/gitlab-ce/Makefile40
-rw-r--r--www/gitlab-ce/distinfo6
-rw-r--r--www/gitlab-ce/files/extra-patch-Gemfile-kerberos-off11
-rw-r--r--www/gitlab-ce/files/patch-Gemfile50
-rw-r--r--www/gitlab-ce/files/patch-config_gitlab.yml.example26
-rw-r--r--www/gitlab-ce/pkg-message4
6 files changed, 57 insertions, 80 deletions
diff --git a/www/gitlab-ce/Makefile b/www/gitlab-ce/Makefile
index e3722dda28c6..038e9f7b9c11 100644
--- a/www/gitlab-ce/Makefile
+++ b/www/gitlab-ce/Makefile
@@ -1,8 +1,8 @@
# Created by: Torsten Zuehlsdorff <tz@FreeBSD.org>
PORTNAME= gitlab-ce
-PORTVERSION= 14.10.0
-PORTREVISION= 2
+PORTVERSION= 15.0.0
+PORTREVISION= 0
CATEGORIES= www devel
MAINTAINER= mfechner@FreeBSD.org
@@ -17,17 +17,18 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
# see https://gitlab.com/gitlab-org/gitlab/-/issues/350866
MY_DEPENDS= git>=2.32.0:devel/git \
gitaly>=${PORTVERSION}:devel/gitaly \
- gitlab-elasticsearch-indexer>=2.17.0:textproc/gitlab-elasticsearch-indexer \
- gitlab-agent>=14.10.0:net/gitlab-agent \
- gitlab-pages>=1.56.1:www/gitlab-pages \
- gitlab-shell>=13.25.1:devel/gitlab-shell \
+ gitlab-elasticsearch-indexer>=3.0.0:textproc/gitlab-elasticsearch-indexer \
+ gitlab-agent>=15.0.0:net/gitlab-agent \
+ gitlab-metrics-exporter>0:devel/gitlab-metrics-exporter \
+ gitlab-pages>=1.58.0:www/gitlab-pages \
+ gitlab-shell>=14.3.0:devel/gitlab-shell \
gitlab-workhorse>=${PORTVERSION}:www/gitlab-workhorse \
redis>=6.0.14:databases/redis \
yarn>=1.10.0:www/yarn \
gtar>0:archivers/gtar \
bash>0:shells/bash \
- rubygem-rails61>=6.1.4.7<6.1.5:www/rubygem-rails61 \
- rubygem-bootsnap>=1.9.1<1.12:devel/rubygem-bootsnap \
+ rubygem-rails61>=6.1.6.0<6.1.7:www/rubygem-rails61 \
+ rubygem-bootsnap>=1.9.4<1.12:devel/rubygem-bootsnap \
rubygem-responders-rails61>=3.0<4.0:www/rubygem-responders-rails61 \
rubygem-sprockets3>=3.7<3.8:devel/rubygem-sprockets3 \
rubygem-view_component-rails61>=2.50.0<2.51:devel/rubygem-view_component-rails61 \
@@ -35,7 +36,7 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-pg>=1.2.3<2:databases/rubygem-pg \
rubygem-rugged>=1.2<2:devel/rubygem-rugged \
rubygem-grape-path-helpers>=1.7.0<1.8:devel/rubygem-grape-path-helpers \
- rubygem-faraday>=1.0<2:www/rubygem-faraday \
+ rubygem-faraday110>=1.10.0<2:www/rubygem-faraday110 \
rubygem-marginalia>=1.10.0<1.11:databases/rubygem-marginalia \
rubygem-declarative_policy>=1.1.0<1.2:security/rubygem-declarative_policy \
rubygem-devise47-rails61>=4.7.2<4.8:devel/rubygem-devise47-rails61 \
@@ -68,6 +69,7 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-rack-oauth2>=1.16.0<1.17.0:security/rubygem-rack-oauth2 \
rubygem-jwt21>=2.1.0<2.2.0:www/rubygem-jwt21 \
rubygem-gssapi>0:security/rubygem-gssapi \
+ rubygem-timfel-krb5-auth>=0.8<1:security/rubygem-timfel-krb5 \
rubygem-recaptcha>=4.11<5.0:devel/rubygem-recaptcha \
rubygem-akismet>=3.0<4.0:devel/rubygem-akismet \
rubygem-invisible_captcha>=1.1.0<1.2.0:graphics/rubygem-invisible_captcha \
@@ -90,7 +92,7 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-graphiql-rails>=1.8<2:devel/rubygem-graphiql-rails \
rubygem-apollo_upload_server>=2.1.0<2.2:net/rubygem-apollo_upload_server \
rubygem-graphql-docs>=1.6.0<1.7.0:devel/rubygem-graphql-docs \
- rubygem-graphlient>=0.4.0<0.5:devel/rubygem-graphlient \
+ rubygem-graphlient>=0.5.0<0.6:devel/rubygem-graphlient \
rubygem-hashie>=4.1.0:devel/rubygem-hashie \
rubygem-hashie-forbidden_attributes>0:devel/rubygem-hashie-forbidden_attributes \
rubygem-kaminari-rails61>=1.2.1<2.0:www/rubygem-kaminari-rails61 \
@@ -108,9 +110,9 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-google-api-client>=0.33<1:devel/rubygem-google-api-client \
rubygem-unf>=0.1.4<0.2.0:textproc/rubygem-unf \
rubygem-seed-fu>=2.3.7<2.4.0:databases/rubygem-seed-fu \
- rubygem-elasticsearch-model6>=6.1.1<7:textproc/rubygem-elasticsearch-model6 \
- rubygem-elasticsearch-rails6>=6.1.1<7:textproc/rubygem-elasticsearch-rails6 \
- rubygem-elasticsearch-api6>=6.8.2<6.9:textproc/rubygem-elasticsearch-api6 \
+ rubygem-elasticsearch-model713>=7.2<8:textproc/rubygem-elasticsearch-model713 \
+ rubygem-elasticsearch-rails>=7.2<8:textproc/rubygem-elasticsearch-rails \
+ rubygem-elasticsearch-api713>=7.13.3<7.13.4:textproc/rubygem-elasticsearch-api713 \
rubygem-aws-sdk-core>=3<4:devel/rubygem-aws-sdk-core \
rubygem-aws-sdk-cloudformation>=1<2:devel/rubygem-aws-sdk-cloudformation \
rubygem-aws-sdk-s3>=1<2:devel/rubygem-aws-sdk-s3 \
@@ -258,7 +260,7 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-webauthn>=2.3<3:security/rubygem-webauthn \
rubygem-ipaddress>=0.8.3<0.9:net/rubygem-ipaddress \
rubygem-parslet1>=1.8<2:textproc/rubygem-parslet1 \
- rubygem-ipynbdiff>=0.4.5<0.4.6:devel/rubygem-ipynbdiff \
+ rubygem-ipynbdiff>=0.4.7<0.4.8:devel/rubygem-ipynbdiff \
rubygem-parser>=0:devel/rubygem-parser
BUILD_DEPENDS= gem:devel/ruby-gems \
@@ -280,7 +282,7 @@ USE_GITLAB= yes
GL_ACCOUNT= gitlab-org
GL_PROJECT= gitlab-foss
# Find the here: https://gitlab.com/gitlab-org/gitlab-foss/-/tags
-GL_COMMIT= 88da5554d9626377fe7868e956a47a0498e04eb5
+GL_COMMIT= 8a186dedfc1da12270ea77f2673b59fa08f770c1
USERS= git
GROUPS= git
@@ -289,13 +291,6 @@ NO_BUILD= yes
NO_ARCH= yes
-OPTIONS_DEFINE= KERBEROS
-OPTIONS_DEFAULT= KERBEROS
-
-KERBEROS_BUILD_DEPENDS= rubygem-omniauth-kerberos>=0.3.0<0.4.0:net/rubygem-omniauth-kerberos
-KERBEROS_RUN_DEPENDS= rubygem-omniauth-kerberos>=0.3.0<0.4.0:net/rubygem-omniauth-kerberos
-KERBEROS_EXTRA_PATCHES_OFF= ${FILESDIR}/extra-patch-Gemfile-kerberos-off
-
post-patch:
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/config/gitlab.yml.example \
${WRKSRC}/config/puma.rb.example \
@@ -408,6 +403,7 @@ post-install:
@${ECHO_CMD} "@dir(,,770) ${WWWDIR_REL}/tmp/prometheus_multiproc_dir/puma" >> ${TMPPLIST}
@${ECHO_CMD} "@dir(,,770) ${WWWDIR_REL}/tmp/prometheus_multiproc_dir/sidekiq" >> ${TMPPLIST}
@${ECHO_CMD} "@dir(,,770) ${WWWDIR_REL}/tmp/prometheus_multiproc_dir/unicorn" >> ${TMPPLIST}
+ @${ECHO_CMD} "@dir(,,770) ${WWWDIR_REL}/tmp/run" >> ${TMPPLIST}
@${ECHO_CMD} "@dir(,,770) ${WWWDIR_REL}/tmp/sessions" >> ${TMPPLIST}
@${ECHO_CMD} "@dir(,,770) ${WWWDIR_REL}/tmp/sockets" >> ${TMPPLIST}
@${ECHO_CMD} "@dir(,,770) ${WWWDIR_REL}/tmp/sockets/private" >> ${TMPPLIST}
diff --git a/www/gitlab-ce/distinfo b/www/gitlab-ce/distinfo
index 706ad3a60aa0..1b07c68a8324 100644
--- a/www/gitlab-ce/distinfo
+++ b/www/gitlab-ce/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1650541235
-SHA256 (gitlab-org-gitlab-foss-88da5554d9626377fe7868e956a47a0498e04eb5_GL0.tar.gz) = 644ffb2b07313aa8e619556cc58996a476994b4e34bf5ad9af437243c77d7fd4
-SIZE (gitlab-org-gitlab-foss-88da5554d9626377fe7868e956a47a0498e04eb5_GL0.tar.gz) = 102639325
+TIMESTAMP = 1653587888
+SHA256 (gitlab-org-gitlab-foss-8a186dedfc1da12270ea77f2673b59fa08f770c1_GL0.tar.gz) = 0cc40097245e23db5b32428be23d9a1aba40612e3dcfb36efabd26c7c9a7d4a4
+SIZE (gitlab-org-gitlab-foss-8a186dedfc1da12270ea77f2673b59fa08f770c1_GL0.tar.gz) = 102265653
diff --git a/www/gitlab-ce/files/extra-patch-Gemfile-kerberos-off b/www/gitlab-ce/files/extra-patch-Gemfile-kerberos-off
deleted file mode 100644
index 7e641a198558..000000000000
--- a/www/gitlab-ce/files/extra-patch-Gemfile-kerberos-off
+++ /dev/null
@@ -1,11 +0,0 @@
---- Gemfile.orig 2022-01-21 10:23:10 UTC
-+++ Gemfile
-@@ -43,7 +43,7 @@
- gem 'omniauth-github', '~> 1.4'
- gem 'omniauth-gitlab', '~> 1.0.2'
- gem 'omniauth-google-oauth2', '~> 0.6.0'
--gem 'omniauth-kerberos', '~> 0.3.0', group: :kerberos
-+#gem 'omniauth-kerberos', '~> 0.3.0', group: :kerberos
- gem 'omniauth-oauth2-generic', '~> 0.2.2'
- gem 'omniauth-saml', '~> 1.10'
- gem 'omniauth-shibboleth', '~> 1.3.0'
diff --git a/www/gitlab-ce/files/patch-Gemfile b/www/gitlab-ce/files/patch-Gemfile
index 79ad55c4ceef..5bd8578f8516 100644
--- a/www/gitlab-ce/files/patch-Gemfile
+++ b/www/gitlab-ce/files/patch-Gemfile
@@ -1,10 +1,13 @@
---- Gemfile.orig 2022-04-21 11:10:02 UTC
+--- Gemfile.orig 2022-05-20 13:56:26 UTC
+++ Gemfile
-@@ -4,7 +4,7 @@ source 'https://rubygems.org'
+@@ -2,9 +2,9 @@
- gem 'rails', '~> 6.1.4.7'
+ source 'https://rubygems.org'
--gem 'bootsnap', '~> 1.9.1', require: false
+-gem 'rails', '~> 6.1.4.7'
++gem 'rails', '~> 6.1.4'
+
+-gem 'bootsnap', '~> 1.9.4', require: false
+gem 'bootsnap', '~> 1.9', require: false
# Responders respond_to and respond_with
@@ -18,15 +21,7 @@
# API
gem 'grape', '~> 1.5.2'
-@@ -103,7 +103,6 @@ gem 'rack-cors', '~> 1.0.6', require: 'rack/cors'
- gem 'graphql', '~> 1.11.10'
- gem 'graphiql-rails', '~> 1.8'
- gem 'apollo_upload_server', '~> 2.1.0'
--gem 'graphql-docs', '~> 1.6.0', group: [:development, :test]
- gem 'graphlient', '~> 0.4.0' # Used by BulkImport feature (group::import)
-
- gem 'hashie'
-@@ -207,7 +206,7 @@ gem 'gitlab-sidekiq-fetcher', '0.8.0', require: 'sidek
+@@ -207,7 +207,7 @@ gem 'gitlab-sidekiq-fetcher', '0.8.0', require: 'sidek
gem 'fugit', '~> 1.2.1'
# HTTP requests
@@ -35,7 +30,7 @@
# Colored output to console
gem 'rainbow', '~> 3.0'
-@@ -334,118 +333,18 @@ gem 'batch-loader', '~> 2.0.1'
+@@ -334,87 +334,15 @@ gem 'batch-loader', '~> 2.0.1'
gem 'peek', '~> 1.1'
# Snowplow events tracking
@@ -45,12 +40,14 @@
# Metrics
gem 'method_source', '~> 1.0', require: false
-gem 'webrick', '~> 1.6.1', require: false
++gem 'webrick', '~> 1.6', require: false
gem 'prometheus-client-mmap', '~> 0.15.0', require: 'prometheus/client'
gem 'warning', '~> 1.2.0'
-group :development do
- gem 'lefthook', '~> 0.7.0', require: false
+- gem 'rubocop'
- gem 'solargraph', '~> 0.44.3', require: false
-
- gem 'letter_opener_web', '~> 2.0.0'
@@ -109,10 +106,6 @@
- gem 'sigdump', '~> 0.2.4', require: 'sigdump/setup'
-end
-
- group :development, :test, :danger do
- gem 'gitlab-dangerfiles', '~> 3.0', require: false
- end
-
-group :development, :test, :coverage do
- gem 'simplecov', '~> 0.21', require: false
- gem 'simplecov-lcov', '~> 0.8.0', require: false
@@ -120,14 +113,13 @@
- gem 'undercover', '~> 0.4.4', require: false
-end
-
--# Gems required in omnibus-gitlab pipeline
--group :development, :test, :omnibus do
-- # Using a fork until https://github.com/pivotal/LicenseFinder/pull/816 is
-- # resolved. For details, check discussion in
-- # https://gitlab.com/gitlab-org/gitlab/-/merge_requests/74881
-- gem 'gitlab-license_finder', '~> 6.0', require: false
--end
--
+ # Gems required in omnibus-gitlab pipeline
+ group :development, :test, :omnibus do
+ # Using a fork until https://github.com/pivotal/LicenseFinder/pull/816 is
+@@ -423,30 +351,6 @@ group :development, :test, :omnibus do
+ gem 'gitlab-license_finder', '~> 6.0', require: false
+ end
+
-group :test do
- gem 'fuubar', '~> 2.2.0'
- gem 'rspec-retry', '~> 0.6.1'
@@ -155,9 +147,11 @@
gem 'octokit', '~> 4.15'
# Updating this gem version here is deprecated. See:
-@@ -544,3 +443,5 @@ gem 'ipaddress', '~> 0.8.3'
+@@ -545,3 +449,7 @@ gem 'ipaddress', '~> 0.8.3'
gem 'parslet', '~> 1.8'
- gem 'ipynbdiff', '0.4.5'
+ gem 'ipynbdiff', '0.4.7'
+
+gem 'parser'
++gem 'gitlab-dangerfiles'
++
diff --git a/www/gitlab-ce/files/patch-config_gitlab.yml.example b/www/gitlab-ce/files/patch-config_gitlab.yml.example
index fa4c2547f46a..f4da8a7cd063 100644
--- a/www/gitlab-ce/files/patch-config_gitlab.yml.example
+++ b/www/gitlab-ce/files/patch-config_gitlab.yml.example
@@ -1,6 +1,6 @@
---- config/gitlab.yml.example.orig 2022-04-20 10:00:54 UTC
+--- config/gitlab.yml.example.orig 2022-05-20 13:56:26 UTC
+++ config/gitlab.yml.example
-@@ -1175,14 +1175,14 @@ production: &base
+@@ -1160,14 +1160,14 @@ production: &base
# real path not the symlink.
storages: # You must have at least a `default` storage path.
default:
@@ -18,7 +18,7 @@
# archive_permissions: 0640 # Permissions for the resulting backup.tar file (default: 0600)
# keep_time: 604800 # default: 0 (forever) (in seconds)
# pg_schema: public # default: nil, it means that all schemas will be backed up
-@@ -1231,12 +1231,12 @@ production: &base
+@@ -1202,12 +1202,12 @@ production: &base
## GitLab Shell settings
gitlab_shell:
@@ -34,7 +34,7 @@
# Git over HTTP
upload_pack: true
-@@ -1251,13 +1251,13 @@ production: &base
+@@ -1222,13 +1222,13 @@ production: &base
workhorse:
# File that contains the secret key for verifying access for gitlab-workhorse.
# Default is '.gitlab_workhorse_secret' relative to Rails.root (i.e. root of the GitLab app).
@@ -50,7 +50,7 @@
# The URL to the external KAS API (used by the Kubernetes agents)
# external_url: wss://kas.example.com
-@@ -1270,13 +1270,13 @@ production: &base
+@@ -1241,13 +1241,13 @@ production: &base
## GitLab Elasticsearch settings
elasticsearch:
@@ -66,7 +66,7 @@
## Webpack settings
# If enabled, this will tell rails to serve frontend assets from the webpack-dev-server running
-@@ -1297,16 +1297,16 @@ production: &base
+@@ -1268,15 +1268,15 @@ production: &base
# Sidekiq exporter is webserver built in to Sidekiq to expose Prometheus metrics
sidekiq_exporter:
@@ -81,17 +81,15 @@
sidekiq_health_checks:
- # enabled: true
-- # log_enabled: false
- # address: localhost
-- # port: 8082
+- # port: 8092
+ enabled: true
-+ log_enabled: false
+ address: localhost
-+ port: 8082
++ port: 8092
# Web exporter is a dedicated Rack server running alongside Puma to expose Prometheus metrics
# It runs alongside the `/metrics` endpoints to ease the publish of metrics
-@@ -1527,13 +1527,13 @@ test:
+@@ -1496,13 +1496,13 @@ test:
gitaly_address: unix:tmp/tests/gitaly/praefect.socket
gitaly:
@@ -104,6 +102,6 @@
path: tmp/tests/backups
- gitaly_backup_path: tmp/tests/gitaly/_build/bin/gitaly-backup
+ gitaly_backup_path: %%PREFIX%%/share/gitaly/bin/gitaly-backup
- pseudonymizer:
- manifest: config/pseudonymizer.yml
- upload:
+ gitlab_shell:
+ path: tmp/tests/gitlab-shell/
+ authorized_keys_file: tmp/tests/authorized_keys
diff --git a/www/gitlab-ce/pkg-message b/www/gitlab-ce/pkg-message
index 351fa8f1d642..a8d4aa9e47e4 100644
--- a/www/gitlab-ce/pkg-message
+++ b/www/gitlab-ce/pkg-message
@@ -6,7 +6,7 @@ Gitlab was installed successfully.
You now need to set up the various components of Gitlab, so please
follow the instructions in the guide at:
-https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/install/14.10-freebsd.md
+https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/install/15.0-freebsd.md
EOM
type: install
}
@@ -20,7 +20,7 @@ EOM
If you just installed an major upgrade of GitLab, for example you
switched from 14.5.x to 14.6.x, please follow the instructions in the guide at:
-https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/update/14.9-14.10-freebsd.md
+https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/update/14.10-15.0-freebsd.md
If you just installed an minor upgrade of GitLab please follow
the instructions in the guide at: