aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:48:41 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:21:22 +0000
commit372210589f2155f39c1eea062e8f58a62d806c16 (patch)
treed9f9e9b8e02c74db1394bbbf54bfb85292031053
parentc8da16568f528b796a35ad9550df7c5e62c66822 (diff)
downloadports-372210589f2155f39c1eea062e8f58a62d806c16.tar.gz
ports-372210589f2155f39c1eea062e8f58a62d806c16.zip
textproc/py-sphinx-examples: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for dependency and package change
-rw-r--r--textproc/py-sphinx-examples/Makefile7
-rw-r--r--textproc/py-sphinx-examples/files/setup.py37
2 files changed, 3 insertions, 41 deletions
diff --git a/textproc/py-sphinx-examples/Makefile b/textproc/py-sphinx-examples/Makefile
index 4f5ded8643d6..d3b4543287dd 100644
--- a/textproc/py-sphinx-examples/Makefile
+++ b/textproc/py-sphinx-examples/Makefile
@@ -1,5 +1,6 @@
PORTNAME= sphinx-examples
PORTVERSION= 0.0.5
+PORTREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,15 +12,13 @@ WWW= https://github.com/executablebooks/sphinx-examples
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flit-core>=3.5<4:devel/py-flit-core@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=4,1:textproc/py-sphinx@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sphinx-design>=0:textproc/py-sphinx-design@${PY_FLAVOR}
USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
-post-patch:
- @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
-
.include <bsd.port.mk>
diff --git a/textproc/py-sphinx-examples/files/setup.py b/textproc/py-sphinx-examples/files/setup.py
deleted file mode 100644
index fb35dbe8da5a..000000000000
--- a/textproc/py-sphinx-examples/files/setup.py
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/usr/bin/env python
-# setup.py generated by flit for tools that don't yet use PEP 517
-
-from distutils.core import setup
-
-packages = \
-['sphinx_examples']
-
-package_data = \
-{'': ['*'], 'sphinx_examples': ['_static/*', '_static/styles/*']}
-
-package_dir = \
-{'': 'src'}
-
-install_requires = \
-['sphinx>4', 'sphinx-design']
-
-extras_require = \
-{'sphinx': ['sphinx-book-theme',
- 'sphinx-copybutton',
- 'myst-parser',
- 'sphinx-rtd-theme',
- 'furo']}
-
-setup(name='sphinx-examples',
- version='%%PORTVERSION%%',
- description='A lightweight example directive to make it easy to demonstrate code / results.',
- author=None,
- author_email='Executable Book Project <executablebooks@gmail.com>',
- url=None,
- packages=packages,
- package_data=package_data,
- package_dir=package_dir,
- install_requires=install_requires,
- extras_require=extras_require,
- python_requires='>=3.7',
- )