aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-03-29 14:49:13 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-03-30 23:59:52 +0000
commit3737c3aabe0e5a84eaeac0d58214929d68256ec9 (patch)
tree7608f163e5f0523acbfb971db1167e7f0b8ad891
parent56932296b7bc5c29380a4c433c5a9250fb6b4fb5 (diff)
downloadports-3737c3aabe0e5a84eaeac0d58214929d68256ec9.tar.gz
ports-3737c3aabe0e5a84eaeac0d58214929d68256ec9.zip
lang/php80: Mark DEPRECATED
- Upstream support ends on 2023-11-26. See for more details: https://www.php.net/supported-versions.php - Set EXPIRATION_DATE on 2023-12-31 - Use USES=localbase whenever possible - Refactor old php74 codebase Sponsored by: Bounce Experts
-rw-r--r--lang/php80/Makefile8
-rw-r--r--lang/php80/Makefile.ext2
2 files changed, 6 insertions, 4 deletions
diff --git a/lang/php80/Makefile b/lang/php80/Makefile
index b0cca44d4396..d8b0ff01ace6 100644
--- a/lang/php80/Makefile
+++ b/lang/php80/Makefile
@@ -1,6 +1,6 @@
PORTNAME= php80
DISTVERSION= 8.0.28
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= lang devel www
MASTER_SITES= PHP
DISTNAME= php-${DISTVERSION}
@@ -12,6 +12,9 @@ WWW= https://www.php.net/
LICENSE= PHP301
+DEPRECATED= Upstream support ends on 2023-11-26
+EXPIRATION_DATE= 2023-12-31
+
USES+= compiler:c11 tar:xz cpe gnome pkgconfig
CPE_PRODUCT= php
@@ -31,10 +34,9 @@ CONFIGURE_ARGS+= \
--with-openssl \
--with-password-argon2=${LOCALBASE}
-USES+= autoreconf:build ssl
+USES+= autoreconf:build localbase ssl
USE_GNOME= libxml2
-CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${OPENSSLLIB} -lcrypto -lssl
# PR230207 Allow relocations against read-only segments (override lld default)
LDFLAGS_i386= -Wl,-z,notext
diff --git a/lang/php80/Makefile.ext b/lang/php80/Makefile.ext
index 9129e16808d7..0b8d6c30897e 100644
--- a/lang/php80/Makefile.ext
+++ b/lang/php80/Makefile.ext
@@ -3,7 +3,7 @@ COMMENT= The ${PHP_MODNAME} shared extension for php
USES+= php:ext,noflavors
PHP_MODNAME= ${PKGNAMESUFFIX:S/-//}
PHP_VER= 80
-IGNORE_WITH_PHP= 74 81
+IGNORE_WITH_PHP= 81 82
EXTSUBDIR= ${DISTNAME}/ext/${PHP_MODNAME}
WRKSRC= ${WRKDIR}/${EXTSUBDIR}