aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2022-11-07 07:04:05 +0000
committerWen Heping <wen@FreeBSD.org>2022-11-07 07:04:05 +0000
commit37388c6c439662bcf7181a5cc1967ae0c0422717 (patch)
treee59349aafb94dc68106014cf399bdf29985ab2bb
parent76a387dae49fb7ead65e77bbc220b324c75c38ce (diff)
downloadports-37388c6c439662bcf7181a5cc1967ae0c0422717.tar.gz
ports-37388c6c439662bcf7181a5cc1967ae0c0422717.zip
graphics/mupdf: Update to 1.20.3
PR: 258977 Reported by: wen@ Approved by: maintainer
-rw-r--r--graphics/mupdf/Makefile4
-rw-r--r--graphics/mupdf/distinfo6
-rw-r--r--graphics/mupdf/files/patch-Makefile16
-rw-r--r--graphics/mupdf/pkg-plist15
4 files changed, 26 insertions, 15 deletions
diff --git a/graphics/mupdf/Makefile b/graphics/mupdf/Makefile
index 498812978ab2..91573c2bdaec 100644
--- a/graphics/mupdf/Makefile
+++ b/graphics/mupdf/Makefile
@@ -1,7 +1,6 @@
PORTNAME= mupdf
-DISTVERSION= 1.18.0
+DISTVERSION= 1.20.3
DISTVERSIONSUFFIX= -source
-PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= http://www.mupdf.com/downloads/ \
@@ -47,6 +46,7 @@ JS_LIB_DEPENDS= libv8.so:lang/v8
JS_MAKE_ARGS= V8_PRESENT=1 V8LIBS=-lv8
SCROLL_EXTRA_PATCHES= ${FILESDIR}/scroll_hack-platform__x11__pdfapp.c
+BINARY_ALIAS= bash=/bin/sh
PLIST_SUB= SOVERSION=${PORTVERSION}
post-patch:
diff --git a/graphics/mupdf/distinfo b/graphics/mupdf/distinfo
index d5c44f43c968..87e979bad365 100644
--- a/graphics/mupdf/distinfo
+++ b/graphics/mupdf/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1602272959
-SHA256 (mupdf-1.18.0-source.tar.gz) = 8860ea6d01fc3c360ba5e0fa9fede241c6fbb2a73f5215b17a105de409a19266
-SIZE (mupdf-1.18.0-source.tar.gz) = 72621417
+TIMESTAMP = 1667131678
+SHA256 (mupdf-1.20.3-source.tar.gz) = 6b60070f6eec20e8d87d2b5cd22cf49020311a3cf15ee10998e3e5f5f984b1eb
+SIZE (mupdf-1.20.3-source.tar.gz) = 88457290
diff --git a/graphics/mupdf/files/patch-Makefile b/graphics/mupdf/files/patch-Makefile
index db910c2c1df2..f0e900bcb7d8 100644
--- a/graphics/mupdf/files/patch-Makefile
+++ b/graphics/mupdf/files/patch-Makefile
@@ -1,14 +1,18 @@
$OpenBSD: patch-Makefile,v 1.12 2016/12/12 10:54:39 sthen Exp $
---- Makefile.orig 2020-10-10 08:56:03 UTC
+--- Makefile.orig 2022-10-30 12:16:03 UTC
+++ Makefile
-@@ -214,13 +214,15 @@ MUPDF_LIB = $(OUT)/libmupdf.$(SO)
-
- $(MUPDF_LIB) : $(MUPDF_OBJ) $(THIRD_OBJ) $(THREAD_OBJ) $(PKCS7_OBJ)
+@@ -257,17 +257,19 @@ $(THIRD_GLUT_LIB) : $(THIRD_GLUT_OBJ)
+ $(THREAD_LIB) : $(THREAD_OBJ)
+ $(PKCS7_LIB) : $(PKCS7_OBJ)
else
-MUPDF_LIB = $(OUT)/libmupdf.a
--THIRD_LIB = $(OUT)/libmupdf-third.a
+MUPDF_LIB = $(OUT)/libmupdf.so.$(SOVERSION)
+THIRD_LIB = $(OUT)/libmupdf-third.so.$(SOVERSION)
+ LIBS_TO_INSTALL_IN_LIB = $(MUPDF_LIB) $(THIRD_LIB)
+-THIRD_LIB = $(OUT)/libmupdf-third.a
+ ifneq ($(USE_SYSTEM_GLUT),yes)
+ THIRD_GLUT_LIB = $(OUT)/libmupdf-glut.a
+ endif
THREAD_LIB = $(OUT)/libmupdf-threads.a
PKCS7_LIB = $(OUT)/libmupdf-pkcs7.a
@@ -17,6 +21,6 @@ $OpenBSD: patch-Makefile,v 1.12 2016/12/12 10:54:39 sthen Exp $
+ $(LINK_CMD) -shared -Wl,-soname -Wl,libmupdf.so.$(SOVERSION)
$(THIRD_LIB) : $(THIRD_OBJ)
+ $(LINK_CMD) -shared -Wl,-soname -Wl,libmupdf-third.so.$(SOVERSION)
+ $(THIRD_GLUT_LIB) : $(THIRD_GLUT_OBJ)
$(THREAD_LIB) : $(THREAD_OBJ)
$(PKCS7_LIB) : $(PKCS7_OBJ)
- endif
diff --git a/graphics/mupdf/pkg-plist b/graphics/mupdf/pkg-plist
index add778e8a511..18de275c5b51 100644
--- a/graphics/mupdf/pkg-plist
+++ b/graphics/mupdf/pkg-plist
@@ -17,6 +17,7 @@ include/mupdf/fitz/crypt.h
include/mupdf/fitz/device.h
include/mupdf/fitz/display-list.h
include/mupdf/fitz/document.h
+include/mupdf/fitz/export.h
include/mupdf/fitz/filter.h
include/mupdf/fitz/font.h
include/mupdf/fitz/geometry.h
@@ -44,6 +45,7 @@ include/mupdf/fitz/text.h
include/mupdf/fitz/track-usage.h
include/mupdf/fitz/transition.h
include/mupdf/fitz/tree.h
+include/mupdf/fitz/types.h
include/mupdf/fitz/util.h
include/mupdf/fitz/version.h
include/mupdf/fitz/write-pixmap.h
@@ -63,7 +65,6 @@ include/mupdf/pdf/interpret.h
include/mupdf/pdf/javascript.h
include/mupdf/pdf/name-table.h
include/mupdf/pdf/object.h
-include/mupdf/pdf/output-pdf.h
include/mupdf/pdf/page.h
include/mupdf/pdf/parse.h
include/mupdf/pdf/resource.h
@@ -78,14 +79,14 @@ man/man1/mutool.1.gz
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/android-sdk.html
+%%PORTDOCS%%%%DOCSDIR%%/android-library.html
%%PORTDOCS%%%%DOCSDIR%%/artifex-logo.png
%%PORTDOCS%%%%DOCSDIR%%/building.html
%%PORTDOCS%%%%DOCSDIR%%/coding-overview.html
%%PORTDOCS%%%%DOCSDIR%%/coding-progressive.html
%%PORTDOCS%%%%DOCSDIR%%/coding-style.html
+%%PORTDOCS%%%%DOCSDIR%%/ecosystem.css
%%PORTDOCS%%%%DOCSDIR%%/ecosystem.html
-%%PORTDOCS%%%%DOCSDIR%%/ecosystem.png
%%PORTDOCS%%%%DOCSDIR%%/examples/bbox-device.js
%%PORTDOCS%%%%DOCSDIR%%/examples/create-thumbnail.js
%%PORTDOCS%%%%DOCSDIR%%/examples/draw-device.js
@@ -103,16 +104,22 @@ man/man1/mutool.1.gz
%%PORTDOCS%%%%DOCSDIR%%/examples/pdf-trace.js
%%PORTDOCS%%%%DOCSDIR%%/examples/trace-device.js
%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/library.html
%%PORTDOCS%%%%DOCSDIR%%/manual-mupdf-gl.html
%%PORTDOCS%%%%DOCSDIR%%/manual-mutool-clean.html
%%PORTDOCS%%%%DOCSDIR%%/manual-mutool-convert.html
%%PORTDOCS%%%%DOCSDIR%%/manual-mutool-create.html
%%PORTDOCS%%%%DOCSDIR%%/manual-mutool-draw.html
%%PORTDOCS%%%%DOCSDIR%%/manual-mutool-extract.html
+%%PORTDOCS%%%%DOCSDIR%%/manual-mutool-info.html
%%PORTDOCS%%%%DOCSDIR%%/manual-mutool-merge.html
+%%PORTDOCS%%%%DOCSDIR%%/manual-mutool-pages.html
+%%PORTDOCS%%%%DOCSDIR%%/manual-mutool-poster.html
%%PORTDOCS%%%%DOCSDIR%%/manual-mutool-run.html
%%PORTDOCS%%%%DOCSDIR%%/manual-mutool-show.html
+%%PORTDOCS%%%%DOCSDIR%%/manual-mutool-sign.html
%%PORTDOCS%%%%DOCSDIR%%/manual-mutool-trace.html
+%%PORTDOCS%%%%DOCSDIR%%/mutool.html
%%PORTDOCS%%%%DOCSDIR%%/style.css
-%%PORTDOCS%%%%DOCSDIR%%/template.html
%%PORTDOCS%%%%DOCSDIR%%/thirdparty.html
+%%PORTDOCS%%%%DOCSDIR%%/viewers.html